
ORACLE BUSINESS INTELLIGENCE APPLICATIONS INSTALLATION AND CONFIGURATION GUIDE

Oracle Business Intelligence Applications Installation and 
Configuration Guide

Version 7.9.6.3 Extension Pack



Contents
Preface........................................................................................................................................................4

Audience.................................................................................................................................................4

Documentation Accessibility..................................................................................................................4

Accessibility of Code Examples in Documentation...........................................................................5

Accessibility of Links to External Web Sites in Documentation........................................................5

TTY Access to Oracle Support Services.............................................................................................5

Related Documents.................................................................................................................................5

Conventions............................................................................................................................................5

Overview....................................................................................................................................................6

Pre-Requisites............................................................................................................................................6

Installation..................................................................................................................................................7

Preparing the Staging Area ....................................................................................................................7

Backing up the current installation.........................................................................................................7

Installing Informatica Workflows...........................................................................................................8

Configuring Informatica Workflows......................................................................................................9

Configuring the Helper File................................................................................................................9

Assigning the Integration Service.....................................................................................................10

Installing the DAC Container...............................................................................................................11

Configuring the DAC Container...........................................................................................................11

Creating tables in the Data Warehouse.............................................................................................11

Creating References..........................................................................................................................13

Disabling Tasks and Subject Areas...................................................................................................15

Building the Execution Plan.............................................................................................................16
Verifying the Source System Parameters..........................................................................................17



Configuring the RPD and Webcatalog Objects....................................................................................19

RPD Merge.......................................................................................................................................19

9)Click on Finish to Complete the Process.......................................................................................24

Catalog Merge...................................................................................................................................24



Preface
Oracle Business Intelligence Applications are comprehensive prebuilt solutions that deliver 
pervasive intelligence across an organization, empowering users at all level, from front line 
operational users to senior management, with the key information they need to maximize 
effectiveness. Intuitive and role-based, these solutions transform and integrate data from a 
range of enterprise sources, including Siebel, Oracle, PeopleSoft, SAP, and corporate data 
warehouses, into actionable insight that enables more effective actions, decisions, and processes.
Oracle Business Intelligence Applications are built on Oracle Business Intelligence Suite 
Enterprise Edition, a comprehensive next-generation BI and analytics platform. 
This guide explains how to install, set up, configure, and customize Oracle Business Intelligence 
Applications Version 7.9.6.3 Extension Pack.  
Oracle recommends reading Oracle Business Intelligence Applications Release Notes before 
installing or using Oracle Business Intelligence Applications. The Oracle Business Intelligence 
Applications Release Notes are available:

• On the Oracle Business Intelligence Applications CD-ROM.

• On the Oracle Technology Network at 
http://www.oracle.com/technology/documentation/bi_apps.html     (to register for a free ac-
count on the Oracle Technology Network, go to http://www.oracle.com/technology/about/in-
dex.html).

Audience
This document is intended for BI managers and implementers of Oracle Business Intelligence 
Applications.

Documentation Accessibility
Our goal is to make Oracle products, services, and supporting documentation accessible, with 
good usability, to the disabled community. To that end, our documentation includes features 
that make information available to users of assistive technology. This documentation is 
available in HTML format, and contains markup to facilitate access by the disabled community. 
Accessibility standards will continue to evolve over time, and Oracle is actively engaged with 
other market-leading technology vendors to address technical obstacles so that our 
documentation can be accessible to all of our customers. For more information, visit the Oracle 
Accessibility Program Web site at http://www.oracle.com/accessibility/.

Accessibility of Code Examples in Documentation
Screen readers may not always correctly read the code examples in this document. The 
conventions for writing code require that closing braces should appear on an otherwise empty 
line; however, some screen readers may not always read a line of text that consists solely of a 
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bracket or brace.

Accessibility of Links to External Web Sites in Documentation
This documentation may contain links to Web sites of other companies or organizations that 
Oracle does not own or control. Oracle neither evaluates nor makes any representations 
regarding the accessibility of these Web sites.

TTY Access to Oracle Support Services
Oracle provides dedicated Text Telephone (TTY) access to Oracle Support Services within the 
United States of America 24 hours a day, 7 days a week. For TTY support, call 800.446.2398. 
Outside the United States, call +1.407.458.2479.

Related Documents
For more information, see the following documents in the Oracle Business Intelligence 
Applications Release 7.9.6.3 Extension Pack documentation set (available at 
http://www.oracle.com/technology/documentation/bi_apps.html):

• Oracle Business Intelligence Applications Release Notes for Oracle 7.9.6.3 Extension Pack

• Oracle Manufacturing Analytics Users Guide

• Oracle Enterprise Asset management Analytics Users Guide

Conventions
The following text conventions are used in this document:

• Boldface type indicates graphical user interface elements associated with an action, or terms 
defined in text or the glossary.

• Italic type indicates book titles, emphasis, or placeholder variables for which you supply 
particular values.

• Monospace type indicates commands within a paragraph, URLs, code in examples, text that 
appears on the screen, or text that you enter.

Overview
This document describes the steps to Install and configure the Oracle BI Applications 7.9.6.3 
Extension pack alongside a new or existing implementation of Oracle BI Applications 7.9.6.1, 
7.9.6.2 or 7.9.6.3. The instructions contained in this document describes how to create the data 
warehouse schema, install the Informatica mappings, install and configure the DAC containers 
and merge instructions for the Oracle Business Intelligence Enterprise Edition (OBIEE) RPD. 
This document only covers the installation and configuration specifics for the Oracle BI 
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Applications 7.9.6.3 Extension Packs, for all other related installation and configurations 
questions refer to the Oracle BI Applications Configuration Guide for Informatica PowerCenter 
Users for the associated BI Applications version which can be obtained on OTN (link) or via the 
original software Media Pack provided by Oracle.
The Manufacturing Module in the Oracle 7.9.6.3 Extension pack is pre-integrated with Oracle E-
Business Suite Manufacturing and the EAM module in Oracle 7.9.6.3 Extension pack is pre-
integrated with Oracle E-Business Suite Enterprise Asset Management (EAM) module, as well 
as IBM Maximo 6.5. 

Pre-Requisites
In order to install the Oracle 7.9.6.3 Extension pack at least one module of Oracle BI 
Applications versions 7.9.6.1 to 7.9.6.3 has to be installed. 

Downloading the Extension Pack 
The Oracle Business Intelligence Applications 7.9.6.3 Extension Pack can be downloaded from 
the Oracle eDelivery site. On downloading, you will get a zip file by name 
OracleBIA_7963_Extn_Packs.zip. Extracting the zip will give three zip files, each corresponding 
to extensions for Oracle BI Applications Versions 7961, 7962 and 7963.
For installation, please use the zip file that corresponds to the version of Oracle BI Applications 
your organization has deployed.  Oracle recommends that all new deployments use version 
7.9.6.3.

OBIA Version Extension Pack Zip

7961 Oracle7961_Extn_Pack.zip

7962 Oracle7962_Extn_Pack.zip

7963 Oracle7963_Extn_Pack.zip
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Installation

Preparing the Staging Area
Extract the zip that corresponds to your Oracle BI Applications version using a unzip utility. 
You will get a folder called ‘Oracle 796x_Extn_Pack’ with the following folder structure. 
Oracle_796x_Extn_Pack

→ Informatica
→ SDE_ORAR12_Adaptor_Extn
→ SDE_ORA11510_Adaptor_Extn
→ SDE_MAXIMO65_Adaptor_Extn
→ SILOS_Extn
→ PLP_Extn

→ DAC
→ OracleR12Extn .zip
→ Oracle11510Extn.zip
→ Maximo 65 Extn.zip

→ RPD
→ OracleBIAnalyticsApps_Extn.rpd (for 7961 and 7962) (or)
→ EnterpriseBusinessAnalytics_Extn.rpd (for 7963)

→ Webcatalog
→ EnterpriseBusinessAnalytics_Extn.webcat

Unless otherwise noted in this document, the R12 Informatica and DAC folders contain objects 
that are compatible with Oracle EBS R12, R12.1.1, R12.1.2 and R12.1.3

Backing up the current installation
This section provides backup steps you need to perform before you begin the installation pro-
cess for the Extension pack.

• Rename and copy into a different location your current repositories, Presentation Cata-
log (formerly known as the Web Catalog) and DAC installation folder from your existing 
environment. The file names and locations listed below represent the standard names 
and locations of files that shipped with Oracle BI Applications.

• When you backup the DAC Repository, you export the DAC metadata, in XML format 
(using the DAC's Export tool), into a different database, which can be used later as a ref-
erence. For instructions, see the Oracle Business Intelligence Data Warehouse Adminis-
tration Console User's Guide
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Type Name Location

DAC metadata
Repository

*.drf DAC_HOME\DAC\export

Oracle BI repository
(formerly called
Analytics repository)

OracleBIAnalyt
icsApps.rpd

OracleBI\Repository (10g i.e 7961 /7962)
ORACLE_INSTANCE\bifoundation\OracleBIServer
Component\coreapplication_obis1\repository (11g 
i.e 7963)

Informatica
Repository

Oracle_BI_DW
_Base.rep

INFA_HOME\server\infa_shared\Backup

Presentation Catalog
(formerly called Web
Catalog)

<file_name>.we
bcat

OracleBIData\web\catalog (10g i.e 7961 /7962)
ORACLE_INSTANCE\bifoundation\OracleBIPresen
tationServicesComponent\coreapplication_obips1\c
atalog (11g i.e 7963)

DAC installation
Folder

DAC DAC_HOME\DAC

Installing Informatica Workflows
• Open the repository in which Oracle BI Applications 796x has been installed. The 

repository can be opened through the Informatica Repository Manager tool 

(pmrepmgr.exe) 

• Create new Informatica folders in the repository with names as below
→ SDE_ORAR12_Adaptor_Extn
→ SDE_ORA11510_Adaptor_Extn
→ SDE_MAXIMO65_Adaptor_Extn
→ SILOS_Extn
→ PLP_Extn

• Verify the code page of the Informatica Repository. The extension XMLs are shipped 

with code page of ‘UTF-8’. If the code page of your repository is different from the above, 

please change the code page of the extension XML’s to the required code page. You can 

do it by editing the REPOSITORY tags of the extension XMLs.

E.g. Open the extension XMLs and in the Repository tag mentioned below the CODEPAGE 

Attribute need to be   modified to the required code page.
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<REPOSITORY NAME="BIApps_QA" VERSION="181" CODEPAGE="UTF-8" 

DATABASETYPE="Oracle">

• Select 'Repository → Import Objects' option. Import the xmls from the staging into the 

respective folders created with the same names in the repository.  Please check in the 

XMLs during the import process. 

For E.g.  XMLs in Staging Area->Oracle_796x_Extn_Pack->Informatica->SILOS_Extn 
should be imported to the SILOS_Extn folder created in Informatica.

• In the Import Dialog Box that follows, you will be presented with a list of folders for 

importing. Please choose only the folders with the _Extn extension

• While importing, you will encounter conflicts for Default Session Configurations and 

Reusable Transformations like Mapplet, Lookups etc which are referred from Oracle BI 

Applications folders. Please check the ‘Reuse’ box for resolving these conflicts 

Configuring Informatica Workflows

Configuring the Helper File

Extract the QA_HELPER file from Staging Area-> Oracle_796x_Extn_Pack->Informatica-
>Config_Files folder and add values for organization_id, collection_element and target_column 
fields.  After adding values save it in the following location in the Informatica server.

INFA_HOME/server/infa_shared/SrcFiles 

Assigning the Integration Service

Open Workflow manager to assign an Integration service to the workflows imported into the 
Extension folders. You can reuse the integration services created for Oracle BI Applications. 

Close all the folders in the repository. Select Assign Integration Services from the Service Menu. 
In the resulting window, map the folders imported to the appropriate integration service and 
click ‘Assign’.  The following folders need to be mapped to the appropriate integration services.

→ SDE_ORAR12_Adaptor_Extn
→ SDE_ORA11510_Adaptor_Extn
→ SDE_MAXIMO65_Adaptor_Extn
→ SILOS_Extn
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→ PLP_Extn
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Installing the DAC Container
As part of implementing Oracle BI Apps 796x, you would have created a custom container to 
hold customizations done on Oracle BI Applications. If this is the first time Oracle BI 
Applications is being implemented, please create a new container as a copy of the source 
system container that you wish to implement. This is called the ‘Production’ container. The 
container that is shipped as part of Oracle796x Extension pack is termed as the ‘Extension’ 
container.
The DAC sub folder under the Oracle796x_Extn folder in the Staging Area contains Extension 
Containers. These containers contain extracts from 

• Manufacturing and EAM for R12 and 11510 versions of Oracle E-Business suite 
• EAM for IBM Maximo 65.

Pick the appropriate extension container depending on the version of Oracle E-Business Suite 
and/or the IBM Maximo that you are running.
Go To Tools -> DAC Repository Management -> Import
Import the Extension Container
Select ‘Logical’ check box only while importing the Extension Container
Now, the repository should have the _Extn container in addition to the other containers.

Configuring the DAC Container

Creating tables in the Data Warehouse
Navigate to Tools->ETL Management -> Configure and select the option Create/Upgrade Data 
Warehouse Tables.
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In the screen that follows, provide the name of the Extension Container and the data warehouse 
connection details.
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Creating References
Switch to the production container and create references for the following objects from the 
Extension Container as shown in the below screenshot.

• Reference all the Source system folders 
• Reference all Table definitions.

o
• Reference all Index definitions 
• Reference all the Tasks

o After referencing, the table types of source tables for tasks will be missing. Please 
refer the Extension container for the correct table types and change accordingly. 
Here is the navigation
 Go to Tasks –> Sub tab Source Tables  Select Type  

• Provide referential integrities for the Extension tables by referring the Extension 
container manually.  

13



• If you are implementing the R12 Extension Container, please create an additional  task 
group ‘TASK_GROUP_Extract_MfgResource’ in the merged container with the following 
tasks as child tasks and dependency order as 1 and 2 respectively.  Set ‘Truncate Always’ 
option for this Task group. 

1. SDE_ORA_MfgResource
2. SDE_ORA_MfgResourceDimension_CRResource_Process

• Modify the seeded Task group ‘TASK_GROUP_Extract_CodeDimension’ in the 
Production container and add the following tasks as child tasks.

1. SDE_ORA_CodeDimension_KanbanCardStatus
2. SDE_ORA_CodeDimension_KanbanCardType
3. SDE_ORA_CodeDimension_KanbanDocumentType
4. SDE_ORA_CodeDimension_KanbanErrorCode
5. SDE_ORA_CodeDimension_KanbanSourceType
6. SDE_ORA_CodeDimension_KanbanSupplyStatus

• Reference all the Subject areas and Assemble them individually

Disabling Tasks and Subject Areas
Please disable/inactive the un-licensed subject areas and tasks by referring to the matrix below
Subject Area Requires Oracle BI Applications License

Manufacturing-Costing
Manufacturing-Discrete
Manufacturing-Discrete Quality
Manufacturing-Inventory
Manufacturing-Kanban
Manufacturing-Planning

Manufacturing Analytics

Asset Maintenance Enterprise Asset Management Analytics

Table Name DAC Task Name

Requires 
Oracle BI 
Applications 
License

 W_PURCH_ORDER_F SIL_PurchaseOrderFact, SIL_PurchaseOrder-
Fact_SoftDelete, SDE_ORA_PurchaseOrder-
Fact, SIL_PurchaseOrderFact_IdentifyDelete, 
SDE_ORA_PurchaseOrderFact_Primary

Procurement 
and Spend 
Analytics
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W_PURCH_SCHEDULE_LINE_
F

SIL_PurchaseScheduleLinesFact, SIL_Pur-
chaseScheduleLinesFact_SoftDelete, 
SDE_ORA_PurchaseScheduleLinesFact, 
SIL_PurchaseScheduleLinesFact_IdentifyDe-
lete, 
SDE_ORA_PurchaseScheduleLinesFact_Pri
mary

Procurement 
and Spend 
Analytics

W_SALES_ORDER_LINE_F PLP_SalesOrderLinesAggregate_Load,
PLP_SalesOrderLinesAggregate_Derive,
PLP_SalesOrderLinesFact_Customers_First_
Order_Update,
PLP_SalesOrderLinesFact_InvoicedQty_Up-
date,
PLP_SalesOrderLinesFact_RollupAmt_Up-
date,
PLP_SalesOrderLinesFact_ShippedQty_Up-
date,
SIL_SalesOrderLinesFact,
SIL_SalesOrderLinesFact_SoftDelete,
SDE_ORA_SalesOrderLinesFact,
SIL_SalesOrderLinesFact_IdentifyDelete,
SDE_ORA_SalesOrderLinesFact_Primary,
PLP_SalesOrderLinesAggregate_Derive_Pos
tLoadImage,
SIL_SalesOrderLinesAggregate_Derive_Pre-
LoadImage,
SIL_SalesOrderLinesAggregate_Derive_PreS
oftDeleteImage

Supply Chain 
and Order 
Management 
Analytics

Building the Execution Plan
Build a new Execution Plan with the Subject Areas from existing execution plan and the 
extension subject areas. After generating parameters, set appropriate values for parameters 
during the build.
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Verifying the Source System Parameters
Oracle BI Applications 7.9.6.3 Extension Pack requires common dimensions like Organization, 
Product and Time to be loaded. For more details please refer to the corresponding version of 
the Oracle BI Applications Configuration Guide for Informatica PowerCenter Users that can be 
obtained on OTN (link).
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Please ensure that the following Task level parameters are set for following tasks
Task Parameter

SDE_ORA_ProductDimension Master_org

SIL_DayDimension START_DATE, END_DATE
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Configuring the RPD and Webcatalog Objects

RPD Merge
An RPD merge is only required for adding Oracle BI Applications 7.9.6.3 Extension Pack release 
to a customized BI applications implementation.  If this is the case please follow the instructions 
below.  Otherwise it is advised that you use the RPD that has been shipped in the Oracle BI Ap-
plications 7.9.6.3 Extension Pack as your Production RPD.

 A three-way merge should be performed to integrate the contents of the Production RPD and 
the Extension RPD. The instructions to do a three-way merge are given below.

For  7961 and 7962 (10g  10.1.3.x.x)

1) In the BI Administration tool, open the OracleBIAnalyticsApps_Extn.rpd.
2) Select the menu File > Merge
3) Select the Original Repository (BI Apps seeded RPD). This is the RPD that was extracted 

from the Oracle Installer for 796x.
4) Once the original repository is selected, the Merge Repositories window appears. Note 

that the OracleBIAnalyticsApps_796_Original repository is reflected in the Original 
repository field. Also, note that the changes made in the current repository are listed.

5) Click the Select button beside the Modified repository field to select the modified RPD 
file [ Production RPD]
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6) Now click the Select button beside the “Save merged repository as” field, to give the 
desired name for the merged repository which will be created as a result of this merge 
process.

7)  You can make the decision to select the changes in the current repository or modified 
repository appropriately. Scroll to the right to see the Decision column and select 
Modified or Current from the drop down list.
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For  7963 (11g 11.1.1.6.2)

1) In the BI Administration tool, open the OracleBIAnalyticsApps_Extn.rpd.(7963_Extn)
2) Select the menu File > Merge
      A screen will appear asking Original Modified and Merged Repository Details as shown below
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3) Select Merge Type as Full Repository Merge, Equalize During the Merge (Optional)
4) Select the Original Repository (BI Apps seeded RPD). This is the RPD that was extracted from the 
Oracle Installer for 7963.
5) Select Modified Repository field to select the modified RPD file [Production RPD]
6) Provide desired name for the merged repository which will be created as a result of this merge process. 
Click Next
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7) You can make the decision to select the changes in the current repository or modified repository 
appropriately. 
Scroll to the right to see the Decision column and select Modified or Current from the drop down list.

8) Click on Finish to Complete the Process
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Catalog Merge

 A webcatalog merge is required only for a customized BI applications implementation. 
Otherwise it is advised that you use the Webcatalog that has been shipped in the Oracle BI 
Applications 7.9.6.3 Extension Pack. Here are the steps for Catalog Merge.

1) Choose File->Open Catalog to open the Production catalog in offline mode.

2) Open  the  Extension  Web  Catalog  from  the  Staging  Area  in  offline  mode  using  the 
Catalog Manager.

3) Copy the folders from the Extension Web Catalog into the Production Web Catalog.

Copyright ©2009, 2012, Oracle and / or its affiliates. All rights reserved. http://www.oracle.com
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