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About This Guide

This document provides instructions on how to configure the Oracle ZFS Storage Appliance Simulator.
The Simulator introduces you to the power and simplicity of the Oracle ZFS Storage Appliance software
using VirtualBox or VMware Workstation and is identical in every way to the appliance version, with the
exception of clustering.

Simulator Configuration

Use the following procedures to configure the Simulator:

1. “First Steps” on page 2 - Complete all prerequisites before beginning configuration.
2. Set up the Simulator virtual machine using one of the following procedures:

■ “VirtualBox Setup” on page 4
■ “VMware Workstation Setup” on page 6

3. “Configuring the Simulator” on page 8 - Complete basic configuration in your browser.
4. As needed, refer to these additional procedures:

■ “Configuring Bridged Networking and Services” on page 13 - Enable access to the Simulator
from other machines on your network.

■ “Sharing a SMB Filesystem” on page 15 - Set up a simple filesystem share over SMB.

First Steps

Before you begin the setup and configuration procedures, complete the following prerequisite steps.

1. Ensure that your host system (laptop, desktop, server) has sufficient resources to
support the Simulator's configuration of 2560 megabytes of memory and 125 gigabytes of
dynamically allocated disk space.

2. Check that your CPU has 64-bit capability and supports hardware virtualization; to do so,
refer to your system information or the documentation for your hardware manufacturer.

3. Check that either Intel Virtualization Technology (VT-x) or Advanced Micro Devices
Virtualization (AMD-V) is enabled on your system.
Often these settings are within the BIOS, sometimes under chipset, processor, security, power, or advanced
settings. The BIOS menu is usually accessible during reboot by pressing specific keys. Your system may
require a BIOS update for these settings to be available. For Intel-based Apple products, you might need to
install the latest EFI firmware update. For details, refer to your system information or the documentation for
your hardware manufacturer.

4. Download and decompress the latest Oracle ZFS Storage Simulator for your virtual
machine from the Oracle Technical Network (http://www.oracle.com/technetwork/server-
storage/sun-unified-storage/downloads/sun-simulator-1368816.html).

5. Download and install the latest VirtualBox or VMware Workstation package that is
compatible with your operating system:

■ VirtualBox package and extension pack (minimum version 4.2.12): https://www.virtualbox.org/.
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■ VMware Workstation package (minimum version 10): https://www.vmware.com.

Read any warnings and accept any messages to complete installation.

6. Verify that a host-only adapter is defined.
After you install VirtualBox or VMware Workstation, a host-only adapter is defined by default. You can
use this adapter for the host-only network used during initial Simulator configuration. For details about
host-only networks, refer to the VirtualBox documentation (https://www.virtualbox.org/manual) or the
VMware Workstation documentation (http://pubs.vmware.com/workstation-12/index.jsp).

a.   Virtual Box: Navigate to File > Preferences > Network > Host-only Networks.

If there is no host-only adapter, click the add item icon  to add one as shown below.

b.   VMware Workstation: Navigate to Edit > Virtual Network Editor and select Host-only.
If there is no host-only adapter, click Add Network to add one.

7. In the current window, ensure that the DHCP server is set up and enabled:

■ VirtualBox: Click the tool icon .
Enable the DHCP server after making changes to the configuration information displayed in the dialog
box.
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■ VMware Workstation: Click DHCP Settings.
Make changes as needed to the configuration information provided in the dialog box.

8. If you are on a virtual private network (VPN), ensure that it allows access to the local host
network. If it does not, you may not be able to access the Simulator while on the VPN.

9. Set up your virtual machine by completing one of the following tasks:

■ “VirtualBox Setup” on page 4
■ “VMware Workstation Setup” on page 6

VirtualBox Setup

Complete the following steps to set up the Oracle ZFS Storage Appliance Simulator in VirtualBox.

1. Start VirtualBox and navigate to File > Import Appliance.

2. Navigate to and choose the Simulator OVF file and click Next.

3. If desired, change any of the default settings, including the name. The RAM setting must be
at least 2560 megabytes, which is the default.
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4. Click Import.

5. Select the Simulator in VirtualBox and go to Settings > System > Acceleration. Verify that
"Enable VT-x/AMD-V" is checked.
If hardware virtualization is not enabled on your system, you will not be able to access the Acceleration tab;
see “First Steps” on page 2.

6. To start the virtual machine, click Start. The boot screen appears.

If you get the following error message, click Close VM, and enable VT-x/AMD-V as described in “First
Steps” on page 2. Then restart this step.

7. Press any key to begin configuration. The Configuration screen appears.

8. Use the arrow keys on your keyboard to navigate among the fields on this screen.
Verify that the IP address and IP netmask match the default host-only network. If you modified any values
in the host-only configuration settings in VirtualBox, you may see different values entered on this screen.

Complete the remaining fields:

■ Host Name: Any name you want
■ DNS Domain: localdomain
■ Default Router: Copy the IP address, but use 1 as the final octet (example: 192.168.56.1)
■ DNS Server: Copy the IP address, but use 1 as the final octet (example: 192.168.56.1)
■ Password: Any password you want

9. Press the ESC key followed by the 1 key to confirm these settings.
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10. Wait until the screen provides you with two URLs to use for subsequent configuration and
administration: one with the hostname you specified and one with an IP address.

You will use the IP address URL to configure the Simulator in the next section. You cannot access the
Simulator using the hostname URL without more advanced configuration, as described in “Configuring
Bridged Networking and Services” on page 13. You must configure the Domain Name Server (DNS) to
map the hostname to its corresponding IP address.

VMware Workstation Setup

Complete the following steps to set up the Oracle ZFS Storage Appliance Simulator in VMware
Workstation.

1. Start VMware Workstation and navigate to File > Open.

2. Enter a name for the virtual machine, then navigate to and select the Simulator OVA file
and click Import.

3. If desired, change any of the default settings, including the name. The RAM setting must be
at least 2560 megabytes, which is the default.

4. Right-click the virtual machine name, and select Settings.

5. Select the Hardware tab, then click Processors. Under Virtualization engine, select Intel VT-x
or AMD-V as the preferred mode.
If hardware virtualization is not enabled on your system, see “First Steps” on page 2.

6. To start the virtual machine, click Power on this virtual machine. The boot screen appears.

Oracle® ZFS Storage Appliance Simulator Quick Start Guide 6



If you get the following error message, click OK, and enable VT-x/AMD as described in “First
Steps” on page 2. Then restart this step.

7. Press any key to begin configuration. The Configuration screen appears.

8. Use the arrow keys on your keyboard to navigate among the fields on this screen.
Verify that the IP address and IP netmask match the default host-only network. If you modified any values
in the host-only configuration settings in VMware Workstation, you may see different values entered on this
screen.

Complete the remaining fields:

■ Host Name: Any name you want
■ DNS Domain: localdomain
■ Default Router: Copy the IP address, but use 1 as the final octet (example: 192.168.19.1)
■ DNS Server: Copy the IP address, but use 1 as the final octet (example: 192.168.19.1)
■ Password: Any password you want

9. Press the ESC key followed by the 1 key to confirm these settings.

10. Wait until the screen provides you with two URLs to use for subsequent configuration and
administration: one with an IP address and one with the hostname you specified.
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You will use the IP address URL to configure the Simulator in the next section. You cannot access the
Simulator using the hostname URL without more advanced configuration, as described in “Configuring
Bridged Networking and Services” on page 13. You must configure the Domain Name Server (DNS) to
map the hostname to its corresponding IP address.

Configuring the Simulator

Complete basic Simulator configuration in the Browser User Interface (BUI) using the following steps.

Note - The Simulator’s default configuration, described here, uses a host-only network, meaning that the
Simulator can only be accessed from the computer on which it is running. You can later enable access to
the Simulator from other machines on your network, as described in “Configuring Bridged Networking and
Services” on page 13.

1. Open a web browser and navigate to the URL with the IP address provided in the last step
of “VirtualBox Setup” on page 4 or “VMware Workstation Setup” on page 6.
Accept the web browser security warning. Then the login screen appears.

2. Type the username root and the password you created in the configuration screen, then
click LOGIN. The Welcome screen appears.
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Note - At the top right of every BUI page is a HELP link to the Simulator online help, which is context-
sensitive and provides detailed information about each configuration step.

3. Click START to begin setup.

4. On the Configure Networking screen, click COMMIT to continue.

5. On the Configure DNS screen, either configure DNS, or click COMMIT to skip this screen.
If needed, later you can set these parameters to map the hostname to its corresponding IP address as
described in “Configuring Bridged Networking and Services” on page 13.

6. On the Configure Time screen, either configure the Network Time Protocol (NTP), or click
COMMIT to skip this screen.
If needed, later you can synchronize the appliance time with a NTP server, as described in “Configuring
Bridged Networking and Services” on page 13.
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7. Click COMMIT to skip the Configure Name Services screen.
Later, you can configure NIS, LDAP, and Active Directory for user access control, as described in
“Configuring Bridged Networking and Services” on page 13.

8. Create a storage pool by clicking the add item icon  next to Available Pools.

a.   Name the new storage pool and click APPLY.
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b.   Use the drop-down list next to Data Devices to allocate storage to the pool, then click
COMMIT.

c.   Select a data profile based on your business needs. Click COMMIT to configure the pool.

d.   The Configure Storage page is redisplayed with a description of the new pool.
Click COMMIT to continue.
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9. On the Registration & Support screen, select LATER and click OK to confirm.
When setting up a real Oracle ZFS Storage Appliance, you use this screen to register the appliance, enable
Phone Home support, and configure web proxies required to connect to the Oracle support site.

10. The final configuration screen appears with links to further documentation.

You can return to the configuration wizard at any time by navigating to Maintenance > System and
clicking INITIAL SETUP. Current settings are not changed unless you explicitly change them. User data on
the storage pool (including projects and shares) is not affected.
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11. To close the Simulator, click LOGOUT near the top of the screen and close the VM command
window.

12. Next, power off the Simulator using the appropriate instructions:

a.   VirtualBox: Navigate to Machine > Close.
For details about save and power-off options, refer to the VirtualBox documentation (http://www.
virtualbox.org/wiki/Documentation).

b.   VMware Workstation: Navigate to VM > Power > Shut Down Guest.
For details about save and power-off options. refer to the VMware Workstation documentation (http:
//pubs.vmware.com/workstation-12/index.jsp).

Configuring Bridged Networking and Services

When first installed, the Oracle ZFS Storage Appliance Simulator can only be accessed from the computer
on which it is running. When needed, you can enable access to the Simulator from other machines on your
network by setting up bridged networking using the following steps.

For detailed information about bridged networking and limitations for your operating system, refer to the
VirtualBox documentation (http://www.virtualbox.org/wiki/Documentation) or VMware Workstation
documentation (http://pubs.vmware.com/workstation-12/index.jsp).

1. Collect the following information for the network you want to use:

■ IP address and netmask
■ Host name
■ DNS domain name
■ DNS server IP address
■ Default router (gateway) IP address

You may need to contact your network administrator for this information.

2. Open VirtualBox or VMware Workstation and start the Simulator virtual machine.

3. Log in to the virtual machine.
When the console login prompt appears, log in to the CLI by entering username root and the password you
created during setup. Wait until the hostname prompt appears.

4. Set the network gateway.
When the hostname prompt appears, navigate to configuration net routing and use the show command
to list the routing properties. Select the appropriate route and set the gateway value.

hostname:> configuration net routing

hostname:configuration net routing> show

ROUTE      DESTINATION   GATEWAY        INTERFACE TYPE    STATUS

route-000  0.0.0.0/0     192.168.56.1   e1000g0   static  active

hostname:configuration net routing> select route-000

hostname:configuration net route-000> set gateway="GATEWAY"

hostname:configuration net route-000> commit
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5. Set the IP address and netmask values.
Navigate to configuration net interfaces and use the show command to list the interface properties.
Select the appropriate interface and set the IP address and netmask values appropriate for your network.

hostname:configuration net routing> cd ..

hostname:configuration net> interfaces

hostname:configuration net interfaces> show

Interfaces:

INTERFACE   STATE  CLASS LINKS     ADDRS                LABEL

e1000g0     up     ip    e1000g0   192.168.56.101/24    Untitled Interface

hostname:configuration net interfaces> select e1000g0

hostname:configuration net interfaces e1000g0> set v4addrs="IP/NETMASK"

hostname:configuration net interfaces e1000g0> set v4adhcp=false

hostname:configuration net interfaces e1000g0> commit

 

6. Configure the bridged network settings.

a.   VirtualBox: Select the Simulator virtual machine, and click Settings. Select Network and
in the Adapter 1 tab, select Bridged Adapter to attach it. Then click OK.

b.   VMware Workstation: Right-click the Simulator virtual machine and click Settings. In
the Hardware tab, select Network Adapter and select the Bridged network connection.

7. (Optional) If needed, configure services in the Simulator BUI by navigating to Configuration
> Services and clicking the name of the service you want to configure:
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■ DNS - Set parameters to map the hostname to its corresponding IP address.
■ NTP - Synchronize appliance time with an NTP server by completing the fields under NTP Settings,

or set the appliance time to match the time and date according to your web browser by clicking SYNC
under Clock.

Note - The NTP service can take several minutes to complete startup due to the nature of NTP and the
adjustment of the system clock.

■ NIS - Configure this name service to authenticate users and groups using the Network Information
Service (NIS).

■ LDAP - Configure this name service to authenticate users and groups using the Lightweight Directory
Access Protocol (LDAP).

■ Active Directory - Configure this name service to authenticate users and groups using a Microsoft
Active Directory Server.

Refer to the Simulator online help for detailed information about working with services.

Sharing a SMB Filesystem

Complete the following steps to set up a simple filesystem share over Server Message Block (SMB) with
Windows user access.

1. Navigate to the Shares screen.
Click the add item icon  next to Filesystems to create a new filesystem.

2. Name the filesystem and change the permissions for Group and Other to allow anyone to
read, write, and execute on the filesystem.
In this example, the filesystem is named demo. The filesystem is part of the default project. Click APPLY to
save the changes.

Oracle® ZFS Storage Appliance Simulator Quick Start Guide 15



3. In the Shares screen, mouse over the entry for the new filesystem and click the edit icon 
to edit the filesystem attributes.

4. Click Protocols.

5. In the SMB section, clear the checkbox for Inherit from project, select Read/Write in the
Share mode drop-down list, and set the Resource Name.
In this example, the Resource Name is demo. Click APPLY to save the changes.

6. Click Configuration to access the Configuration Services screen.

7. Enable the SMB service by clicking the power icon .
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The state will change from Disabled to Online.

8. Configure a user with access to the filesystem share.

a.   Click USERS in the navigation bar, and click the add item icon  next to Users to create a
new user.

b.   Select Local Only, set the Username and Password, and click ADD.

9. Log out of the Simulator by clicking LOGOUT near the top of the screen.

10. From a Windows client, connect to the IP address of your Simulator, and log in with the
credentials you set in step 8 to access the shared filesystem.
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