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Oracle Workshop for WebLogic 10g R3 Hands on Labs

Workshop for WebLogic extends Eclipse and Web Tools Platform for development of
Web Services, Java, JavakE, Object Relational Mapping, Spring, Beehive, and Web
Applications. It installs as a plug-in to your existing Eclipse, or will install Eclipse for
you.

Workshop for WebLogic is used to develop, build, assemble, deploy, debug and test
Java SE, Java EE, Web Services, Java Web Applications, Object Relational Mapping
on Eclipse. If you are an Oracle Weblogic Server user, this is the free tool for you.

10g R3 Release Notes

Workshop for WebLogic introduces new tools in support of Java EE 5.0 standards.
The support for Java EE5 includes the following technologies:

Java EE5 Standards Support

« Servlet 2.5

- JSP21
« JSF1.2
- JSTL1.2
« Unified Expression Language
«  JAX-WS
« JAXB 2.0
- EIB3
« EE5 EAR

+ EJB 3 Session Beans
+ EJB 3 Message Driven Beans

Built on Eclipse 3.3.2 and Web Tools Platform 2.0.3

Workshop for WebLogic 10g R3 is built on the Eclipse Platform, an open source
framework that is now widely used for Java development. Workshop extends Eclipse
3.3.2 and the Web Tools Platform 2.0.3

Supported by Windows Vista

Workshop for WebLogic 10g R3 is supported by Windows Vista.
XML Beans

Workshop for WebLogic 10g R3 supports XMLBeans 2.3.
Workshop for WebLogic IDE Launcher

The WorkSpace Studio launcher has been discontinued. The Workshop for
WebLogic IDE launcher is WORKSHOP_HOME/workshop[.exe].
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Getting Familiar with Workshop for WebLogic 10g R3

The core components of this Eclipse based development environment are defined by
the following functional areas:

Enhanced server plug-ins for multiple versions of Oracle WebLogic Server
Visual Oracle WebLogic Server Web Service and XML IDE

WYSIWYG Web and presentation tier tools for portable Java Web applications
Object-relational mapping workbench and database tools

Apache Beehive IDE for Java Page Flow and controls

AppXRay support for the above components

Spring IDE Project and Spring code generation wizards

Core IDE features for Java SE and Java EE

Built in Web Application and Web Service test client

Upgrade tools for Workshop 8.1, 9.2 and 10 users

Getting hands on with Workshop for WebLogic 10g R3

This document contains instructions for the following labs:

1. Creation of a simple JAX-WS web service
2. Using the Workshop ClientGen functionality
3. JAX-WS Web Service with custom bindings
4. JAXB
5. FastSwap Java Class Redefinition

LAB1: JAX-WS Service

Note:

The lab resources and completed projects can be found in the companion
10gR3Labs.zip file. The folder names match the lab titles in this document.

Objective: Create a simple JAX-WS web service in WLW and deploy it to a running

Server.

This release of WebLogic Server supports both Java API for XML-Based Web Services
2.1 (JAX-WS) and Java API for XML-Based RPC 1.1 (JAX-RPC) Web Services. JAX-

RPC, an older specification, defined APIs and conventions for supporting XML Web
Services in the Java Platform as well support for the WS-I Basic Profile 1.0 to
improve interoperability between JAX-RPC implementations. JAX-WS is a follow up to
JAX-RPC 1.1 and it implements many of the new features in Java EE 5. For additional
documentation and examples about programming the features described in the
following sections in a JAX-WS Web Service, see the JAX-WS documentation
available at https://jax-ws.dev.java.net.

Java API for XML-based Web Services (JAX-WS) 2.1 is supported in this release,
adding the following features to those found in JAX-WS 2.0:

= Support for the JAXB 2.1 (JSR 222) Data Binding API
= WS-Addressing support
* Dynamic publishing of endpoints



ORACLE

= APIs for EndpointReference creation and propagation
= Annotations and APIs to enabled/disable features, such as MTOM and
Addressing

The WebLogic Server implementation of JAX-WS is based on the JAX-WS Reference
Implementation (RI), Version 2.1.4, and includes enhancements to the tool layer to
simplify the building and deployment of JAX-WS services and to ease the migration
from JAX-RPC to JAX-WS. The following features and enhancements are available
from the JAX-WS RI 2.1.4:

= _NET 2.0/WSF 3.0 MTOM interoperability support

» Significant performance improvements through the use of Woodstox

StAX Parser

» SOAPAction- based dispatching

» Integration of JAXB RI 2.1.5

= JAXB type substitution support

= WS-Addressing support for both W3C (1.0) and Member Submission

(2004/08)
= Asynchronous client/server support
= Dispatch and provider support:
e Dispatch<Message> and Provider<Message> support
e Development of non-WSDL or non-SOAP endpoints, such as
REST

As with WebLogic Server 10.0, developers may begin development with either a Java
source file or WSDL file. The WebLogic Server Ant tasks <jwsc> and <clientgen>
automate the generation of portable data binding classes, creation of deployment
descriptors, and packaging.

Steps:
Note: The JAX-WS Service and ClientGen projects are combined in the

JaxWsService.zip archive. The Service is ‘JaxwsServiceWeb’ and the client is
‘JaxwsClientWeb’.

Open Workspace and create a new space called ‘SimpleJaxwsSpace’
Select File -> New -> Project -> J2EE

Create a new Enterprise Application called ‘JaxwsProjectEAR’

Keep the default configuration

Click *Finish’

W=
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© New EAR Application Project

EAR Application Project
Create a EAR application, ==

Project name: | JaowsProjectEAR

Project conkents:
Use default

Targek Rurkirme

‘Oracle weblogic Server v10.3 v| [Ngw... ]
Configurations
‘Default Configuration For Oracle Weblogic Server v10.3 v ‘

A good starting paint For working with Oracle ‘WeblLogic Server
10,3 runtime, Additional facets can later be installed to add new
functionality to the praject.

@ [ Mext > H Einish H Cancel ]

6. Select File -> New -> Project

7. Find ‘Web Service Project’ under ‘Web Services’. Select and click ‘Next’

8. Name the project ‘JaxwsServiceWeb’

9. Under ‘Configurations’ select ‘Annotated Web Services Facets JAX-WS
(Recommended) (v10.3)’

10. Select ‘Add project to an EAR’

11. Click ‘Finish’

web Service Project [ .

wrt

Create a Web Service project in the warkspace or at an external location.

Project narne: \ JaxwsService\Web

Project contents:
Use: default

Target Runtime

Configurations
‘Annotatad ‘Web Service Facets JA%-WS {Recommended) {v10.3) v :
Uppart for creafing web services with the WeD Services Metadata z skandard.

Additionally supports using WeblLogic web service extensions,

EAR Membership

EAR Project Mame: | JaxwsProjectEAR. v| [New... ]

@ [ < Back. ][ Next > H Finish '\g[ Cancel ]
2

12.1n the ‘Project Explorer’ View right click the ‘Java Resources/src’ folder in the
JaxwsServiceWeb project and select New -> package.

13. Name the package ‘webservice’

14.Right click the ‘webservice’ package folder

15. Select New -> WebLogic Web Service

16. Enter the class name *HelloJaxWs’ and click ‘Finish’

17.You’ll get the source with the ‘*@WebService’ annotation
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18. Fill out the *hello’ method with the following:

@WebMethod

public String hello(String name) {
System.out.printin("Service invoked with name: " + name);
return "Hello " + name + " from JAX-WS service";

by

19. Create a server by right clicking in the servers tab (towards the bottom of the
screen) and choosing new -> server.

[Zl Problems | ¥ Tasks | 4L Servers 53 =1 Srippets | B Consale

SErver State Status

m ﬁ} Server

20. Choose the Oracle WeblLogic Server 10.3 (default)

© New Server |;|@@

Define a New Server
Chaoose the type of server to create

Server's host name: | localhost w |

Download additional server adapters

Select the server type:

|type Filker bext |

(= Apache

(= BEA Systems, Inc.

(= Basic

(= Caucha Technalogy

(= 1EM

(= JBoss

(= Mort Bay

(= Objectweb

== Orale
E Oradle OC4] Standalone Server 10,13
E Oracle OC4] Standalone Server 10,1.3.1

gic Server v10.3

Oracle WeblLogic Server v10,3

Server runtime: | Oracle Weblogic Server v10.3 vl [Insta\led Runtimes, .,
®

21.Click next.

22.When creating the server, you can use the sample domain that ships with the
product by pointing to the directory
<bea_home>\wlserver_10.3\samples\domains\wI_server. Choose the domain
and then click finish.
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O New Server |z|@@

Dracle Weblogic Server v10.3

@ Specify a weblogic domain directory CRALLE
Mame: | Oracle Weblogic Server w10.3 at localhost
Server Type: (®) Local () Remate
Configuration
Domain Direckary: v| [Browse... ]
Click here td=. beal03 Z4iwlserver 10,3 samplesidomainsimedrec

[#] isable Automatic Publishing To Server
[ always start WebLogic Server in debug mode

2

23.Right click on the HelloJaxWs.java as shown below, and choose run as.. run
on server to build and deploy and test the application onto Oracle WebLogic
Server 10gR3. Click finish on the resulting dialog to run.

% JaxwsProjectEAR
B2 JaxwsServiceWeb

@ Deployment Descriptor: Jaxw Mew 4
=2 Java Resources i
B sre Open Type Hierarchy F4
Show In Alt+Shift+w b

=3 webservice

SR e M Open F3
202 Hellodaxws Open With N
@ helloStri 2 Copy e

=i Libraries
(= build =
£= webCantent |z Paste Chrl+y
¥ Delete Delete
Build Path
Source Ale+shift+5
Insert
Refactor Ale+shift+T

E= Copy Qualified Marme

- v v v

£xg Impart...
£ Export...

& | Refresh F5

References 4
Deeclarations 4

Debug As 4

Profile As 4
Yalidate

Upgrade Source File{s)...

Team L4
Compare With 4
Replace With 4
Restore from Local History...

Web Services L4

2 oOpeh Run Dialog...

Properties Alk+Enter

Troubleshooting Tip: If you have an issue deploying the app where the error says
that someone else owns the edit lock on the server go to the WLS console ->
Preferences and disable the automatic locking. Then click ‘Release Edit Lock’ to
fix it.
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24.The test client should launch in the embedded Eclipse web browser. This test
harness allows you to interact with your JAX-WS web service. Enter your
name and click the “Hello” button, then scroll down to see the response.

EI HelloJaxs, java (@ Weblogic Test Client 52 =iE
o g§" | htkp:{flocalhast: 7001 fwls_utciclearlog.do v B
/ M Test Client
http:/flocalhost:7001/JaxwsServiceWeb/HelloJaxWsService ?2WSDL
Operations
@ hello

string argi: ‘Your Name Here|

—

Major Werzion: 10.2
Build 10: 1134752
Copyright 2008 & Oracle. 8l rights reserved.

25. Leave Workshop open, server running and application deployed, as you will
need it in the next lab.

LAB2: Client Gen — depends on LAB1

Note:

The lab resources and completed projects can be found in the companion
10gR3Labs.zip file, located on the OTN. The folder name for this lab is the same as
lab 1: "JAX-WS Service”.

Objective: Create a client for the previously created JAX-WS web service using the
ClientGen functionality of WLW. This should be done in sequence after labl to work

properly.

The clientgen Ant task generates, from an existing WSDL file, the client component
files that client applications use to invoke both WeblLogic and non-WeblLogic Web
Services. This allows your web service to be called from a web or non-web client.
When generating a JAX-WS Web Services, the output includes:
*» The Java class for the Service interface implementation for the
particular Web Service you want to invoke.
= JAXB data binding artifacts.
* The Java class for any user-defined XML Schema data types included
in the WSDL file.
When generating a JAX-RPC Web Services, the output includes:
*» The Java class for the Stub and Service interface implementations for
the particular Web Service you want to invoke.
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* The Java source code for any user-defined XML Schema data types
included in the WSDL file.

= The JAX-RPC mapping deployment descriptor file which contains
information about the mapping between the Java user-defined data
types and their corresponding XML Schema types in the WSDL file.

= A client-side copy of the WSDL file.

Client applications can use the generated artifacts of clientgen to invoke Web
Services, for example with:
» Stand-alone Java clients that do not use the Java Platform, Enterprise
Edition (Java EE) Version 5 client container.
= Java EE clients, such as EJBs, JSPs, and Web Services, that use the
Java EE client container.

Client Gen’s output libraries can also be used or declared as a Shared Java EE library
on Weblogic. Java EE library support in WebLogic Server provides an easy way to
share one or more Java EE modules or JAR files among multiple Enterprise
Applications. A Java EE library is a stand-alone Java EE module, multiple Java EE
modules packaged in an Enterprise Application (EAR), or a plain JAR file that is
registered with the Java EE application container upon deployment. After a Java EE
library has been registered, you can deploy Enterprise Applications that reference the
library. Each referencing application receives a copy of the shared Java EE library
module(s) on deployment, and can use those modules as if they were packaged as
part of the application itself.

Steps:

Note: The JAX-WS Service and ClientGen projects are combined in the
JaxWsService.zip archive. The Service is ‘JaxwsServiceWeb’ and the client is
‘JaxwsClientWeb’.

Select File -> New -> Project -> Web Services

Select ‘Web Service Project’

Click *"Next’

Name the project ‘JaxwsClientWeb’ and under ‘Configurations’ select
‘Annotated Web Services Facets JAX-WS (Recommended) (v10.3)’ as
shown below:

AWNPR
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© New Web Service Project

Web Service Project

Create a Web Service project in the workspace or at an external location.

Project name: | JaxwsClient\web |

Project contents:
Use default

Target Runkime

|Oracle Weblogic Server v10.3 ~ | [Ngw. o ]

Configurations

Annotaked W

Support For creating web services with the Web Services Metadata (J-S.R-224) standard,
Additionally supports using Weblogic web service extensions,

EAR Membership
[ add project to an EAR

Mew. ..

(':’) [ < Back ][ Mext = H Finish Q[ Cancel ]

5. Click ‘Finish’

6. Now deploy your new project to server that's already running. In the server
tab, right click “Oracle WebLogic Server v10.3 ....” and choose “Add and
Remove Projects” as shown below.

Mew 4
Qpen

¥ Delete
Renarme

#;it Debug
0 Restart

Stop
(L5 Publish
Clean...

Far A4dd and Remove Projects. .. k

Monitaring

Properties

B (2 Orag ogic i at i Sy i
I8 JaxwsProjectEAR. Synchronized

7. Click next on the resulting dialog.
8. Add the project by clicking add all, then finish. Do not remove existing
projects.
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© Add and Remove Projects |:||E|rg|
Add and Remove Projects =
Maodify the projects that are configured on the server
I

Move projects ko the right to configure them on the server
Available projects: Configured projects:

Ty JaxwsClentled
I% JaxwsProjectEAR

[z Remove All |

@ [ Finish ] [ Cancel ]

9. Right click the ‘JaxwsClientWeb/WebContent’ folder

10. Select New -> Other -> Web Service -> ClientGen Web Service Client

11. Select the ‘Remote’ radio button and enter the following URL:
http://localhost:7001/JaxwsServiceWeb/HelloJaxWsService?WSDL

12. Click ‘Validate WSDL'’

TROUBLESHOOTING TIP:

Make sure that the server is started and running, with the ‘JaxwsServiceWeb’
project deployed, and that you created the projects with the JAX-WS
configuration, not the JAX-RPC configuration, in the previous steps.

13. Click ‘Next’
14. Click “Next’
15. Select ‘Copy WSDL into Client jar’
ClientGen Wizard

Specify any additional aptions.

Package: | | {optional)

WSDL Location: | | {optional)

IL&qex.W..S.DL..in;e..?!ignk..!s?f.é
[ P5enerate Runtime Catalog

%ML Catalag | | [Browsa‘.. ]

Select Bindings

@
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16. Click ‘Finish’

17.You’ll find the HelloJaxWsService.jar file in
JaxwsClientWeb/WebContent/WEB-INF/lib

18. Copy index.jsp from the lab resources to the JaxwsClientWeb/WebContent
folder

19. Right click on the index.jsp file and choose “"Run As.. Run on Server to and
deploy it to the server and open it in the embedded Eclipse browser. Click ok
on the resulting dialog.

[ Project &2 & appxpl a;DI:uXpIDr = B
==
= 'I.D"I- lamwsClient\Weh

|§] Deployment Descripkor: JaxwslientWeb
2% Java Resources

(= build
=- %= webCantent
sk Findesx. jsp S
G META-INF  TWEW
B2 WEB-INF | gpen F3
= classe Open With ,
= lb
Eh web.x =] Copy Chrl+C
[ weblo
&2 1aewsProjectEAR % Deloto Delete
[ | .
i+
[F-i= JawwsService'el Mave. ..
Renarme Fz
£ Import...
£ Export...
# | Refresh FS
Yalidate

Upgrade Source File(s). ..

Debug As r _
Profile fie y 2 Open Run Dislog...
Team k

Compare With L

Replace ‘With r

Source L

Properties Alt+Enter

20.The embedded browser should take you to
http://localhost:7001/JaxwsClientWeb/index.jsp

The next lab will make use of a client JAR in the user interface code.
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LAB3: Custom Bindings

Objective: Creating web service that leverages JAX-B custom bindings, generating a
client JAR, plugging client code into JSP and running it.

Introduction to customizing XML Schema-to-Java Mapping Using Binding Declarations

Due to the distributed nature of a WSDL, you cannot always control or change its
contents to meet the requirements of your application. For example, the WSDL may
not be owned by you or it may already be in use by your partners, making changes
impractical or impossible. If directly editing the WSDL is not an option, you can
customize how the WSDL components are mapped to Java objects by specifying
custom binding declarations. You can use binding declarations to control specific
features, as well, such as asynchrony, wrapper style, and so on, and to control the
JAXB data binding artifacts that are produced by customizing the XML Schema.
You can define binding declarations in one of the following ways:
» Create an external binding declarations file that contains all binding
declarations for a specific WSDL or XML Schema document.
= Note: If customizations are required, Oracle recommends this method
to maintain flexibility by keeping the customizations separate from the
WSDL or XML Schema document.
= Embed binding declarations within the WSDL or XML Schema
document.
The binding declarations are semantically equivalent regardless of which method you
choose. Custom binding declarations are associated with a scope, as shown in the
following figure.

Scopes for Custom Binding Declarations
Global Scope
Schema Scope
Defiinition Scope
Component Scope

The following table describes the meaning of each scope.
Scopes for Custom Binding Declarations

Scope Definition

Global Describes customization values with global scope. Specifically:

scope » For JAX-WS binding declarations, describes customization values
that are defined as part of the root element.
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= For JAXB annotations, describes customization values that are
contained within the <globalBindings> binding declaration.
Global scope values apply to all of the schema elements in the
source schema as well as any schemas that are included or
imported.

Schema
scope

Describes JAXB customization values that are contained within the
<schemaBindings> binding declaration. Schema scope values apply to
the elements in the target namespace of a schema.

Note: This scope applies for JAXB binding declarations only

Definition
scope

Describes JAXB customization values that are defined in binding
declarations of a type definition or global declaration. Definition scope
values apply to elements that reference the type definition or global
declaration.

Note: This scope applies for JAXB binding declarations only

Component
scope

Describes customization values that apply to the WSDL or schema

element that was annotated.

Scopes for custom binding declarations adhere to the following inheritance and
overriding rules:

Steps:

OURWN

Inheritance—Customization values are inherited from the top down.
For example, a WSDL element (JAX-WS) in a component scope inherits
a customization value defined in global scope. A schema element
(JAXB) in a component scope inherits a customization value defined in
global, schema, and definition scopes.

Overriding—Customization values are overridden from the bottom up.
For example, a WSDL element (JAX-WS) in a component scope
overrides a customization value defined in global scope. A schema
element (JAXB) in a component scope overrides a customization value
defined in definition, schema, and global scopes.

Create a new workspace called ‘CustomBindingsSpace’

Select File -> New -> Project -> Web Services

Select ‘Web Service Project’

Click ‘Next’

Name the project ‘CustomBindingsServiceWeb’

Be sure to select ‘Annotated Web Service Facets JAX-WS

(Recommended)(v10.3)’ in the ‘Configurations’ drop down, as shown
below, then click finish.
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O New Web Service Project ‘@

Web Service Project ==
Create a Web Service project in the workspace or at an external Y
location. &4 f

Project name: i CustomBindingsServiceWeb i

Project conkents:
Use default

Target Runtime

|Oracle “Weblogic Server v10.3 | [Ngw... ]

Configurations

P 7
skandard, Additionally supports using WebLogic web service extensions,

EAR Membership
[ add project ko an EAR
IZ:'E'J [ < Back ][ Mext = ] [ Finish ] [ Cance| ]

7. Select File -> New -> Project -> Web Services

8. Select ‘Web Service Project’

9. Click ‘Next’

10. Name the project ‘CustomBindingsClientWeb’

11.Be sure to select ‘Annotated Web Service Facets JAX-WS
(Recommended)(v10.3)’ in the ‘Configurations’ drop down, as shown
below, then click finish.

© New Web Service Project |;|@

web Service Project ==
Create a Web Service project in the workspace or at an external _'@‘-,
location. 4]

Project name: i CustomBindingsClientweb| i

Project conkents:
Use default

Target Runkime

|Oracle Weblogic Server v10,3 w i [Ngw. oo ]

Configurations

|Annntated Weh Service Facets 1a%-WS (Recommended) (w10.3) bl

Support For creating web services with the Web Services Metadata (ER-224)
standard, Additionally supports using WeblLogic web service extensions,

EAR Membership
[add project ko an EAR

@ [ <Back J[ mext>= ][ Fmish 'L\g[ Cancel |

12. Do this next part carefully, making sure the paths are correct

13.1In the CustomBindingsServiceWeb project create a folder called ‘wsdl’ under
‘WebContent’ and copy the file ‘TemperatureService.wsdl’ in
‘CustomBindingsServiceWeb'.
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14.
15.
16.
17.
18.
19.
20.

21.
22.

23.

Copy the file ‘myBindings.xml’ to
CustomBindingsServiceWeb/WebContent/wsdl.

In the CustomBindingsClientWeb project create a folder called ‘bindings’
under ‘WebContent’. NOTE THIS IS NOT THE SAME PROJECT.

Copy ‘myBindingsClient.xml’ to the ‘bindings’ folder in
CustomBindingsClientWeb

Go back to CustomBindingsServiceWeb/WebContent/wsdl, right click on the
wsdl file and select Web Services -> Generate Web Service using WSDLC.

In the first screen delete the value from the ‘Java package’ field.

Click *"Next’

In the ‘JAXB Bindings for WSDLC’ select ‘Add’, navigate to ‘WebContent/wsdl’
and choose ‘myBindings.xml’

Click *Finish’

This will create the web service files in *CustomBindingsServiceWeb
/WebContent/WEB-INF/lib/TemperatureService_wsdl.jar’. If you want, you
can open the file with winzip and you’ll see the custom packaging reflected in
the folder naming.

Create a server by right clicking in the servers tab (towards the bottom of the
screen) and choosing new -> server.

[% Problems | v Tasks | 41k Servers 53 i snippets | B cansole

Server Skate Status

m 5 Server

24. Choose the Oracle WeblLogic Server 10.3 (default)
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O New Server |Z|@

Define a New Server
Choose the bype of server to create

Server's host name; | locathost - |

Download additional server adapters

Select the server bype:

|type filker text |

(== Apache
(£ BEA Systems, Inc.
(& Basic
(£ Caucho Technolagy
(= M
(= JBoss
(£ Mort Bay
(£ Objectweb
= Oracle
E Oracle OC4] Standalone Server 10.1.3
8 Oracle OC4] Standalone Server 10.1.3.1
r v10.3

Oracle WebLogi

Oracle WeblLogic Server v10.3

Server runtime: | Oracle WebLogic Server v10.3 | [installed Runtimes. .

@

25. Click next.

26. When creating the server, you can use the sample domain that ships with the
product by pointing to the directory
<bea_home>\wlserver_10.3\samples\domains\wI_server. Choose the
domain and then click finish.

O New Server |Z|E

Oracle WeblLogic Server v10.3

@ Specify a weblogic domain directory ORACLE
Mame: | Oracle Weblogic Server w10.3 at localhost
Server Type: (®) Local () Remote
Canfigurakion
Dornain Diveckory: v| ’Browse... ]
Click here b

r 10, nples!
beal0d Z4vworkshop 10,3 samplesid

k 8ins works

[#] Disable Automatic Publishing To Server
[ alhways start WebLogic Server in debug mode

@

27.Now deploy the CustomBindingsServiceWeb project to server that’s already
running. In the servers tab, right click *Oracle WebLogic Server v10.3 ...." and
choose “Add and Remove Projects” as shown below.

28. Click next on the resulting dialog.
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Tew L4
Jpen

¥ Delete
Rename

3 Debug

0 Restart

Stop
FL5! Publish
Clean...

i"- Add and Remove Projects. .,
MoritoHia L

Properties
O oracle Weblogic Server w103 at localhost e

®.nchronized

29. Add the project by clicking on the CustomBindingsServiceWeb and clicking

add, then finish. This will deploy the application on the server.
© Add and Remove Projects |Z|@

Add and Remove Projects
Modify the projects that are configured on the server
—J
Move projects ko the right to configure them on the server
Available projects: Configured projects:
'_=;3 CustomBindingsClientweb '_=o CustomBindingsServiceweb
<< Remove Al
':':’:' [ Finish L\\{l [ Cancel ]

30. Start the server by clicking the green play button, in the servers tab.

I 0 e B

31. Go to the ‘CustomBindingsClientWeb’ project

32.Right click the ‘WebContent’ folder and select New -> Other

33.Select Web Services -> ClientGen Web Service Client

34. Select the ‘Remote’ radio button and enter the wsdl location:
http://localhost:7001/CustomBindingsServiceWeb/TemperatureService?WSDL
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35.

Click ‘Validate WSDL'

Troubleshooting tip: make sure the CustomBindingsServiceWeb has successfully
deployed to a running server, and that you created the projects with the JAX-WS
configuration, not the JAX-RPC configuration, in the previous steps.

36.
37.
38.

39.
40.

41.

42.

Click *‘Next’

Click ‘Next’

In the '‘Bindings’ section select ‘Add’. Navigate to
‘WebContent\bindings\myBindingsClient.xml|” and add it.

Click ‘Finish’

You now have ‘TemperatureService.jar’ in WEB-INF/lib. Open it and view the
package structure.

Copy ‘index.jsp’ from the lab resources to CustomBindingsServiceWeb
/WebContent

Right click on the JSP page (as shown below), choose run as.. run on server,
and the embedded Eclipse browser should take you to
http://localhost:7001/CustomBindingsClientWeb/index.jsp

™ Proje. &3 & appx a;DbXpI =g
=

==

(= META-INF -~
(= WEE-INF

= 'u_'—‘,Jv CustomBindingsServiceW'eb

'&m Deployment Descriptor: CustamBin

23 Java Resources

(= build

= javadoc

== webcantent
=

M 3
(= mETA
= WEB-Il  Cpen F3
= da|  openwith C
== b
Iﬂ =| Copy ChrC
il
'8 we 3 Delete Delete
(= wsdl Move...
- 15R-1N9 Wieh ¢
¢ Rename Fz
2y Impart...
£ Export...
2 | Refresh FS
Yalidate

Upgrade Source File(s). ..
Run As

Debug As

Profile As

Team

_5 1 Run on Server ale+shift+:, R

ﬁ Open Run Dialog. ..

Conpare 'With
Replace ‘Wwith
Saurce

* v v v v vl

Propetties Alk+Enter
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LAB4: JAXB

Objective: Demonstrate the JAXB functionality in Workshop by creating JAXB
classes from an xsd and using them in a simple application.

Overview of Data Binding Using JAXB

With the emergence of XML as the standard for exchanging data across disparate
systems, Web Service applications need a way to access data that are in XML format
directly from the Java application. Specifically, the XML content needs to be
converted to a format that is readable by the Java application. Data binding
describes the conversion of data between its XML and Java representations.

JAX-WS uses Java Architecture for XML Binding (JAXB) to manage all of the data
binding tasks. Specifically, JAXB binds Java method signatures and WSDL messages
and operations and allows you to customize the mapping while automatically
handling the runtime conversion. This makes it easy for you to incorporate XML data
and processing functions in applications based on Java technology without having to
know much about XML. The following figure shows the JAXB data binding process.

Data Binding With JAXB

s o s s e

| |
| o
| oinding | Annotations |
| declarations | i 1
-------- el I\-————I————-I
I
e R . S
I XML 'i '/ 3 :Schema-derivedj
i » d existing |
| L Bind ; an g
|$I:h£‘mal-... "‘__l Java Classes |
| R N bt T--=-- -
[N !
I |
I ¥ b
| — | — » Unmarshal > .
I - — JavaObjects
HTTP ! SoAP | XML ﬁ
L/T—_»i — e = Marshal <
S N— |
b vy
JAXB

As shown in the previous figure, the JAXB data binding process consists of the
following tasks:
= Bind—Binds XML Schema to schema-derived JAXB Java classes, or
value classes. Each class provides access to the content via a set of
JavaBean-style access methods (that is, get and set). Binding is
managed by the JAXB schema compiler.
= Unmarshal—Converts the XML document to create a tree of Java
program elements, or objects, that represents the content and
organization of the document that can be accessed by your Java code.
In the content tree, complex types are mapped to value classes.
Attribute declarations or elements with simple types are mapped to
properties or fields within the value class and you can access the
values for them using get and set methods. Unmarshalling is managed
by the JAXB binding framework.
= Marshal—Converts the Java objects back to XML content. In this case,
the Java methods that are deployed as WSDL operations determine
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the schema components in the wsdl:types section. Marshalling is
managed by the JAXB binding framework. You can use the JAXB
binding language to define custom binding declarations or specify JAXB
annotations to control the conversion of data between XML and Java.

Steps:

Create a new workspace called ‘JaxbSpace’

Select File -> New -> Project -> J2EE

Create a new Enterprise Application called ‘JaxbApp’
Keep the default configuration

Click ‘Finish’

EAR Application Project

uhwhE

Create a EAR application, |

Project name: :.J_ax.hgpace

Project conkents:
Use default

Target Runkime

|oracle weblLogic Server v10.3 w |

Configurations
iDefauIt Configuration for Oracle ‘WeblLogic Server v10.3 |

A good starting poink For working with Oracle WeblLogic Server w10.3 runtime,
Additional Facets can later be installed ko add new Functionality ko the project.

@ [ < Back ][ et > H Finish H Cancel ]

6. Select File -> New -> Project -> Web -> Dynamic Web Project
7. Create a Dynamic Web Project called ‘JaxbWeb’
8. Add project to the EAR and click ‘Next’, as shown below
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© New Dynamic Web Project |Z”E]@

Dynamic Web Project

Create a standalone Dynamic Web project or add it ko a new or | @
existing Enterprise Application,

Project name: Jaxbiweb

Project contents:
Use default

Target Runtime

Configurations
Default Configuration for Oracle Weblogic Server +10.3 v

A good starting point Far warking with Oracle WeblLogic Server v10.3 runtime.,
Additional Facets can later be installed to add new Functionality to the project,

EAR Praject Name: | JaxbSpace i v__f
i:'-:’:i' B I [ext = RU Finish I [ Cancel ]

9. Be sure to select the Web Services facet and click ‘Finish’, as shown below

& %MLE=ans

[]08) auxisz web Services
[[1/=! Beehive Contrals 101
[1= Beehive MetLI 1.0.1
[#]fa Dynamic Weh Madule 2.5 -
[1¥%4 Hibernate 3.2 -
[#]&] Java £.0 -
@ Java Annokation Processing Suppork 5.0
[ Pa 1.0
] 15F 1.2 -
I 157L 1z -
&2 oracle Koda 4.1 -
14~ spring 2.0 -
[J%s Struts 1.2 -

@ Wb Services

\=| WebDaoclet (XDoclet) 1.23 -

10. Create the folder JaxbWeb/WebContent/xsd

11. Copy the book.xsd file from the lab resources to JaxbWeb/WebContent/xsd

12. Copy the books.xml file to the domain root of the server, located at
<bea_home>\wlserver_10.3\samples\domains\wl_server

13. Right click on book.xsd and select Web Services -> Generate a JAXB type JAR

14. Click *Next’

15. Enter ‘book’ as the package

16. Click ‘Finish’

17.The jar file book.jar is created in JaxbWeb/WebContent/WEB-INF/lib. If you
like, you can double click on it to view the contents in WinZip in a file explorer
window.

18. Create a package ‘book’ under JaxbWeb/Java Resources/src
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19. Copy in the JaxbTest source file from the lab resources into the ‘book’
package

20. Copy in the index.jsp from the lab resources to WebContent/JaxbWeb
/WebContent, say yes to overwrite and replace the default generated one.

21.Create a server by right clicking in the servers tab (towards the bottom of the
screen) and choosing new -> server.

[Z1 Problems | ¥2) Tasks | 4L Servers 53 i snippets | B cansole

Server Skate Status

m E‘*’ Server

22.Choose the Oracle WeblLogic Server 10.3 (default)
© New Server |Z|@@
Define a New Server =
Choose the bype of server to create D

Server's host name; | localhost -

Download sdditional server adapters

Select the server type:
type Filter text

(£ fpache
(£ BEA Systems, Inc.
(= Basic
(£ Caucho Technolagy
(= 1BM
(= JBoss
(£ Mork Bay
(£ Objectweb
= Oracle
E Oracle OC4] Standalone Server 10.1.3

Oracle WeblLogic Server v10.3

Server runtime: | Oracle Weblogic Server v10.3 | | Installed Runtimes. ..

23. Click next.

24. When creating the server, you can use the sample domain that ships with the
product by pointing to the directory
<bea_home>\wlserver_10.3\samples\domains\wI_server. Choose the domain
and then click finish, as shown below.
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O New Server |:|@

Dracle Weblogic Server v10.3

@ Specify a weblogic domain directory CRALLE
Mame: | Oracle Weblogic Server w10.3 at localhost
Server Type: (®) Local () Remate
Configuration
' | [Browse ]

Domain Direckary:

Cibeal0dd z4hwiserver 10, 3isamplesidomains medrec
_:healls wer 10, 3samplesidom /E
ibeal0s Z4vworkshop 10, 3samples dalns workshn

Click here b

[#] isable Automatic Publishing To Server
[ always start WebLogic Server in debug mode

@

25. Right click on the JaxbWeb/WebContent/index.jsp (as shown below) and
choose run as.. run on server. This will open the embedded eclipse browser
and should navigate you to http://localhost:7001/JaxbWeb/index.jsp

m JaxbTest java i@ http:fflocalhost: 7001 Jaxbwebfindex.jsp &3

= O

=) Q.:,Q‘"-' |http:,l',l'lu:u:alhu:ust:?[ltl1,|'Ja>c:|:|'-.-'-.-'e|:u,l'index.jsp V| L=

Bock Name: Java Websernces today and Beyond
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%5 Jaxbspace
=] ::‘,«J- Jaxbweb
= :‘5 Jawva Resources
=5 e
=8 book
=48] JaxhTest.java
u@ JaxbTest
FE resources
=i Libraries

= build
=-%= webContent
= META-INE  Mew *
[ pages
G wEB-INF|  OPED F3
= wed Cpen iwith r
[=| Copy Chrl4+C
¥ Delete Delete
Maowve, ..
Renarme Fz
Exg Import...
£ Export..,
2| Refresh F5
Yalidate

Upgrade Source File(s), ..

Debug As L

Frofile As " ﬁ Cpen Fun Dialog.”,
Team L4

Compare With L4

Feplace ‘With r

Saurce L

Properties Alk+Enker

26.The resulting webpage calls the JaxbTest class for some output (see below).
Examine the JaxbTest.java for details.

LABS: Class Redefinition (FastSwap)

Objective: Demonstrate the WLS FastSwap capability from within a Workshop
project using a stateful session bean.

Java SE 5 introduces the ability to redefine a class at runtime without dropping its
ClassLoader or abandoning existing instances. This will allow containers to reload
altered classes without disturbing running applications, vastly speeding up iterative
development cycles and improving the overall development and testing experiences.
The usefulness of Java SE 5’s dynamic class redefinition is severely curtailed,
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however, by the restriction that the shape of the class - its declared fields and
methods - cannot change. The purpose of FastSwap is to remove this restriction in
WebLogic Server, allowing the dynamic redefinition of classes with new shapes to
facilitate iterative development.

With FastSwap, Java classes are redefined in-place without reloading the ClassLoader
thus having the huge advantage of fast turnaround times. This means that
developers do not have to sit and wait for an application to redeploy and then
navigate back to wherever they were in the Web page flow. They can make their
changes, auto compile, and then see the effects immediately.

Supported Application Configurations
e FastSwap is only supported when the server is running in development mode. It is
automatically disabled in production mode.
e Only changes to class files in exploded directories are supported. Modifications to
class-files in archived applications as well as archived jars appearing in the
application’s classpath are not supported. Examples are as follows:
e When a web application is deployed as an archived war within an ear,
modifications to any of the classes are not picked up by the FastSwap agent.
e Within an exploded web application, modifications to Java classes are only
supported in the WEB-INF/classes directory; the FastSwap agent does not
pick up changes to archived jars residing in WEB-INF/Iib.

Application Types and Changes Supported with FastSwap

FastSwap is supported with POJOs (JARs), Web applications (WARs) and enterprise
applications (EARs) deployed in an exploded format. FastSwap is not supported with
resource adapters (RARs).

The following types of changes are supported with FastSwap:

Addition of static methods.

Removal of static methods.

Addition of instance methods.

Removal of instance methods.

Changes to static method bodies.

Changes to instance method bodies.

Addition of static fields.

Removal of static fields.

Addition of instance fields.

Removal of instance fields.

The online documentation has a detailed table listing the change types supported
with FastSwap.

Limitations of FastSwap

e Java Reflection results do not include newly added fields and methods and
include removed fields and methods. As a result of this, use of the reflection
API on the modified classes can result in undesired behavior.

e Changing the hierarchy of an already existing class is not supported by
FastSwap. Example: a) Changing the list of implemented interfaces of a class.
b) Changing the superclass of a class is not supported.
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Steps:

WN -

Project name: | FastSwapieb

Project contents:

Target Runtime

Configurations
Default Configuration For Oracle Wweblogic Server v10.3 v

A good starting poink For working with Oracle Weblogic Server 10,3 runtime, Additional Facets can later
be installed to add new functianality ko the project.

Addition or Removal of Java Annotations is not supported by FastSwap, since
this is tied to reflection changes mentioned above.

Addition or Removal of methods on EJIB Interfaces is not supported by
FastSwap since an EJB Compilation step is required to reflect the changes at
runtime.

Addition or Removal of constants from Enums not supported in this release.
Addition or Removal of the finalize method is not supported.

Create a new workspace called ‘FastSwapSpace’

Create a new Enterprise Application called ‘FastSwapApp’

Select File -> New -> Project -> Web -> Dynamic Web Project called
‘FastSwapWeb’ and check the box for “add project to an EAR, as shown below.
Then click finish.

Use default

EAR Membership

%EHE&E}E&"EE"&H EAR:

EAR-Project-MamerFastSwapipp w

Caniel

Create a new EJB project called ‘EJBProject’. Select File -> New -> Project ->
EJB -> EJB Project... then check the “add project to an EAR"” similar to the
preceding step, then click finish.

Go to Window -> Preferences -> Validation and disable all validation
Create a package under ‘ejbModule’ called ‘sessionbean’

Copy ‘Account.java’, ‘AccountBean.java’ and ‘AuditInterceptor.java’ into the
sessionbean package from the lab resources

Copy ‘index.jsp’ from the lab resources to the FastSwapWeb/WebContent
folder

In the project explorer, right click on FastSwapWeb/WebContent/index.jsp
and choose run as... run on server..
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=2 EJBProjectClient
% FastIwapapp
= .IDJ FastSwapWeb
25 Java Resources
(= build
= E& WebCantent
= META-INF
= pages
(= WEB-INF
s [

Mesw 4
Cpen F3
Open With 4
= Copy Chrl+C
¥ Delete Delete
Move...
Rename Fz
£ Import...
7 Export...
& | Refresh F5
Yalidate

Upgrade Source Fileis)...
Run As

Debug As

Profile As

Team

& 1 Run mn Server Alt-+Shif
i k

{2 Open Run Dialog...

Compare ‘With

Replace wWith
Saurce

*r v+ v v v v

Properties Alt+Enter

10. This will prompt you to create a server, choose the Oracle WebLogic Server
10.3 (default)
O New Server |Z|@

Define a New Server
Choose the bype of server to create
Server's host name: | localhost v |

Download sdditional server adapters

Select the server type:

|type filker text |

(= fpache

(= BEA Systems, Inc.

(= Basic

(£ Caucho Technolagy

(= 1BM

(= JBoss

(£ Mork Bay

(£ Objectweb

= Oracle
E QOracle OC4] Standalone Server 10.1.3
8 Oracle OC4] Standalone Server 10,1.3.1

Ora ).3

Oracle WeblLogic Server w10.3

Server runtime: | Oracle Weblogic Server v10.3 V| [Insta\led Runtimes, ..

@

11. Click next.

12. When creating the server, you can use the sample domain that ships with the
product by pointing to the directory
<bea_home>\wlserver_10.3\samples\domains\wI_server. Choose the
domain and then click finish.
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Dracle Weblogic Server v10.3

@ Specify a weblogic domain directory CRALLE
Mame: Oracle Weblogic Server w10.3 at localhost
Server Type: (®) Local () Remate

Configuration

Domain Direckary: | | Browse. ..

Click here td=. beal03 Z4iwlserver 10,3 samplesidomainsimedrec

[#] isable Automatic Publishing To Server
[ always start WebLogic Server in debug mode

13. The embedded browser will launch and navigate you to
http://localhost:7001/FastSwapWeb/index.jsp. (If a separate IE window pops
up, you can ignore or close it).

14.1In the web page, you’ll see the current balance is 100. Hit refresh a few
times to see the balance increase by 100 each time.

15.In EJBProject open the AccountBean.java file and in the ‘getBalance’ method
change the return to ‘balance + 1’. Save the change.

16.In the server tab you’ll see the Status is ‘Republish’ but don’t republish yet.

[l Problems [ ¥£] Tasks | =l Properties [ &b Servers £3 =1 snippets | B Consale 0 g8 = 8

Server Skake Skakus
B O Oracle WebLogic Server v10.3 at i Started Republish

17.Refresh the browser a few more times and notice that it still increments to an
even number.

18. Now republish to the server

19. Go back to the browser and refresh and you’ll see the balance is xx1 each
time

20.Remove the *+1’ from the getBalance method and save the change

21.Open the FastSwapApp\EarContent\META-INF\weblogic-application.xml file

22.Add ‘<fast-swap/>" just before the closing tag </wls:weblogic-application>

23.Save and republish. If this fails with a validation error, go to step 6.

24. Refresh the browser and the balance should now again be 100

25.Add the *+1’ back to the getBalance method and save the change

26. Again the server status will be ‘Republish’ but don’t publish

27.Refresh the browser and you’ll see the xx1. This happens because the
runtime class was updated in the classloader using ‘FastSwap’.



