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Metadata Manager Overview 
The need for more sophisticated and precise metadata management is a growing concern for 

most large organizations.  Nearly all components that comprise modern information technology, 

from CASE tools, ETL engines, Warehouses, BI, EAI environments, as well as metadata 

repositories, contain, and often derive their processing from, metadata.  The metadata for these 

environments is distributed and duplicated, often times active, and generally represented in a 

variety of methodologies, depending upon the underlying technology they represent. 
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The Oracle Metadata Management (OMM) provides a strikingly expansive set of capabilities in 

many facets of metadata management, including: 

 Data Governance 

 Metadata annotation and labeling 

 Metadata comparison, integration, and mapping 

 Version and configuration management 

 Data life cycle related metadata management 

 Lineage and impact analysis 

 Enterprise architecture development, management and deployment. 

 

At the heart of the Oracle Metadata Management (OMM) is its Repository which contains 

repository objects such as Models and Mappings which are organized in Folders. Models can be 

harvested from any External Metadata model or External Metadata Repository for Databases, 

Data Modeling (DM), Data Warehouse (DW), Data Integration (DI) and Business Intelligence 

(BI) tools. A particular type of Repostory Object called Configuration can connect (metadata 

stitching) Models and Mappings together to represent the Enterprise Architecture (EA) to be 

analyzed, including full support for data flow lineage and impact analysis, as well as semantic 

lineage definitions. 
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Disclaimer 
Oracle Metadata Management (OMM) solutions includes two products: Oracle Metadata 

Management for Oracle Business Intelligence and Oracle Enterprise Metadata Management.  

Each of these products provides a subset of a full Metadata Management (MM) solution as 

described below. Therefore, some sections of this help documentation may not apply to the 

Oracle Metadata Management (OMM) solutions. 

 

Importing (or Uploading) models 
In order to view a model over the web, one must first add the model to the Repository.  

There are three basic ways to place an External Metadata model in the Repository: 

 One may import one or more models directly from External Metadata. 

 One may import a model by defining a Model (identifying the location of an External 

Metadata model using the Oracle Metadata Management (OMM)’s Metadata Manager 

UI. 

 One may Upload a model by simply opening it in the External Metadata tool and 

exporting it to the Oracle Metadata Management (OMM) (where supported in the 

External Metadata tool’s User Interface). 

 

In each case, a model is produced, which may then be placed in a configuration to be Published 

and browsed/analyzed on the web. 

 

Scheduled Oracle Metadata Management (OMM) Synchronization of models 
One may configure Oracle Metadata Management (OMM) to synchronize with updates to 

models or a Mart.  In this way, updates to the models on a file system or in a Mart will be 

reflected in Oracle Metadata Management (OMM) on a regularly schedule basis. 

 

Configurations 
After importing or Uploading a model to the Repository, it may be necessary to place the 

resulting model into a configuration. A configuration is a hierarchical collection of models 

which: 

 Allows one to connect together, or stitch, models in Oracle Metadata Management 

(OMM) so as to allow end-to-end lineage and impact analysis 

 Can be Published, or made available to users of the Metadata Explorer UI 

 Provides a scope for Repository-wide browsing, searches and analysis 

 

Stitching a Configuration 
A valid configuration consists of a collection of model versions, mapping versions, glossaries 

and stitchings. The model versions relate to data stores and data processes that have been 

harvested into Oracle Metadata Management (OMM).  The repository objects are then stitched 

together by specifying how connection definitions in each relate to each other.  Once verified, 

end-to-end lineage and impact analysis, definition lookup and semantic usage reporting are 

possible across the entire Configuration.  In addition, the stitching are automatically migrated 

forward as versions of the repository objects involved in the change. 
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Publishing a Configuration 
A configuration allows the Administrator of the Repository ensure the completeness and 

correctness of what is visible to business users and how all users search and analyze within the 

full complexity of the Repository. 

 

Finally, configurations may be defined for automatic update (publication) of new repository 

object versions.  In this way, each time a new version of a model is harvested (say, based upon a 

schedule) or Uploaded using the External Metadata tool, that new version of the model will be 

reflected as a member of the Published configuration. 

 

Searching a configuration 
A user may use a web based search for metadata at the most detailed level (e.g., the data type of 

an attribute) across any configuration defined in the system. 

 

Managing configurations 
Oracle Metadata Management (OMM) allows the Administrator to: 

 Define any number of configurations 

 Publish a configuration to a different set of users (by group) 

 Publish none, some, or all configurations. 

 

In this way, the Administrator of the Repository has infinitely fine control of who sees what and 

when they may see it. 

 

Model Versions 
In some cases, one may wish to use the Repository to maintain a version history for each harvest 

or Upload of a model.  These versions are individual objects within the Repository and represent 

the repository object content at a specific point in time. 

 

The Administrator may manage any number of versions.  By default, however, the Metadata 

Manager UI only shows one version of a model.  The technical user may change to a multi-

version user interface mode at any time.  In addition, a particular version may be designated to 

be the default version. It is the default version of a model which is used when the Metadata 

Manager UI is in single-version mode.  

 

In addition, when including a model in a configuration, one is actually including a specific 

version of that model in the configuration.  This means that one may control which version of 

which models are to be Published at any point in time.  E.g., one may place the approved version 

of a model in a Published configuration while data modelers continue to edit and Upload newer 

version as work in progress (unpublished). 

 

The user of the Metadata Explorer UI is restricted to a single configuration, and thus in all cases 

the Metadata Explorer UI only shows one version of a model.   

 

Configuration versions 
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In some cases, one may wish to maintain a version history for a configuration.  E.g., one may 

wish to maintain historical configurations of versions for historical analysis.  In addition, one 

may wish to perform what-if analysis by placing the latest, but not approved, version of the 

repository objects in a new (and unpublished) version of that configuration.   

 

As with Models, these Configuration versions are individual objects within the Repository and 

represent the configuration of the contents at a specific point in time. 

 

The Administrator may manage any number of Configuration versions.  By default, however, the 

Metadata Manager UI only shows one version of a configuration.  The Metadata Manager UI 

may be changed to a multi-version user interface mode at any time. 

 

Additionally, when one sets a version of a configuration to Published status, it is then available 

to users of the Metadata Explorer UI.  I.e., one is actually designating a specific version of that 

configuration as the Published version.  This means that one may Publish a precise collection of 

content versions.   

 

In all cases, the Metadata Explorer UI only shows the Published version of a configuration, 

which is simply seen as the configuration. 

 

Users, Groups and Permissions 
Fundamentally, Oracle Metadata Management (OMM) has users and permissions. Users derive 

authority from the union of permissions they have.  In a large system with a large number of 

users and a large variety of permissions, granting individual permissions to individual users 

would be unmanageable without the ability to assign security and workflow roles and security 

policies to large groups of users. Users can be logically grouped into groups and multiple 

permissions can be represented by security and workflow roles. Roles and groups the reduce the 

complexity and are easier to manage.  

 

User Feedback, Collaboration and Review 
Provides an environment where Oracle Metadata Management (OMM) models may be reviewed 

and/or approved by users with the appropriate permission. These tools allow one to add 

Comments (notes) and Labels to individual objects, such as Tables and Columns.   The 

comments may also be synchronized with the External Metadata (where supported in the 

External Metadata tool user interface) outside Oracle Metadata Management (OMM). 

 

Data Mapping Specifications for Data Flow Lineage & Impact Analysis 

Some data flow processes are not harvestable, but if these processed are not modeled in Oracle 

Metadata Management (OMM), it will leave gaps in the lineage and impact analysis answers and 

provide an incomplete picture of the physical architecture of your systems.  In order to address 

these gaps and produce proper lineage and impact results, Oracle Metadata Management (OMM) 

has a Data Mapping Specifications editing and management toolset to produce high-level logical 

(or notional) definitions of the way data “flows” from some number of source models into 

elements of a target model.  These mappings are specified using a simple web based drag and 
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drop type mapping specification editor and are defined using descriptive text and one may also 

define pseudo operations using an operation editor. 

 

Business Glossary 

Critical to the development and management of a complete data architecture is a Business 

Glossary.  Oracle Metadata Management (OMM) provides an ISO 11179 based Business 

Glossary to capture, define, maintain and implement an enterprise Business Glossary of 

terminology, data definitions, code sets, domains, validation rules, etc.  In addition, semantic 

mappings describe how elements in a source model (more conceptual like the Business Glossary) 

define elements in a destination model (closer to an implementation or representation). 

 

The Business Glossary helps an enterprise to reach agreement between all stakeholders on their 

business assets (e.g. terms) and how they relate to data assets (e.g. database tables) and 

technology assets (e.g. ETL mappings).  The Business Glossary can be used to document 

logical/physical data entities and attributes across IT collaboratively. Again, it involves tracing 

dependencies between business and technical assets. 

 

Semantic Mapping 

A Semantic Mapping describes how elements in a source model (more conceptual) define 

elements in a destination model (closer to an implementation or representation).  Put the other 

way, elements in the destination model are representations or implementations of the associated 

element in the source model. 

 

The three primary uses are: 

 Data Standardization and Compliance 

 Multi Level Modeling of semantic relationships from conceptual to logical, and to 

physical data model with a few sub cases 

  Business Glossary term classification 



Help on Metadata Manager 
 

July 2016 Copyright © 2016, Oracle and/or its affiliates. All Rights Reserved. (7/18/2016) Page 9 of 97 
 All trademarks, trade names, service marks and logos referenced herein belong to their respective companies 

 

User Interface 

User Interface General Concepts 

Placement of Action Icons 
There are some basic rules regarding the layout of the user interface which provides consistency and ease of navigation.  In particular, 

action icons (e.g.,  for Search) are organized into two categories: 

 Actions which relate to the panel overall (e.g., model or configuration) 

 Actions which apply to a selected element within the panel (e.g., a table or column in a model) 

 and placed accordingly in the UI: 

 Overall panel icons are placed on the right hand side of the header for the panel 

 Selected element icons are placed on the left in the tool bar for the panel (underneath the header). 

Split Workspace 
It is possible to see and work with two workspace panels at the same time placing one below the other.  Simply right-click on the tab 

of the workspace you wish to dock to the bottom of the browser window, then select  

Standard graphical navigation tool bar 
Lineage overview, lineage traces and model diagrams are highly graphical results, and thus a standard graphical navigation bar (see 

the diagram visualization or graphical lineage UI) is used consistently throughout Oracle Metadata Management (OMM) for 

navigating within these graphical presentations. 

 

In particular, one may 

 Click on a location in the Overview to quickly navigate to that portion of the repository object. 

 One may also drag the mouse around the Overview panning the diagram. 

 Show or hide the overview using the Overview toggle. 

 Resize the overview by dragging the lower right-hand corner of the Overview panel. 

 Zoom in and out using the zoom in and ( ) control. 

 Zoom out completely by clicking on the Fit Contents ( ) icon. 

 Drag the cursor anywhere within the diagram to bring portions off screen into the current graphical context. 
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Standard object context menu 

 

Object Lineage Tracing Actions 
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User Interface Component 

Header with Global Menus  
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General User Interface Component Layout 

 



Help on Metadata Manager 
 

July 2016 Copyright © 2016, Oracle and/or its affiliates. All Rights Reserved. (7/18/2016) Page 13 of 97 
 All trademarks, trade names, service marks and logos referenced herein belong to their respective companies 

 

Repository Panel User Interface Components 

 



Help on Metadata Manager 
 

July 2016 Copyright © 2016, Oracle and/or its affiliates. All Rights Reserved. (7/18/2016) Page 14 of 97 
 All trademarks, trade names, service marks and logos referenced herein belong to their respective companies 

 

Properties Panel User Interface Components 
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Workspace and Content User Interface Components 
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Search User Interface Components 
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Diagram Visualization User Interface Components 
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Lineage Trace User Interface Components 
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Configuration model Manager User Interface Components 
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Configuration Architecture Diagram User Interface Components 
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Business Glossary Catalog and Term User Interface Components 
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Business Glossary Term User Interface Components 
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Semantic Mapping Mapping Editor User Interface Components 

 



Help on Metadata Manager 
 

July 2016 Copyright © 2016, Oracle and/or its affiliates. All Rights Reserved. (7/18/2016) Page 24 of 97 
 All trademarks, trade names, service marks and logos referenced herein belong to their respective companies 

 

Mapping Reporter User Interface Components 
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Data Mapping Specifications Editor User Interface Component  
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Physical Data Model User Interface Components 
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User preferences 

 
 

Show / hide timestamps in log messages 
1. Sign in to the Repository as a user with Administrator privileges.  

2. Go to Tools -> Preferences. 

3. Check the Show Log with Timestamps checkbox. 

 

Show / hide debug level log messages 
1. Sign in to the Repository as a user with Administrator privileges.  

2. Go to Tools -> Preferences in the header. 

3. Check the Print Debug Log Messages checkbox. 

Special UI capabilities 

Docking tabs 
It is possible to dock the tabs in the Workspace Panel of the Metadata Manager UI either at the 

top half of the browser or at the bottom half.   
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E.g., to move a tab from the top half to the bottom half: 

1. Right click on a tab in the header of the Workspace Panel and select Dock tab to south 

and it will move to the bottom of the browser window. 

2. If there are already some tabs docked in the bottom half, be sure to drop the one you are 

dragging next to an existing tab. 

Undocking properties panel 
It is possible to undock the Properties panel so that it is not docked to the right hand side of the 

browser window.  It may then be resized and placed anywhere within the browser window.   

 

To undock the Properties panel: 

1. Right-click on the header of the Properties panel. 

2. Select Detach all properties. 

 

To re-dock the panel, simply close the floating window. 
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Exploring Metadata 
 

Browse a Model 

1. Sign in to Oracle Metadata Management (OMM) as a Metadata Explorer UI user.  

2. Navigate to the  model using the Configuration panel (see Metadata Explorer UI User 

Interface Components) 

3. To open the  model for browsing, you may: 

o Right click on a model in the Configuration 

panelhttps://sites.google.com/a/metaintegration.info/miti-development/users/john-

friedrich/ca-erwin-web-portal/getting-started/concepts-and-overview/using-the-

repository-panel and select Open. 

o Double-click on a  modelin the Configuration panel 

o Drag a  modelin the Configuration panel into header of the Workspace Panel 

where the tabs are. 

4. You are then presented with the Metadata Browser. 

From here you may: 

 Click on an element and view its properties in the Properties Panel.  You may need to 

expand the properties panel (far right hand side of the page) using the Show / Hide 

Selected Object Properties control. 

 Navigate directly to any hyperlinked element (with an arrow in the lower left corner of its 

icon) by clicking on this icon.  

 Actions which apply to the overall model (right-hand side of the model header): 

o Search ( ) icon to search for objects in the model containing a text string 

o Data Flow Overview ( ) icon to show an overview of the data flow in the 

model 

o Labels ( ) icon to review labels for the model 

o Comments ( ) icon to manage comments for the model 

o Attachments ( ) icon to view files attached to the model. 

o Use the Actions icon for more options, including: 

- Show in Configuration - show the specific location of this model in the 

configuration 

- Export – Export the model to the External Metadata format 

- View Log – View logs for any action executed against the model 

 Actions which apply to the selected object in the model: 

o The tree presented is actually a hyperlinked tree, and as such some objects in the 

tree will have a small arrow in the lower left corner of the icon.  In this case, the 

entry in the tree is a link to another location in the tree structure.  You may 

double-click or right-click and select Go To Reference on the object to jump to 

this other location where the object is fully defined.  In order navigate after 

following hyperlinks, the navigation icons are useful: 

 Forward ( ) icon to return to an object you had jumped to before 

https://sites.google.com/a/metaintegration.info/miti-development/users/john-friedrich/ca-erwin-web-portal/getting-started/concepts-and-overview/using-the-repository-panel
https://sites.google.com/a/metaintegration.info/miti-development/users/john-friedrich/ca-erwin-web-portal/getting-started/concepts-and-overview/using-the-repository-panel
https://sites.google.com/a/metaintegration.info/miti-development/users/john-friedrich/ca-erwin-web-portal/getting-started/concepts-and-overview/using-the-repository-panel
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 Back ( ) icon to return to an object you had jumped from 

o Open ( ) icon – for a diagram, to visualize the diagram of a Model 

o Show in Diagram ( ) to visualize a model diagram for the selected object 

o Trace Lineage ( ) icon to trace lineage for the selected object 

o Bookmark ( ) icon to Create a bookmark or link to this result 

o Right-click on an element or select an element and use the Actions icon for more 

options, including: 

- Open – for a diagram, to visualize the diagram of a Model 

- View Object Change History – Presents the change history within all 

earlier versions of this model for the selected element. 

- Open in Metadata Explorer – Will open the element in the Metadata 

Explorer.  If there is more than one configuration version in which the 

object is defined, then a pick list will be presented. 

Search for any metadata object 

Search for specific objects within a content 
1. Browse to a specific model (see Browse a model). 

2. Click on the Search ( ) icon. 

3. Enter the search text in the search text box (see Metadata Explorer UI User Interface 

Components).  Also be sure to see the search query language for advanced searching. 

4. Select any pre-filtering criteria. 

5. Click on the  Search  button. 

6. You are then presented with the Search Interface Components. 

 

From here you may: 

 Navigate directly to any element in the search results by clicking on its name. 

 In the toolbar: 

o Navigate through the pages of results using the controls above the results. 

o Specify additional criteria for the searching using the All Options to select search 

options. 

o Filter the search results using the Filters panel. 

 One may check and uncheck possible 

1. Types of objects 

2. Models in the scope of the search results 

 One may also click on the expand ( ) icon to see these options 

o Bookmark ( ) icon to Create a bookmark or link to this result 

o Download ( ) icon to download the results of the search using that link. 

o Right-click on an element or select the Actions icon for more options. 

Search across many repository objects 

1. Sign in to Oracle Metadata Management (OMM) as a Metadata Explorer UI user. 
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2. Click on the Search control in the upper right of the Repository Panel (see Metadata 

Explorer UI User Interface Components). 

3. Enter the search text. 

4. Select any pre-filtering criteria. 

5. Click on the search button. 

6. You are then presented with the Search User Interface Components. 

 

From here you may: 

 Navigate directly to any element in the search results by clicking on its name. 

 Click on an element and view its properties in the Properties Panel. 

 Filter the search results using the Filters panel. 

 Navigate through the pages of results using the controls above the results. 

 Create a bookmark or link to this result. 

 Download the results of the search using that link. 

 Right-click on any result and select from the Standard Model Object Context Menu. 

 Right-click on an element or select the Actions icon for more options. 

Query language 
In addition to the pre and post filtering selections, one may search for very precise results by 

specifying a search using the built-in query language.  This is quite similar to most other web 

based search engines. 

 

Specific searches may be made for the following type of criteria: 

To search for Example Result 

Any words sales order Any result containing the word “sales” or the word “order” 

Exact phrase “sales order” Any result containing the exact phrase “sales order” 

All words +sales +order Any result containing BOTH the words “sales” and “order” 

Exclude words sales –order Any result containing the word “sales” but cannot contain the 

word “order” 

Wild card end sale* Any result containing part of a word beginning with “sale” 

Parent and child sales.order Any result where the parent is named “sales” and the child is 

named “order”.  E.g., the attribute “order” contained within the 

entity “sales”. 

Exact name .order Any result only containing the word “order” 

 

One can, of course, append these together into a search string.  E.g.: 
Sales +order -date property:physicalname type:column 

Creating bookmarks and URLs for collaboration 

Define a bookmark for the current page 

1. From any page and selecting any object on that page, click on the Bookmark ( ) 

icon (see Metadata Explorer UI User Interface Components). 

2. You may then  

o Obtain a URL to be shared. 
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o Add a bookmark which will be added to the Bookmarks panel (see Metadata 

Explorer UI User Interface Components). 

o Mail Link to invoke your default e-mail client with the URL. 

Obtain a URL 
1. From any page, either: 

o Click on the Bookmark ( )  icon (see Metadata Explorer UI User Interface 

Components) 

o Right-click on an object and select Get Link. 

2. Right click on the URL text and paste into any other application (e.g., e-mail, document, 

etc.) 

3. You may also use the Email Link button to invoke your default e-mail client with the 

URL. 

Place labels for search and review 
Labels are Oracle Metadata Management (OMM) wide meta tags, which may be applied to any 

object in a model, searched on, reviewed and managed centrally by model or configuration. 

Assign and View Labels on an Object 
To assign a label to an object: 

1. Navigate directly to any model. 

2. Click on an object and view its properties in the Properties Panel. 

3. Scroll down in the Properties Panel if necessary, and expand the Labels if necessary. 

4. Enter a single word label into the Labels combo box, or select an already defined label. 

 

Note:  Labels are defined Oracle Metadata Management (OMM) wide.  Please keep in mind that 

the pool of labels defined by anyone will be seen by and available to everyone. 

Remove a Label Assignment 
To no longer assign a label to an object 

1. Navigate directly to any model. 

2. Click on an object and view its properties in the Properties Panel. 

3. Scroll down in the Properties Panel if necessary, and expand the Labels if necessary. 

4. Click in the Labels combo box. 

5. Click on the “x” next to the label you wish to un-assign. 

  

Note:  Labels are defined Oracle Metadata Management (OMM) wide.  Removing a label 

assignment does not remove the label from the system. 

Review Label Assignments 
One may review the label assignments across an entire model or configuration. 

 

1. For a model or configuration 

o For a model, navigate directly to any model in the configuration Panel and open 

it.  Click on the Review Labels ( ) icon . 

o For a configuration, click on More actions ( ) icon in the configuration Panel 

tool bar and select Review Labels. 
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2. Enter any number single word labels into the Labels combo box or select any number 

using the combo box selection.  Remember, you may select any number of labels to 

review. 

3. To add or remove a label: 

o Right-click on any item in the list of objects and select Add Label or Remove 

Label. 

o Or, 

1. Right-click on that item 

2. Select Show in Metadata Browser 

3. View its properties in the Properties Panel 

4. Scroll down in the Properties Panel if necessary 

5. Expand the Labels if necessary. 

4. Click on the “x” next to the label you no longer wish to include in the review. 

Search for Label Assignments 
When searching in a model or configuration, one may  

 Filter the search results using the Filters panel to specific labels. 

Provide feedback/comments and review 
Comments are free-form text notes which may be queried for, reported on, reviewed and 

managed by model.  A comment tracks its author, creation time, update time, importance and 

status.  The user can attach any file including pictures and multimedia to the model and refer to 

them in a comment.  One can leave one or more comment(s) per object and see comments made 

by others.   

 

Unlike labels, comments only apply to the specific version of the model they were entered in.  

However, comments may be migrated forward to newer versions as part of the review of 

comments across a model process. 

 

In addition, these comments may then be exported out of Oracle Metadata Management (OMM) 

and opened in External Metadata tool, there to be reviewed and edited in the original External 

Metadata model format  (where supported in the External Metadata tool user interface). 

Add comments 
To add a comment to an object: 

1. Navigate directly to any model. 

2. Click on an object and view its properties in the Properties Panel. 

3. Scroll down in the Properties Panel if necessary, and expand the Comments if necessary. 

4. Enter any amount of text into the Comment dialog box. 

5. Click Save. 

Manage comments on an individual object 
To add a comment to an object: 

1. Navigate directly to any model. 

2. Click on an object and view its properties in the Properties Panel. 

3. Scroll down in the Properties Panel if necessary, and expand the Comments if necessary. 

4. Click on a particular existing comment. 
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5. You may now 

o View the comment in the comment text box at the bottom of the Properties Panel. 

o Add a new comment. 

o Edit the selected comment. 

o Specify the Importance of the comment as one to five stars. 

o Delete the selected comment.  This is a permanent action. 

o Send an e-mail to the author of the selected comment. 

Review comments across a model 
To manage all comments within a model: 

1. Navigate directly to any model in the configuration Panel and open it.   

2. Right-click on the Review Comments ( ) icon. 

3. A list of all objects within the model which have comments is presented.  From here, you 

may: 

o View the comment in the comment text box at the bottom of the Properties Panel. 

o Add/remove and sort by columns to this list. 

o Download the list to Excel. 

o Right-click and select one of the following, or use the actions in the list header to 

for the selected object to: 

 Add a new comment. 

 Edit the selected comment. 

 Set status of the comment. 

 Set importance of the comment. 

 Deleted the selected comment.  This is a permanent action. 

 Send an e-mail to the author of the selected comment. 

 Migrate the comment to another version of the model, so that as you 

import new versions, you may carry the comment forward. 

o Keep in mind, you may select multiple comments at one time. 

Search for comment contents 
When searching in a model or configuration, one may  

 Filter the search results using the Filters panel for comment text. 

Visualize the diagram of a Model 
1. Browse to a specific Model (see Browse a model). 

2. Do one of the following: 

o Navigate to any object which is presented in a diagram (e.g., table, relationship) 

and right-click to select Show in Diagram.  You will be presented with a choice 

of diagrams available in the model, if there are more than one, and selecting one 

will present the diagram as a new tab. 

o Expand ER Diagrams and navigate to any diagram and right-click to select 

Open.  You will be presented with the diagram as a new tab. 

o Expand Subject Areas and navigate to any diagram and right-click and select 

Open.  You will be presented with the diagram as a new tab. 
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Note that any number of diagrams may be opened at a time and each will be assigned a tab in the 

model workspace panel. 

 

While one cannot permanently alter a diagram (or create new ones) for a simple model, 

nevertheless all of the layout, annotation, display level, etc., features may be employed for 

visualization.  You may always return to the original published layout by clicking on the Show 

original button.   

 

Thus, from here you may: 

 All actions that are available for a harvestable model are also available here with a 

Physical Data Model. 

 Click on an metadata element and view its properties in the Properties Panel.  You may 

need to show ( )the Properties Panel (far right hand side of the page). 

 Make use the of the standard graphical navigation toolbar. 

 Open the selected object ( ) icon to display the metadata details page for the selected 

metadata element. 

 Trace lineage ( ) to/from the selected metadata element 

 Show only related entities ( ) related to the selected table 

 Click on the Undo ( ) to undo the last action. 

 Click on the Redo ( ) to redo the last action. 

 Click on the New Shape ( ) icon to create and edit annotations in many shapes for a 

diagram. 

 Click on the Remove ( ) icon to remove an object from the diagram. 

 Click on the Layout ( ) icon to automatically layout the diagram. 

 Use the Diagram Properties ( ) pick list to specify Model display options, including: 

o General 

 Notation (e.g. IDEF vs. IE) 

 Diagram Background color 

 Default Entity display type 
 Show lines on top. 

o Display format with formats for Entity, Shape and Label, including: 

 Background color 

 Border color 

 Border size 
 Font   

 Opacity  

o Default Entity Display Options 

 Use the Entities Display ( ) pick list to specify Model display options, including: 

o Display Level 
o Column Properties 

o Reset entities size 
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 Use the  control for the selected metadata element (or the entire diagram if 

nothing is selected), including Show and Hide: 

o Labels for labels on relationship lines 

o Relationship Names for names on relationship lines 

o Cardinalities for cardinality notations on relationship lines 

o Role Names for role name notations on relationship lines 

o Layout Labels to arrange relationship labels  

 For any selected object in the diagram, right-click for the context menu or click on the 

 icon in the header to: 

o Open – Open the selected object details page 

o Show in Diagram – Move to the selected object location in the diagram and 

highlight the object 

o Trace Lineage – Trace lineage from the selected Object in the context of the 

current configuration 

o Show only related entities – related to the selected table 

o Quick Color – Quick color pallet dialog for the selected object 

o Reset Size – Reset the size of the selected object to the last saved state 

o Auto Size – Auto size the select object 

o Display Level… – Specify the display level for the selected object, including: 

 Entity 

 Description 

 Primary Key 

 Keys 

 Attributes 

 Physical Order 

 Inherit – Inherit level from diagram settings. 

o Layout – Auto layout the selected object(s) 

o Start Relationship – To start a relationship line from the selected object 

o Properties – Edit properties for the selected object 

o Remove – Remove the selected object from the diagram only 

 Actions which apply to the overall model (right-hand side of the model header): 

o Use the  text box metadata elements in the displayed diagram using 

a text string. 

o Print ( ) the diagram 

o Analyze relationships in the diagram of a physical data model 

 You may select a relationship in that diagram and perform the following 

analysis: 

 The associated primary keys and foreign keys are highlighted in the 

associated tables in the diagram.  If there are more than one PK/FK 

pair, each will be highlighted in a different color. 

 In the Properties Panel you may copy and paste the Related 

Columns to be used to define the equivalent join directly in a 

reporting . 
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Auto-Layout 
After you have found a Model and visualize the diagram of a Model, you may use the Auto 

Layout function to re-layout the diagram according to a specific algorithm.  You may always 

return to the original published layout by clicking on the Show original button. 

Dynamic diagram subset generation and layout 
When you have selected a particular table/entity in a diagram, you may use the Show only 

related entities option to redisplay a smaller diagram with only those tables/entities which are: 

 Directly related (through relationship definitions) 



Help on Metadata Manager 
 

July 2016 Copyright © 2016, Oracle and/or its affiliates. All Rights Reserved. (7/18/2016) Page 38 of 97 
 All trademarks, trade names, service marks and logos referenced herein belong to their respective companies 

 

 Have 2 levels of separation 

 Are in Anyway related. 

Analyze relationships in the diagram of a Model 
After you have found a Model and visualized the diagram of a Model, you may select a 

relationship in that diagram and perform the following analysis: 

 The associated primary keys and foreign keys are highlighted in the associated tables in 

the diagram.  If there are more than one PK/FK pair, each will be highlighted in a 

different color. 

 In the Properties Panel you may copy and paste the Relationship Join Expression to 

be used to define the equivalent join directly in a reporting tool . 
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Export the Model to External Metadata format 
1. Browse to a specific Model (see Browse a Model). 

2. Click on the More Actions ( ) icon (see Metadata Manager UI User Interface 

Components). 

3. Select Export. 

4. Select the External Metadata export format in the Export to pull-down. 
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5. For each of the Parameters, complete according to the tool-tips displayed in the right 

hand panel of the dialog.  Be sure to use the remote repository browse function (  icon 

in the parameter entry box) to include the folders and Models you wish to include. 

6. Click Export.  A dialog will appear asking to import the Model.  Click Yes. 

7. The Log Messages dialog then appears and log messages are presented as the export 

process proceeds. 

8. If you receive the Operation Successful result, click Close to open the Model.  If 

instead you see the Operation Failed result, inspect the log messages and correct the 

issue accordingly. 

You may now open the Model in the External Metadata. 

Export comments back to External Metadata Model 
These comments may be exported back to some External Metadata formats (e.g., incorporated as 

Notes on those same objects).  To do so: 

1. Review comments across Model 

2. Export the Model to External Metadata format. 

3. Be sure to indicate how the comments will be exported to the External Metadata tool. 

Trace and Analyze the data flow and semantic lineage of a repository object 
External Metadata Repository Connection Overview 

To obtain a high-level overview of the interconnections defined in the source External Metadata 

Repository one may view the model Connection Overview: 

1. In the configuration Panel either: 

o Right-click on the External Metadata Repository and model Connection 

Overview. 

o Click on the model Connection Overview  icon in the Configuration tool bar. 

2. Or one may open the External Metadata Repository and then click on the model 

Connection Overview  icon in the model Directory tool bar (see Metadata Explorer 

UI User Interface Components). 

 

From here you may: 

 Click on an object and view its properties in the Properties Panel. 

 Right-click on any result and select from the Standard Model Context Menu. 

 Utilize the Standard graphical navigation tool bar 

 Create a bookmark or link to this result. 

 Search for specific objects within a content in the displayed diagram. 

 Right-click on an element or select the Actions ( ) icon for more options. 

 

Model Lineage Analyzer 

To obtain a complete analysis of the lineage defined in the source model one may view the 

model Lineage Analyzer: 

1. Browse to a specific model(see Browse a model). 

2. Open the model. 
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3. Click on the Lineage Overview tab (see Metadata Explorer UI User Interface 

Components). 

 

From here you may: 

 Click on an object and view its properties in the Properties Panel. 

 Right-click on any result and select from the Standard Model Object Context Menu. 

 Utilize the Standard graphical navigation tool bar 

 Create a bookmark or link to this result. 

 Search for specific objects within a content in the displayed diagram. 

 Right-click on an element or select the Actions ( ) icon for more options. 

 

Object Lineage Tracing Options 

The lineage trace is a fully detailed trace of semantic and/or data flow lineage for detailed 

analysis.  Unlike the overview or Lineage Analyzer tab for a model, this presentation allows 

one to narrow in on specific elements and how they relate in terms of data flow and/or 

semantic lineage within a model, External Metadata Repository (data flow only), or 

configuration. 

 

Data flow lineage tracing options 

For data flow tracing, the options include: 

 Trace Data Flow in model – presents the data flow trace (both in terms of impact, or 

forward, and lineage, or backward) for the selected element within the specific model one 

is currently browsing. 

 Trace Data Flow in Configuration – presents the data flow trace (both in terms of 

impact, or forward, and lineage, or backward) for the selected element within a specific 

configuration, either the one that is currently being browsed, or chosen from a pick list. 

 Trace Data Flow (Advanced) – presents the data flow trace for the selected element 

with full control of options: 

o Trace:  

- Data Impact (forward) 

- Data Lineage (backward) 

- Semantic Definition (up) 

- Semantic Usage (down) 

o Scope 
- Model: Just within the opened model 

- Model directory: Within the directory of models containing the opened 

model 

- Configuration: Within the entire selected configuration 

o Configuration 
- Select the configuration 

o Display 

- Text/List 

- Graph/Flow 
o And if you select Graph/Flow then: 

- Show Control Links – Show control flow links (see yellow lines below) 
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- Show Internal Objects – Show objects all objects in lineage 

o Save as default lineage options 

- Save the above selected options so they will be the default in the future.  

Use the Trace Data Flow (Advanced) option again to reset the default. 

-  

Semantic lineage tracing options 

For semantic lineage tracing, the options include: 

 Trace Semantic Definition in Configuration – presents the semantic trace backward to 

a definition of an object.  Of course, many elements will not have direct semantic links 

back to definitions.  Thus, this trace will also look at the (one-to-one) data flow lineage 

back to elements which do have semantic links to definitions.  Thus, if an element with 

semantic definition links can be shown to be truly equivalent (tracing back through the 

data flow lineage with only one-to-one relationships without formulas), then that 

element’s definition semantic information is presented. 

 Trace Semantic Usage in Configuration – presents the semantic trace forward showing 

all semantic usage of the selected element. 

Generally, there are two types of lineage: 

 Data Flow based upon connection definitions to data stores and physical transformation 

rules which transform and move the data 

 Semantic, e.g., detailing the relationships from a conceptual to logical model, or a logical 

to physical model. 

Oracle Metadata Management (OMM) can allow users to display and analyze both types of 

lineage. 

 

In general, the lineage tools within Oracle Metadata Management (OMM) function identically 

whether one is analyzing data flow lineage, semantic lineage or both.  However, the presentation 

is different, as follows: 
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In addition, Oracle Metadata Management (OMM) has four levels of presentation: 
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 configuration model Connections Overview – which is a diagram representing the 

various models contained within a configuration and how they are related (or stitched) to 

each other based upon connection definitions manually assigned to Oracle Metadata 

Management (OMM). 

 External Metadata Repository model Connections Overview – which is a diagram 

representing the various models contained within the directory of a External Metadata 

Repository and how they are related (or stitched) to each other based upon connection 

definitions already provided in the External Metadata Repository. 

 Model Lineage Overview – which is a diagram representing and overview of the lineage 

within a given model. 

 Lineage Trace analysis at the configuration or model level – which is a fully detailed 

trace of semantic and/or data flow lineage for detailed analysis. 

 

  

View attached documents 
1. Browse to a specific model(see Browse a model). 

2. Open the model. 

3. Click on the Attachments tab (see Metadata Explorer UI User Interface Components). 

Print the contents of a page 
1. From any page 

o Click on the More Actions ( ) icon (see Metadata Explorer UI User Interface 

Components) and select Print. 

o Or select the Print ( ) icon, if available. 

2. A print dialog is presented by the internet browser. 

 

Note:  The sort order and column selections, as well as focus in a diagram, on the page being 

printed will be maintained in the printed result. 

Data Preview 
The data preview feature allows on to view the actual data source from which metadata has been 

harvested.  It is only possible for models which are imported directly from either database 

sources or big data sources. 

 

I order to take advantage of this feature, a user with the Manager security role should: 

1. Open the settings for the model 

2. Click on the Data Preview Setup tab 

3. Click on the Show Data Preview Options button 

4. Click the Enable data preview checkbox 

5. Define connectivity information.  Note, this is separate and may be different than the 

connection information in the Import Setup tab. 

6. Specify number of rows to display for a given table 

7. Click the Save button. 

 

Once these setting are saved, one may 
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1. Open the model 

2. Navigate to a table 

3. Right click on the table name and select Data Preview. 
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Harvesting/Importing Metadata 

Harvest a model Generic Principles 
When harvestings a model from source tools and formats, there are several considerations: 

 Ensuring that one has proper connectivity to the external format metadata source.  This 

could be: 

o One or more files 

o An external tool application programming interface (API) 

o An external tool API based upon a client installation 

 Ensuring that one has full access to any auxiliary resources as need.  This depends upon 

the external format one is attempting to connect to, but general examples include: 

o Substitution parameter definition files for tools where substitution variables may 

be defined in the source metadata and are required in order to parse it successfully 

o Connection information to data sources like database connection names 

 

All these requirements are documented in the bridge tool tips, which are available in the Help 

panel on the Import Setup tab. 

 

Many harvest actions will require pointing to files on the Oracle Metadata Management (OMM) 

application server.  The drives available for browsing are controlled by the conf.properties file.  

More details may be found in the Oracle Metadata Management (OMM) ReadMe.html file on 

the application server. 

Harvest a model from External Metadata 
1. Sign in to Oracle Metadata Management (OMM) as a user with Metadata Manager UI 

privileges.  

2. Right click on a folder In the Repository Panel where you want the model to be located, 

and selection New -> model. 

3. Select the General tab in the Create Model dialog. 

4. Enter the Name and Description for the model. 

5. Select the External Metadata import format in the Import From pull-down. 

6. Select the Import Setup tab. 

7. One may select a (remote) server name in the Execute On pull-down in order to use a 

remote bridge server. 

8. For each of the Parameters, complete according to the tool-tips displayed in the right 

hand panel of the dialog.  Be sure to use the remote repository browse function (  icon 

in the parameter entry box) to locate the model you are looking for. 

9. Click the check box Set as default if you wish to automatically set any new imported 

version as the default version. 

10. Click Create. 

11. A dialog will appear asking to import the model.  Click Yes. 

12. The Log Messages dialog then appears and log messages are presented as the import 

process proceeds. 

13. If you receive the Import Successful result, Click Yes to open the model.  If instead 

you see the Import Failed result, inspect the log messages and correct the source 

model file accordingly. 
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14. You may now browse the model. 

Harvest a single model from External Metadata Repository 
Be sure that you have assigned a login for the service, as defined in the installation instructions 

and readme. 

 

1. Sign in to Oracle Metadata Management (OMM) as a user with Metadata Manager UI 

privileges.  

2. Right click on a folder In the Repository Panel where you want the External Metadata 

Repository to be located, and selection New -> Havestable model. 

3. Select the General tab in the Create Model dialog. 

4. Enter the Name and Description for the External Metadata Repository. 

5. Select the correct source format in the Import From pull-down. 

6. Select the Import Setup tab. 

7. One may select a (remote) server name in the Execute On pull-down in order to use a 

remote bridge server. 

8. For each of the Parameters, complete according to the tool-tips displayed in the right 

hand panel of the dialog.   

9. Click the check box Set as default if you wish to automatically set any new imported 

version as the default version. 

10. Click Create. 

11. A dialog will appear asking to import the External Metadata Repository.  Click Yes. 

12. The Log Messages dialog then appears and log messages are presented as the import 

process proceeds. 

13. If you receive the Import Successful result, Click Yes to open the External Metadata 

Repository.  If instead you see the Import Failed result, inspect the log messages and 

correct the import bridge parameters accordingly. 

14. You may now browse the External Metadata Repository. 

Harvest several models from External Metadata Repository 
1. Sign in to Oracle Metadata Management (OMM) as a user with Metadata Manager UI 

privileges.  

2. Right click on a folder In the Repository Panel where you want the model to be located, 

and selection New -> model. 

3. Select the General tab in the Create External Content dialog. 

4. Enter the Name and Description for the model. 

5. Select the External Metadata Repository multiple models import format in the Import 

From pull-down. 

6. Select the Import Setup tab. 

7. One may select a (remote) server name in the Execute On pull-down in order to use a 

remote bridge server. 

8. For each of the Parameters, complete according to the tool-tips displayed in the right 

hand panel of the dialog.  Be sure to use the remote repository browse function (  icon 

in the parameter entry box) to include the folders and models you wish to include. 
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9. Click the check box Set as default if you wish to automatically set any new imported 

version as the default version. 

10. Click Create.  Keep in mind  that this will be a collection of models inside one location 

in Oracle Metadata Management (OMM). 

11. A dialog will appear asking to import the model.  Click Yes. 

12. The Log Messages dialog then appears and log messages are presented as the import 

process proceeds. 

13. If you receive the Import Successful result, Click Yes to open the model.  If instead 

you see the Import Failed result, inspect the log messages and correct the source 

model file accordingly. 

14. You may now browse the model. 

15. You may also define a synchronization schedule so that the collection of models is 

synchronized (re-imported when there are changes) with the External Metadata 

Repository. 

Harvest several models from a directory of External Metadata files. 
It is common for an organization to have a large number of External Metadata files, but does not 

use External Metadata Repository.   Often, this organization would like import the files into 

Oracle Metadata Management (OMM) in batch in an automated fashion.  Oracle Metadata 

Management (OMM) has the ability to support this scenario with the help of a harvesting script. 

 

In this case, the files are stored under a file directory which is accessible to the Oracle Metadata 

Management (OMM) application server.  The script scans the directory and its subdirectories for 

files of the particular External Metadata type and finds matching models under a particular folder 

in Oracle Metadata Management (OMM). The Oracle Metadata Management (OMM) repository 

folder and model structure will match the structure of files and their directories on the file 

system.   When the necessary model does not exist the script creates one and imports the file. 

When the content is present the script will re-import it if the file’s version has not been harvested 

yet.  

 

One can schedule MM to run the script periodically using the Tools  Administration -> 

Schedules tab.  It should allow customers to place files under the directory and be assured that 

Oracle Metadata Management (OMM) will import them automatically.  It will work for any 

single model file-based bridges. 

 

A special model named Settings must also be defined in order to control how the files will be 

imported (what source tool and what bridge parameters). 

 

Create the Oracle Metadata Management (OMM) folder: 

1. Sign in to Oracle Metadata Management (OMM) as a user with Metadata Manager UI 

privileges.  

2. Right click on a folder in the Repository Panel where you want to place the folder 

containing the results of the import and select New  Folder. 

3. Name the folder accordingly. 
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Create the Settings file to control the import of models: 

4. Right click on that new folder in the Repository Panel and select New  Model. 

5. Select the General tab in the Create Model dialog. 

6. Enter “Settings” in the Name for the model. 

7. Select the correct source format in the Import From pull-down. 

8. Select the Import Setup tab. 

o For each of the Parameters, complete according to the tool-tips displayed in the 

right hand panel of the dialog.  In particular,  for the File: parameter : 

1. Click on the  icon and browse for a file inside the directory structure on 

the file system. 

2. Update the File: parameter to so that the path only refers to the top level of 

the directory structure on the file system (i.e., remove the file name and 

any sub-directory names). 

9. Click the check box Set as default if you wish to automatically set any new imported 

version as the default version. 

10. Click Create. 

11. A dialog will appear asking to import the model.  This is very important: Click No. 

Harvest the models on demand: 

1. Right click on that new folder in the Repository Panel and select Scripts  Import new 

versions from folder. 

2. Click on the Run Script button. 

3. The Log Messages dialog then appears and log messages are presented as the import 

process proceeds. 

4. If you receive the Import Successful result, click Yes to open the model.  If instead 

you see the Import Failed result, inspect the log messages and correct the source 

model file accordingly. 

5. You may now browse the models. 

Define a harvesting schedule: 

6. You may also define a harvesting schedule so that the collection of models is 

synchronized (re-imported when there are changes) with the External Metadata. 

Please note, the files will automatically be attached (attach a file to a content) on import. 

Remote harvesting (Remote bridge execution) 
If the specific external tool client software (and associated API) is not available locally on the 

Oracle Metadata Management (OMM) application server, there is the option to create and utilize 

a remote bridge server where this client software is available. 
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Installing a remote bridge server is equivalent to installing Oracle Metadata Management 

(OMM) on an application server, except that no license is required and thus it will not have an 

available web based UI.  Please refer to the installation instructions for more details. 

 

To add a remote bridge server to Oracle Metadata Management (OMM) after it is installed and 

running: 

1. Go to Tools  Administration  Servers 

2. Click on Add 

3. Specify 

a. The Name to refer to this remote server by 

b. the URL for this remote server (generally one only need update the machine 

name inside the URL signature suggested) 

c. The Server Location  to control how files are transferred from and to the remote 

bridge server: 

 Local – File Copy 

 Remote – Upload/Download 

 Remote over WAN – Compresses the files before uploading downloading 

d. A Description 

4. Click Save 

 

When harvesting using a remote bridge server, one would perform the same steps as for any 

other harvesting activity with the exception of selecting server name in the Execute On pull-

down. 

Attach a file to a content 
1. Sign in to Oracle Metadata Management (OMM) as a user with Metadata Manager UI 

privileges. 

2. Right click on a content in the Repository Panel you wish to add a file attachment to and 

selection Open. 

3. Click on the Manage attachments ( ) icon. 

4. Click on the Add ( ) icon. 

5. Browse for the file you wish to attach and select it. 

6. You may edit the Description text box next to the file now listed. 

To remove an attachment, select the attachment and use the Delete icon or right-click on the 

attachment and select Delete. 

One may also Edit ( ) the attachment description later. 

Publish a content 
After importing or Uploading a content to the Repository, it may be necessary to place the 

resulting model into a configuration. A configuration is a hierarchical collection of models 

which: 

 Can be Published, or made available to users of the Metadata Explorer UI 

 Provides a scope for Repository-wide browsing, searches and analysis 
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In short, a configuration allows the Administrator of the Repository ensure the completeness and 

correctness of what is visible to business users and how all users search and analyze within the 

full complexity of the Repository. 

1. Sign in to Oracle Metadata Management (OMM) as a user with Metadata Manager UI 

privileges.   

2. Open the Published configuration. 

3. Drag and drop the content you wish to Publish from the Repository Panel into the 

Published configuration. 

4. You may now view the content when signed into the Metadata Explorer UI. 

Schedule automated harvesting (Scheduled Oracle Metadata Management 
(OMM) Synchronization of models) 

1. Sign in to Oracle Metadata Management (OMM) as a user with Metadata Manager UI 

privileges. 

2. Right click on a model or folder in the Repository Panel and select Settings. 

3. Select the Schedule tab in the Settings dialog. 

4. Specify the schedule information. 

5. Save the changes.  

The above steps ensure that each time the content is harvested, a new version is created.  

However, it will also be necessary to update (and validate) any configurations containing the 

mart with this latest version, before it is available to Metadata Explorer UI users or available for 

configuration based analysis.  To do so, first define the configuration (s) for automatic update.  

Now, schedule automatic validation for the configuration: 

1. Go to Tools -> Administration -> Schedules. 

2. Click on Add. 

3. In the Add a new schedule dialog. 

4. Enter an appropriate name and description for the schedule. 

5. Drag the configuration (or containing folder) from the Repository Panel to the Object 

box. 

6. Select the Update configurations script. 

7. Specify the schedule information.  In general, this will be scheduled for just after the 

harvest of the mart. 

8. Add the new schedule.  
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Metadata Version & Configuration Management 

Manage model versions 
In some cases, one may wish to use the Repository to maintain a version history for each harvest 

or Upload of a model.  These versions are individual objects within the Repository and represent 

the object’s contents at a specific point in time. 

 

The Administrator may manage any number of versions.  By default, however, the Metadata 

Manager UI only shows one version of a model.  The technical user may change to a multi-

version user interface mode at any time.  In addition, a particular version may be designated to 

be the default version. It is the default version of a model which is used when the Metadata 

Manager UI is in single-version mode.  

 

In addition, when including a model in a configuration, one is actually including a specific 

version of that model in the configuration.  This means that one may control which versions of 

which models are to be Published at any point in time.  E.g., one may place the approved version 

of a model in a Published configuration while data modelers continue to edit and Upload newer 

version as work in progress (unpublished). 

 

The user of the Metadata Explorer UI is restricted to a single configuration, and thus in all cases 

the Metadata Explorer UI only shows one version of a model.   

Show / Hide content and configuration versions 
1. Sign in to Oracle Metadata Management (OMM) as a user with Metadata Manager UI 

privileges.   

2. Go to Tools  Preferences the Application Header. 

3. Use the check box to either show or hide versions. 

Add a new version to a model 
Adding a new version of a model simply involves harvesting or Uploading the model again. 

Review import log 
1. Sign in to Oracle Metadata Management (OMM) as a user with Metadata Manager UI 

privileges.   

2. Right click on the model for which you want to view the log messages and select View 

log. 

3. As a model may be imported several times, select the log for the specific date and time of 

the import in question and click on View Log. 

Publish a version of a content 
4. Sign in to Oracle Metadata Management (OMM) as a user with Metadata Manager UI 

privileges.   

5. Open the Published configuration. 

6. Be sure the Repository Panel is filtered to show the content versions. 

7. Drag and drop the content you wish to Publish from the Repository Panel into the 

Published configuration. 

https://sites.google.com/a/metaintegration.info/miti-development/users/john-friedrich/ca-erwin-web-portal/getting-started/concepts-and-overview/using-the-repository-panel
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8. You may now view the content when signed into the Metadata Explorer UI. 

Manage Configurations 
The Configurationis an extremely important concept. It is the scope for many operations, 

including lineage analysis, search, version management, etc. In this way, what would otherwise 

be an overload of information (everything in the repository) is instead well managed according to 

the Configurationof metadata one is interested in analyzing or working with. The name 

Configuration comes from the concept of "Version & Configuration Management" where a 

Configurationis a collocation of particular version of models. 

 

A valid Configurationconsists of a collection of model versions, mapping versions, glossaries 

and stitchings. The model versions relate to data stores and data processes that have been 

harvested into Oracle Metadata Management (OMM).  

 

A Configurationmay be understood as any of the following: 

 Repository workspace - a collection of repository objects to be analyzed together (search, 

browse, reports, etc.) as a technical scope, or business area under the same access permission 

scope. 

 Enterprise architecture - a collection of data store models (ODS, data staging areas, data 

warehouses, data marts, etc.) and data process models (ETL/DI, and BI) connected together 

through data flow stitching. 

 Design workflow - a collection of conceptual, logical and physical models connected 

(semantically stitched) together through semantic mappings modeling the design process. 

 

A Configurationmay have one or more Configuration versions. Configuration versions may be 

understood each as a different collection of versions of repository objects. In this way, one can 

define several Configuration versions, each containing various versions of the repository objects. 

As a result, one may perform 

 Historical analysis using Configuration versions containing older versions of models 

which were deployed at some time in the past 

 What-if analysis using Configuration versions containing the versions of models which 

may be deployed in the future. 

 

One may also publish a Configuration version., or make it available to users of the Metadata 

Explorer UI. In this way, a Configuration may be used by an administrator of MIMM to ensure 

the completeness and correctness of what is visible to business users and how all users search 

and analyze within the full complexity of Oracle Metadata Management (OMM). 

 

Oracle Metadata Management (OMM) accomplishes this management within the UI by way of 

the Configuration Manager. This tool provides a drag and drop based visual interface for 

constructing configurations of repository objects.  One may: 

 Define any number of Configurations 

 Publish a Configuration to a different set of users (by group) 

 Publish none, some, or all Configurations. 

 



Help on Metadata Manager 
 

July 2016 Copyright © 2016, Oracle and/or its affiliates. All Rights Reserved. (7/18/2016) Page 54 of 97 
 All trademarks, trade names, service marks and logos referenced herein belong to their respective companies 

 

In this way, one has infinitely fine control of who sees what and when they may see it. 

Create a new configuration 
1. Sign in to Oracle Metadata Management (OMM) as a user with Metadata Manager UI 

privileges.   

2. Right click on a folder In the Repository Panel where you want the configuration to be 

located, and select New -> Configuration. 

Assign a group to a configuration 
Groups may be assigned to a particular configuration.  In this way, any users who are associated 

with that group are provided with the Metadata Explorer UI and presented with only that 

configuration. 

 

Publish a configuration 
1. Sign in to Oracle Metadata Management (OMM) as a user with Metadata Manager UI 

privileges.   

2. If you have not already done so: 

o Create a new configuration. 

3. Right click on the configuration in the Repository Panel and select Publish. 

4. Assign a group to that configuration. 

Publish a content to any configuration 
1. Sign in to Oracle Metadata Management (OMM) as a user with Metadata Manager UI 

privileges.   

2. If you have not already done so: 

o Create a new configuration. 

o Assign a group to that configuration. 

o Right click on the configuration in the Repository Panel and select Publish. 

3. Open the configuration. 

4. Drag and drop the content you wish to Publish from the Repository Panel into the 

configuration. 

5. You may now view the content when signed into the Metadata Explorer UI as a user who 

is assigned the group above. 

Manage configuration structure 
The contents contained within a configurations may be organized into configuration folders.  

This organizational structure will be reflected in the Metadata Explorer UI when browsing for 

contents. 

 

1. Sign in to Oracle Metadata Management (OMM) as a user with Metadata Manager UI 

privileges.   

2. Open the configuration you wish to define or update the structure for. 

3. Use the Add action of  the configuration editor to add a folder and the Delete action to 

remove one. 

4. Drag and drop contents into folders, or the root, to reorganize them. 
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Stitching models together for data flow mapping 
Some External Metadata models may contain data movement source specifications and data 

movement rules.  These are in turn imported into Oracle Metadata Management (OMM).  In 

many cases, these data movement source specifications may match up with another External 

Metadata model which was imported separately.  Such data movement specification models may 

then be added to a configuration and may be “stitched” together with that second model, where 

one model is the complete representation of a source that is defined in another with data 

movement specifications. 

 

To do so: 

1. Sign in to Oracle Metadata Management (OMM) as a user with Metadata Manager UI 

privileges.   

2. Open the configuration you wish to contain these stitched models. 

3. Drag a model containing these data movement rules into the configuration. 

4. Drag another model into the configuration which fully defines the same data store as a 

data source specification in the first model (the one with data movement rules). 

5. Right-click on the first model (the one with data movement rules) and select Edit 

Connections. 

6. In the Edit Connections dialog, associate each data movement source specification with 

a model (the second model in this case) which represents or matches that source. 

7. Click OK. 

8. Click on the Validate action. 

One may then report on data flow lineage between these two (or more) models. 

Browse the Configuration architecture 
Once stitched, the relationships among repository objects in a Configuration can be visualized 

producing a data flow and semantic based architecture diagram.  One may edit the layout and 

annotate these diagrams using the Configuration manager. 

 

To obtain a high-level configuration overview of the architecture defined by a configuration one 

may view the Architecture Diagram: 

1. Open the Configuration you wish to contain these stitched repository objects. 

2. Select the Architecture Diagram tab. 

 

From here you may: 

 Click on an object and view its properties in the Properties Panel. 

 Right-click on any result and select from the Standard Model Context Menu. 

 Utilize the Standard graphical navigation tool bar 

 Create a bookmark or link to this result. 

 Search for specific objects within a content in the displayed diagram. 

 Right-click on an element or select the Actions ( ) icon for more options. 

 Click on the Edit action and edit the diagram. 
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Edit Configuration architecture diagram 
1. Sign in to Oracle Metadata Management (OMM) as a user with Metadata Manager UI 

privileges.   

2. Open the Configuration you wish to contain these stitched repository objects. 

3. Select the Architecture Diagram tab. 

4. Click on the Edit action. 

 

From here you may: 

 Click on an element and view its properties in the Properties Panel. 

 Drag elements into new positions in the diagram Right click on the Subject Areas 

element and add a subject area. 

 Click on the Annotation ( ) icon to create and edit annotations for a diagram. 

 Click on the Layout ( ) icon to lay the diagram out automatically.  This cannot be 

undone unless you refresh the browser and thus lose all your changes in this session. 

Setting up a configuration for automatic update 
Configurations may be defined for automatic update (and hence publication) of new content 

versions.  In this way, each time a new version of a model is harvested (say, based upon a 

schedule) or Uploaded using the External Metadata tool, that new version of the model will be 

reflected as a member of the Published configuration. 

 

1. Sign in to Oracle Metadata Management (OMM) as a user with Metadata Manager UI 

privileges.   

2. If creating a new configuration 

o Create a new configuration 

o Check the Automatic Update checkbox 

3. If updating an existing configuration 

o Right click on a configuration in the Repository Panel and select Settings. 

o Check the Automatic Update checkbox 

Manage configuration versions 
In some cases, one may wish to maintain a version history for a configuration.  E.g., one may 

wish to maintain historical configurations of content versions for historical analysis.  In addition, 

one may wish to perform what-if analysis by placing the latest, but not approved, version of the 

contents in a new (and unpublished) version of that configuration.   

 

As with contents, these Configuration versions are individual objects within the Repository and 

represent the configuration of the contents at a specific point in time. 

 

The Administrator may manage any number of Configuration versions.  By default, however, the 

Metadata Manager UI only shows one version of a configuration.  The Metadata Manager UI 

may be changed to a multi-version user interface mode at any time. 

 

Additionally, when one sets a version of a configuration to Published status, it is then available 

to users of the Metadata Explorer UI.  I.e., one is actually designating a specific version of that 
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configuration as the Published version.  This means that one may Publish a precise collection of 

content versions.   

 

In all cases, the Metadata Explorer UI only shows the Published version of a configuration, 

which is simply seen as the configuration. 

Publish a version of a content to any configuration version 
When one sets a version of a configuration to Published status, it is then available to users of the 

Metadata Explorer UI.  I.e., one is actually designating a specific version of that configuration as 

the Published version.  This means that one may Publish a precise collection of content versions.   

 

In all cases, the Metadata Explorer UI only shows the Published version of a configuration, 

which is simply seen as the configuration. 

 

1. Sign in to Oracle Metadata Management (OMM) as a user with Metadata Manager UI 

privileges.   

2. Be sure the Repository Panel is filtered to show the content versions. 

3. If you have not already done so: 

o Create a new configuration. 

o Assign a group to that configuration. 

o Right click on the configuration version in the Repository Panel and select 

Publish. 

4. You may create 

5. Open the configuration. 

6. Drag and drop the content you wish to Publish from the Repository Panel into the 

configuration. 

7. You may now view the content when signed into the Metadata Explorer UI as a user who 

is assigned the group above. 

External Metadata Publishing to Oracle Metadata Management (OMM) 

Upload (publish from External Metadata) a model 
1. Open a model in External Metadata (be sure that any changes you have made are saved). 

2. Go to File -> Portal -> Publish. 

3. For each of the Parameters, complete according to the tool-tips displayed in the bottom 

panel.  Here is an example: 

o Repository URL: http://portalhostname:19980/MM/services 

o User name: Administrator (Be sure to select a user with Admin privileges) 

o Password: password 

o Repository content path: <empty> 

o Publish to configuration: True 

o Repository configuration path: <empty> 

o Attachment files: <empty> 

o Wait for repository operation completion: True 

https://sites.google.com/a/metaintegration.info/miti-development/users/john-friedrich/ca-erwin-web-portal/getting-started/concepts-and-overview/using-the-repository-panel
https://sites.google.com/a/metaintegration.info/miti-development/users/john-friedrich/ca-erwin-web-portal/getting-started/concepts-and-overview/using-the-repository-panel
https://sites.google.com/a/metaintegration.info/miti-development/users/john-friedrich/ca-erwin-web-portal/getting-started/concepts-and-overview/using-the-repository-panel
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In the above example, the model will be placed in the public folder as well as 

included in the default (“Published”) configuration. 

4. Click Finish. 

5. Inspect the log file to be sure no errors occurred.  Also, consider correcting any warnings 

in the original model file and re-publish. 

6. Click OK. 

The model is now Uploaded and Published to the specified configuration. 
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Data Governance with Business Glossary 
Data Governance 
Critical to the development and management of a complete data architecture is a Business 

Glossary.  Oracle Metadata Management (OMM) provides an ISO 11179 based Business 

Glossary to capture, define, maintain and implement an enterprise Business Glossary of 

terminology, data definitions, code sets, domains, validation rules, etc.  In addition, semantic 

mappings describe how elements in a source model (more conceptual like the Business Glossary) 

define elements in a destination model (closer to an implementation or representation). 

 

The Business Glossary helps an enterprise to reach agreement between all stakeholders on their 

business assets (e.g. terms) and how they relate to data assets (e.g. database tables) and 

technology assets (e.g. ETL mappings).  The Business Glossary can be used to document 

logical/physical data entities and attributes across IT collaboratively. Again, it involves tracing 

dependencies between business and technical assets. 

 

The business glossary 
 

In Oracle Metadata Management (OMM), a business glossary is a self-contained collection of 

categories and the terms sub-categories contained within each category.  In turn, the terms may 

be semantically mapped to objects throughout the rest of the repository, such as tables and 

columns in a data model.  Once mapped, one may perform semantic lineage traces such as 

definition lookups and term semantic usage across any configurations containing the business 

glossary, mappings and mapped objects. 

 

Building a business glossary can be as simple as dragging in an existing well documented data 

model, via import from other sources via a CSV file format, or can be populated directly via the 

user interface as well as during the process of classifying objects in other data store models.  In 

general, a combination of such methods are employed in conjunction with one another. 

 

In order to ensure that the business glossary is accurate, up-to-date, available to all who need 

access to it and integrated properly with the rest of the metadata in the repository, Oracle 

Metadata Management (OMM) also provides a robust collection of Data Governance tools and 

methodologies.  The Oracle Metadata Management (OMM) business glossary provides a very 

flexible workflow and publication process that may alternatively be quite sophisticated or quite 

simple depending upon one’s needs.  In addition, one may maintain any number of business 

glossaries, each with different workflow and publication characteristics. 

 
The Business Glossary may be part of your lineage, will appear in the repository panel and when  

you open a Business Glossary, you will presented with a different UI than for other (harvestable) 

models. 

 

Glossary Workflow 
By default, a business glossary will have no workflow requirement (including no approval 

process).  In this simple state changes made to the business glossary are reflected immediately 

throughout the system.  This is a very useful mode for organizations that did not want the 
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complexity of a workflow process.  It is also useful for other organizations when they are first 

building and populating a business glossary and related semantic mappings. 

 

The Oracle Metadata Management (OMM) also provides a very flexible and complete set of 

possible workflow and publication processes that one may employ.   Choose these processes 

carefully, as once selected they cannot be undone or changed. 

 

When your company would like to have a formal glossary development process that involves 

multiple users you can enable the glossary workflow. The workflow is prepackaged sequence of 

glossary activities around term proposal, review, acceptance, publishing and depreciation. It is a 

flexible process that can be customized to require only publishing activity, approval with or 

without review, approval and review by one or multiple users, etc.  

 

Workflow roles 
A user with the Administrator security role can enable the workflow and assign the following 

workflow roles to Categories: 

 Editor 

 Reviewer 

 Approver 

 Publisher 

 

A workflow role can be assigned to users and applies to all terms in the category. A Category 

inherits all user-to-role assignments from the parent category and can have additional ones. 

 

Stewards 
Stewards are users or groups of users who are assigned as point of contact to answer questions 

for specific terms or entire categories.  They have no special workflow role assignments based 

upon their stewardship assignment. 

 

Workflow process options 
The workflow process applies to terms, but not categories. All changes to Categories made in the 

Manager UI are immediately visible (published) in the Explorer UI. When the workflow is 

enabled you cannot delete a category that has published terms.  

 

The most complete workflow possible is in the diagram below: 

You can enable the workflow when you create the glossary or after. You cannot disable the 

workflow after it has been enabled. 

Workflow Action Workflow Role 
Editor Reviewer Approver Publisher 
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Propose Candidate X X X X 
Create Draft X    
Discard X    
Start Review X    
Mark for Deprecation X    
Submit for Approval X    
Send to Draft X    
Recommend Approval  X   
Request Change  X   
Reject (Awaiting Approval)   X  
Approve   X  
Reject (Approved)    X 
Publish    X 
Publish (Deprecate)    X 
Create, edit or remove attributes and 
relations 

X X X  

Create comments X X X X 
Edit or remove comments X X X  
Create, edit or remove attachments X  X  
Assign roles to users and groups   X  
Start/stop workflows and reassign 
tasks 

X  X  

 

Term management dashboards 
Workflow driven search criteria are available allowing one to efficiently organize terms and 

identify what requires action at any given time.  These include: 

 Show all my candidate terms 

 Show all my draft terms 

 Show all terms under my review 

 Show all terms pending my approval 

 Show all term ready for me to publish 

 

Workflow transition buttons 
When working with individual terms which are at some point in the workflow process, workflow 

transition buttons prompt you with possible actions, e.g., if  a term is in Draft status, then the 

action icons would include: 

 Start Review 

 Submit for Approval 

 Mark for Deprecation 

 Discard 

 

Versions 
The business glossary is one of the content types Oracle Metadata Management (OMM) 

supports. As a content, it can have multiple versions. You can employ different business glossary 
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workflow strategies that involve one, two and multiple versions of the glossary. Here are some 

options: 

 Simple - single version  

 Dev vs. Prod - development and published versions 

 Snapshots - historical versions 

 

The business glossary may be part of your lineage, will appear in the repository panel, and when 

you open a business glossary you will presented with a different UI than for other (harvestable) 

models. 

 

Categories  

A business glossary is organized into categories, which may then contain terms or other 

categories.  Categorization can help with: 

 Subset by subject matter or organizational structure 

 Managing stewardship assignments (at the category level) 

 

Relationships  

Terms may be cross-linked in a wide variety of relationship types, including: 

 Synonyms 

 See Also 

 More General 

 More Specific 

 Contains 

 Contained By 

 Represents 

 Represented By 

 

Simply edit a specific term to do so. 

View and edit a Business Glossary 
To edit a Business Glossary: 

1. Sign in to Oracle Metadata Management (OMM) as a user who is assigned the Editor 

workflow role to the Business Glossary you wish to document.  

2. Navigate to the Business Glossary using the Repository panel  

3. To open the Business Glossary to be viewed and or edited, you may: 

o Right click on a model in the Repository panel and select Open. 

o Double-click on a  modelin the Repository panel 

o Drag a  modelin the Repository panel into header of the Workspace Panel where 

the tabs are. 

4. You are then presented with the  Business Glossary Editor. 

From here you may: 

 All actions that are available for a harvestable model are also available here with a 

Business Glossary. 
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 Click on a term and view its properties in the Properties Panel.  Here you may also edit 

many of the properties. 

 Right-click on any term or category and select Open to view and edit further. 

 Click on the Open Category (expansion triangle) next to any category to view the 

contents. 

 Move terms to other categories. 

 Click on an term or category and Delete (trashcan) the selected terms and categories. 

 Click on a term and select Trace Semantic Usage for terms which will produce semantic 

usage reports for the selected term. 

 Click on a term and select Assign Workflow Roles to assign roles in the workflow to 

users and groups of users. 

 Click on a term or category and select Download Audit Log which will produce an audit 

log. 

 Click on an term or category and select Export to CSV File to produce a CSV version of 

the selected element. 

 Click on the Add ( ) icon to add a term or category. 

 Click on the Edit ( ) icon to change to bulk edit mode where one can edit each line in 

the Business Glossary panel as if it were part of a spreadsheet.  Remember, one may 

always add and remove columns and sort in order to make the editing easier. 

 Additional actions which apply to the overall Business Glossary (right-hand side of the 

header): 

o Import from a CSV File ( ) icon to import from a CSV file in the same format 

as the export. 

o Bookmark ( ) icon to Create a bookmark or link to this result 

o Search for specific objects within a Business Glossary by using the search box in 

the header, including selecting a workflow dashboard (workflow driven search 

criteria). 

o Use the Actions ( ) icon for more options, including: 

- Show in Repository - show the specific location of this model in the 

Configuration 

- Set Default – to make this the default version of the Business Glossary 

- Edit Semantic Usage Mapping – To use the mapping editor to edit the 

semantic mappings between the Business Glossary and other models. 

Search for a term 
To search for a term: 

1. Sign in to Oracle Metadata Management (OMM) as a user who is assigned a workflow 

role to the Business Glossary you wish to document.  

2. Navigate to the Business Glossary using the Repository panel  

3. To open the Business Glossary to be viewed and or edited, you may: 

o Right click on a model in the Repository panel and select Open. 

o Double-click on a  modelin the Repository panel 

o Drag a  modelin the Repository panel into header of the Workspace Panel where 

the tabs are. 

4. You are then presented with the Business Glossary Editor. 
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5. Enter text in the search criteria and click on the search icon. 

6. You are the presented with a list of search results where you may still use the bulk edit 

and multiple edit functions. 

View Term Management Dashboards 
Workflow based search criteria, or dashboards, are available as part of the search capability.  

They are only available (and only meaningful) if you have specified a workflow process for the 

business glossary. 

1. Sign in to Oracle Metadata Management (OMM) as a user who is assigned a workflow 

role to the Business Glossary you wish to document.  

2. Navigate to the Business Glossary using the Repository panel  

3. To open the Business Glossary to be viewed and or edited, you may: 

o Right click on a model in the Repository panel and select Open. 

o Double-click on a  modelin the Repository panel 

o Drag a  modelin the Repository panel into header of the Workspace Panel where 

the tabs are. 

4. You are then presented with the Business Glossary Editor. 

5. Use the pull-down next to the search criteria and click on one of the dashboards: 

o Show all my candidate terms 

o Show all my draft terms 

o Show all terms under my review 

o Show all terms pending my approval 

o Show all term ready for me to publish 

 

Depending upon the workflow role you are assigned, some of the items may or may not be 

enabled.   

Trace Semantic Usage 
One can produce a lineage report showing all data elements which are semantically mapped to a 

particular term in the business glossary. 

1. Open the Business Glossary. 

2. Navigate to the proper location (term) to be the context for the report. 

3. Either: 

 Right-click and select Trace Semantic Usage 

 Open the term and select Trace Semantic Usage. 

Add a term 
1. Sign in to Oracle Metadata Management (OMM) as a user who is assigned the Editor 

workflow role to the Business Glossary you wish to document.  

2. Navigate to the Business Glossary using the Repository panel. 

3. To open the Business Glossary to be viewed and or edited, you may: 

o Right click on a model in the Repository panel and select Open. 

o Double-click on a  modelin the Repository panel 

o Drag a  modelin the Repository panel into header of the Workspace Panel where 

the tabs are. 

4. You are then presented with the  Business Glossary Editor. 



Help on Metadata Manager 
 

July 2016 Copyright © 2016, Oracle and/or its affiliates. All Rights Reserved. (7/18/2016) Page 65 of 97 
 All trademarks, trade names, service marks and logos referenced herein belong to their respective companies 

 

5. Click on an Add ( ) icon and select term/category depending upon whether you wish to 

add a term or a category. 

o Edit term in Business Glossary 

o For a category, simply specify the name the Properties panel. 

Note: If there is a workflow process defined for the business glossary then the term will be a 

Candidate term and you will be working on a draft. 

Edit a Term 
1. Sign in to Oracle Metadata Management (OMM) as a user who is assigned the Editor 

workflow role to the Business Glossary you wish to document.  

2. Navigate to the Business Glossary using the Repository panel. 

3. To open the Business Glossary to be viewed and or edited, you may: 

 Right click on a model in the Repository panel and select Open. 

 Double-click on a  modelin the Repository panel 

 Drag a  modelin the Repository panel into header of the Workspace Panel where 

the tabs are. 

4. You are then presented with the  Business Glossary Editor. 

5. You may either: 

 Navigate to the term and select and open the term 

 Search for the term and select and open the term 

 Use the bulk edit on the list of terms or search results 

6. When navigating to the term, you have access to: 

  Add linked terms by clicking on the Add ( ) icon next to the link type. 

 Add notes by clicking on the Add ( ) icon. 

 Add a custom attribute by click on that pull-down and selecting the specific 

custom attribute already defined. 

 

Note: If there is a workflow process defined for the business glossary then instead you must use 

the Create Draft action button to start the editing process. 

Assign workflow roles 
A user with the Administrator security role can enable the workflow and assign the following 

workflow roles to Categories: 

 Editor 

 Reviewer 

 Approver 

 Publisher 

 

A workflow role can be assigned to users and applies to all terms in the category. A Category 

inherits all user-to-role assignments from the parent category and can have additional ones. 

The workflow process applies to terms, but not categories. All changes to Categories made in the 

Manager UI are immediately visible (published) in the Explorer UI. When the workflow is 

enabled you cannot delete a category that has published terms.  
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You can enable the workflow when you create the glossary or after. You cannot disable the 

workflow after it was enabled. 

1. Sign in to Oracle Metadata Management (OMM) as a user who is assigned the Approver 

workflow role to the Business Glossary you wish to document.  

2. Navigate to the Business Glossary using the Repository panel. 

3. To open the Business Glossary to be viewed and or edited, you may: 

 Right click on a model in the Repository panel and select Open. 

 Double-click on a  modelin the Repository panel 

 Drag a  modelin the Repository panel into header of the Workspace Panel where 

the tabs are. 

4. You are then presented with the  Business Glossary Editor. 

5. Navigate to a category where you wish to assign a workflow role to. 

6. Right-click on the category and select Assign Workflow Roles. 

 

Workflow Action Workflow Role 
Reviewer Editor Approver Publisher 

Create, edit or remove an asset  X X  
Create, edit or remove attributes and relations X X X  
Create, edit or remove comments X X X  
Create, edit or remove comments/attachments  X X  
Assign roles to users and groups   X  
Start/stop workflows and reassign tasks  X X  
Publish an asset    X 
 

Editor Workflow Role 

The Editor is responsible for creating, revising and shepherding terms through the approval 

process. The Editor can import terms into the glossary from files or create them manually. These 

terms start in the Draft status.  The workflow can allow any glossary user to propose a term. A 

proposed term starts in the Candidate status. The Editor of the category where the term is 

proposed can accept the term by promoting it to Draft or deleting it. The user who created the 

term can edit and delete it as long as it is Candidate. 

 

When the approval activity is disabled the Editor is solely responsible for the terms’ workflow. 

In this case, the Editor takes on the Publisher’s responsibilities and can publish terms when the 

Editor deems ready. 

 

Reviewer Workflow Role 

The Reviewer is a subject matter expert (SME) responsible for assessing and commenting on 

assets under development. The Reviewer can list assets assigned to him/her for the review and 

comment, endorse or dismiss them individually. Each of the assets offer the Reviewer the 

Comment, Recommend for Approval and Request Change buttons. Pressing the buttons 

allows the user to explain the decision with a comment. 

 

The Request Change action sends the asset back to Draft. The Editor is responsible for 

implementing requested changes or providing clarifications and re-submitting the asset for 

review again. The review is an iterative activity. 
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Approver Workflow Role 

The Approver is an accountable decision maker who is responsible for rejecting or approving 

new assets of changes to published assets.  The Approve action advances the asset to the 

Approved status. The Reject action returns the asset to the Draft status.  

 

The approval activity is a part of the workflow process by default. The Administrator can disable 

it by setting the “Allow approval of terms” to No. to , specify Number of  required Approvers 

necessary to and enable and configure the approval activity to progress automatically to the 

approval activity when the required number of recommendations is reached. You can disable the 

automatic progression by setting the number to 0. In this case, the Editor is responsible to tally 

the review results and submit the asset for approval then it is appropriate.  

 

Publisher Workflow Role 

The Publisher is an accountable decision maker who is responsible for publishing assets.  Oracle 

Metadata Management (OMM) provides two UIs, Manager and Explorer. The Manager UI is the 

repository development environment. The Explorer UI is designed for reviewing the repository 

content by business users. You can use the Manager UI to create new and edit existing glossary 

objects. If you do not want your business users to see unfinished glossary changes in the 

Explorer UI you can enable the workflow. The workflow includes Publishing always.  

 

When the workflow is enabled you can make multiple changes to different glossary objects and 

publish all changes at once or groups of changes at a time. When the workflow is disabled all 

changes made in the Manager UI are immediately visible in the Explorer UI.  You can change an 

object by editing its attributes (e.g. description) and adding/removing its relationships (e.g. 

contains). When the workflow is enabled the Manager UI shows all unpublished changes 

specially (e.g. yellowish background color). It allows to view differences between published and 

unpublished versions of attributes and relationships (e.g. button to show differences in a popup 

dialog or inline). 

 

When the workflow is enabled terms show their Publishing status in Manager UI. The 

application sets the attribute’s value automatically.   A new term is Unpublished. When the 

approval activity is enabled the Publisher can only publish Approved terms. The Administrator 

can configure the workflow to publish terms automatically when they are approved. 

Assign a Steward 
1. Sign in to Oracle Metadata Management (OMM) as a user who is assigned the Editor 

workflow role to the Business Glossary you wish to document.  

2. Navigate to the Business Glossary using the Repository panel. 

3. To open the Business Glossary to be viewed and or edited, you may: 

o Right click on a model in the Repository panel and select Open. 

o Double-click on a  modelin the Repository panel 

o Drag a  modelin the Repository panel into header of the Workspace Panel where 

the tabs are. 

4. You are then presented with the  Business Glossary Editor. 

5. You may either: 
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o Navigate to the term and select and open it 

o Search for the term and select and open it 

o Use the bulk edit and edit multiple on the list of terms or search results.   

6. Click on the browse ( )icon and select a user as the steward. 

 

Note, only users who either have been identified as possible stewards are members of a group of 

user identified as possible stewards can be selected from the pull-down list. 

Set the status of a term 
You may not set the status of a term by editing it.  Instead, you will use the workflow transition 

buttons presented to you based upon: 

 The workflow processes enabled for the specific business glossary 

 The status of the term you are editing. 

 

Note: If there is no workflow process defined for the business glossary then the term will always 

be in Published status and there is no need to set it. 

List terms status 
You may set the status of multiple terms from either a list a category contents or as the result of a 

search.  You may either: 

 Click on the column header to include status as a column to display, and then sort on that 

column 

 Click on More Search Options and select the status in the search filters. 

List terms by Steward assignment 
You may set the steward of multiple terms from either a list a category contents or as the result 

of a search.  You may either: 

 Click on the column header to include steward as a column to display, and then sort on 

that column 

 Click on More Search Options and select the steward in the search filters. 

Bulk Edit 
Either when browsing the terms in a category or when browsing a search result, you may use the 

bulk edit function: 

 Click on the Edit ( ) icon to change to bulk edit mode where one can edit each line in 

the Business Glossary panel as if it were part of a spreadsheet.  Remember, one may 

always add and remove columns and sort in order to make the editing easier. 

 Click again on the Edit ( ) icon to end the bulk edit mode and return to normal 

Business Glossary edit behavior. 

Edit multiple 
When in the Bulk Edit mode, you may also edit multiple terms at the same time: 

 Click on the Edit ( ) icon to change to bulk edit mode. 

 Select multiple rows using: 

o The check boxes to the left 
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o The check box at the top of the list for all 

o Shift-click and Ctrl-click 

Map (classify) Terms to objects in other models 
1. Sign in to Oracle Metadata Management (OMM) as a user who is assigned the Editor 

workflow role to the Business Glossary you wish to document.  

2. You may navigate to the mapping directly using the Repository panel 

3. Or you may open the Business Glossary to be viewed and or edited, you may: 

o Right click on a model in the Repository panel and select Open. 

o Double-click on a  modelin the Repository panel 

o Drag a  modelin the Repository panel into header of the Workspace Panel where 

the tabs are. 

And then select Edit Semantic Usage Mapping and pick a mapping. 

4. You are then presented with the Mapping Editor. 

5. From here, each term mapped using the mapping editor will be a classification of that 

term and provide semantic lineage from the term to the element in the other model. 

Extend the attributes defined in the Business Glossary 
The Business Glossary is quite extensible and allows one to define any number of additional 

attributes for terms and categories. 

1. Sign in to Oracle Metadata Management (OMM) as a user who has Metadata Manager UI 

privileges to the Business Glossary you wish to document.  

2. Navigate to the Business Glossary using the Repository panel. 

3. To open the Business Glossary you may: 

o Right click on a model in the Repository panel and select Open. 

o Double-click on a  modelin the Repository panel 

o Drag a  modelin the Repository panel into header of the Workspace Panel where 

the tabs are. 

4. Click on an the Attribute Manager tab. 

5. Click on an Add ( ) icon and  

o Provide a Name for the attribute. 

o Select Term/Category depending upon whether you wish to add a new attribute 

to terms or categories. 

o Specify the Data Type of the attribute: 

 String – Any text 

 Date – Date field 

 Enumeration – List of possible values, which you many then specify 

below 

o Default Value to assign to this attribute initially. 

o Click on Add. 

Create a Business Glossary 
1. Sign in to Oracle Metadata Management (OMM) as a user with Metadata Manager UI 

privileges.   
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2. Right click on a folder In the Repository Panel where you want the Business Glossary to 

be located, and selection New -> Business Glossary. 

3. Select the Properties tab in the Create Business Glossary dialog. 

4. Enter the Name and Description for the Business Glossary. 

5. You may specify a workflow process for the business glossary. 

6. Click Create. 

7. The Business Glossary will open automatically. 

Specify the workflow process for a Business Glossary 
1. Sign in to Oracle Metadata Management (OMM) as a user with Metadata Manager UI 

privileges.   

2. Right click on a folder In the Repository Panel where you want the Business Glossary to 

be located, and selection New -> Business Glossary. 

3. Select the Workflow tab in the Business Glossary dialog. 

4. Check the workflow entries you wish to specify. 

5. Click Save. 

The most complete workflow possible is in the diagram below: 

 

Populate (bootstrap) a Business Glossary from a model 
1. Sign in to Oracle Metadata Management (OMM) as a user with MetadataManagerUI 

privileges.   

2. Open the Business Glossary to populate. 

3. Drag a model from the Repository Panel to the Business Glossary. 

4. Specify the Term Status (in the lifecycle) to assign all terms to be populated (created 

from the original model). 

5. Check whether or not to Create a new Category in the Business Glossary where all the 

populated terms will be created. 

6. Check whether or not to Create a semantic mapping between the Business Glossary and 

the original model (from where all the populated terms will be derived) so that semantic 

lineage may be traced to and from the terms and objects in the original model. 

7. Enter the Name for the semantic mapping. 

8. Click Import. 

9. The Log Messages dialog then appears and log messages are presented as the import 

process proceeds. 

10. If you receive the Import Successful result, click Yes to open the model.  If instead 

you see the Import Failed result, inspect the log messages and correct the source 

model file accordingly. 

11. You may now edit the Business Glossary. 
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Export Business Glossary to a CSV file 
1. Open the Business Glossary for editing. 

2. Navigate to the proper subset (category) to export. 

3. Click on the Actions ( ) icon and select Export to CSV. 

4. The CSV format file will be downloaded locally. 

Import Business Glossary from a CSV file 
One can bootstrap a business glossary, or import from existing business glossary type systems, 

using a pre-defined CSV file format.  You may find sample of this in the installation folder on 

the Application server at <installation-

folder>\conf\Glossary\GlossaryImportSample.csv. 

1. Open the Business Glossary for editing. 

2. Navigate to the proper location (category) to be the context to import in to. 

3. Click on the More action and select Import. 

4. Select a CSV format file saved locally. 

5. To see the format for this file, simple Export a subset of an existing Business Glossary to 

Excel. 

 

The sample CSV file has documentation inside, explaining the formatting. 

Produce and Audit Log 
One can produce an audit log of activity at any level in the business glossary. 

4. Open the Business Glossary. 

5. Navigate to the proper location (category or term) to be the context for the report. 

6. Right-click and select Download Audit Log. 

Documenting a Data Store 
The Oracle Metadata Management (OMM) allows users to document existing data stores, like 

databases, big data sources, imported as models in Oracle Metadata Management (OMM), and 

publish the resulting documented data stores to the enterprise. 

 

Data modeling tools have been conceived as database design tools to be use by data architects 

and database administrator to design logical and physical data models generating DDL. Although 

many of these data modeling tools are rather used to document (create a data model) of existing 

databases. Oracle Metadata Management (OMM) offers a different approach than traditional data 

modeling tool: 

 The Business Glossary driven methodology allows for immediate reuse and creation of 

Terms and naming standards on the fly, fast tracking the data store documentation 

process 

 The Web enabled tool offers better access than Desktop tools 

 The Data Modeling / Diagramming capabilities of the Oracle Metadata Management 

(OMM) are similar to conventional data modeling tools 

 Full integration (import/export) to most popular data modeling tool. 
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Oracle Metadata Management (OMM) can import undocumented metadata directly from a data 

store or External Metadata model.  When documenting a model, one may: 

 Add business names and descriptions to objects, like tables and columns 

 Document relationships including  

o Cardinality 

o Join conditions 

o Verb phrases 

o to better understand interrelated objects 

 Organize and view objects graphically using diagrams and subject areas 

 Annotate diagrams. 

 

In addition, these data stores change over time. Oracle Metadata Management (OMM) protects 

an investment in documenting data stores by supporting the migration of existing documentation 

to new data store versions automatically.  

 

Finally, Oracle Metadata Management (OMM) has a business glossary application that allows 

one to manage terminology and domain definitions across the enterprise. One can reuse these 

definitions not only among different enterprise applications but between versions of the same 

application.   A glossary may be used to collect and apply naming standards based upon the 

name assignments made when editing a documentable model.  In addition, the Oracle Metadata 

Management (OMM) allows one to link tables and columns to terms and glossary domains and 

business rules. 

Create a Physical Data Model 
1. Sign in to Oracle Metadata Management (OMM) as a user with Metadata Manager UI 

privileges.   

2. Right click on a folder In the Repository Panel where you want the model to be located, 

and selection New -> Physical Data Model. 

3. Select the Properties tab in the Create Physical Data Model dialog. 

4. Select the local or remote harvesting server to use 

5. Select the correct source format in the Import From pull-down. 

6. Select a glossary to be linked to this model. 

7. Select the Import Setup tab. 

8. For each of the Parameters, complete according to the tool-tips displayed in the right 

hand panel of the dialog.  Here is an example: 

o File: click on the magnifying glass icon and browse for a file. 

o Leave all other parameters with the defaults. 

9. Click the check box Set as default if you wish to automatically set any new imported 

version as the default version. 

10. Select the Naming Standard tab. 

o Specify a glossary (and category inside) already to be used as a naming standard 

to derive logical names and descriptions for this Physical Data Model.   

o Select the naming standard rules to apply 

o Specify Supervised Learning 

11. Click Create. 

12. A dialog will appear asking to import the model.  Click Yes. 
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13. The Log Messages dialog then appears and log messages are presented as the import 

process proceeds. 

14. If you receive the Import Successful result, click Yes to open the model.  If instead 

you see the Import Failed result, inspect the log messages and correct the source 

model file accordingly. 

Manage a Physical Data Model in the Metadata Manager UI 
One may view and edit the diagram(s) of a physical data model: 

o Use the Actions icon for more options, including: 

 Select a table or column and right-click and select Show in Diagram 

 Select a table of column and click on the Show in Diagram ( ) icon 

 Select a diagram and double-click, right-click and Open. 

In this diagram the usual actions apply as for any diagram in Oracle Metadata 

Management (OMM). 

 

o Use the Actions ( ) icon for more options, including: 

 Show in Repository - show the specific location of this model in the Configuration 

 Unset Default – Set/Remove default setting on this version of the physical data model 

 View Log – View logs for any action executed against the model 

 Compare with previous version – Compare this version with previous versions of the 

Physical Data Model 

 Edit Semantic Definition Mapping – ??? 

 Edit Semantic Usage Mapping – ??? 

o Right-click on the physical data model in the Repository panel for more options, including: 

 Export – Export the physical data model to the External Metadata format 

Edit a Physical Data Model 
One uses the Metadata Explorer UI to edit a physical data model.  Thus, first include the physical 

data model inside a published configuration so that it will appear in the Metadata Explorer UI 

Migrate (bootstrap) logical properties to a Physical Data Model from another 
model 
In addition to manually editing the logical properties and defining diagrams and relationships for 

a Physical Data Model, one may migrate this information from an existing model, perhaps 

harvested from External Metadata.  To do so: 

1. Open the physical data model 

2. Click on any existing model in the Repository panel and drag it into the central  Model 

Browser panel of the physical data model. 

3. Confirm the creation of a new version of the physical data model and migration of logical 

elements. 

Naming standard for a Physical Data Model. 
Abbreviation/Naming standard can help one to derive business names from physical ones in a 

consistent manner. For example, a physical name empl_first_name can be interpreted as a 

business name Employee First Name by tokenizing the physical name over the “_” separator, 
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assuming “empl” is an abbreviation of “employee” and capitalizing the first letters of each word.  

This process is automated by Oracle Metadata Management (OMM) based upon any defined 

naming standard.  

 

A naming standard is a list of abbreviations and words they represent, defined as terms in a 

glossary. Oracle Metadata Management (OMM) allows one to define a naming standard once 

and reuse it for documenting different models and their new versions.   

 

Oracle Metadata Management (OMM) can generate an initial naming standard from a physical 

model. It is a list of all unique abbreviation tokens produced from table and column physical 

names. The application tokenizes names by separating characters (e.g. “_”)  and capitalized 

letters (e.g. EmployeeName). The application cleanses the list from obvious noise (e.g. 

numbers).  

 

To associate a glossary with a Physical Data Model for naming standard purposes, you may do 

so at model creation time or when editing the Settings of the model. 

Naming standard supervised learning 
When supervised learning is specified in the Naming Standards tab for the documentable model, 

every time you edit the (logical) Name property for columns and tables, the associated naming 

standard business glossary category terms will be updated to reflect the new naming.  E.g., if and 

column has the Physical Name ACT, and then one edits the (logical) Name to be Action, a term 

Action will be created with and Abbreviation ACT. 

 

One may apply the naming standard on demand as needed. 

Apply a naming standard 
To do so, when editing a physical data model use the Apply naming standard icon. 

Export documented physical data model to External Metadata format(s) 
As Oracle Metadata Management (OMM) allows one to produce a fully documented data model, 

one can export this model to a data modeling tool. 

9. Browse to a specific physical data model. 

10. Either: 

o Open the physical data model 

1. Click on the More Actions icon. 

2. Select Export. 

o In the Repository panel 

1. Right-click on the physical data model or a specific version thereof 

2. Select Export. 

11. Select the External Metadata export format in the Export to pull-down. 

12. For each of the Parameters, complete according to the tool-tips displayed in the right 

hand panel of the dialog.  Be sure to use the remote repository browse function 

(magnifying glass icon in the parameter entry box) to include the folders and models you 

wish to include. 

13. Click Export.  A dialog will appear asking to import the model.  Click Yes. 
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14. The Log Messages dialog then appears and log messages are presented as the export 

process proceeds. 

15. If you receive the Operation Successful result, click Close to open the model.  If 

instead you see the Operation Failed result, inspect the log messages and correct the 

issue accordingly. 

16. You may now open the model in the External Metadata. 

 Data Mapping Specifications for Data Flow Lineage & Impact Analysis 
Some data flow processes are not harvestable using the bridges provided as a part of the 

Metadata Import/Export tool suite.  Of course, if these processed are not modeled in Oracle 

Metadata Management (OMM), it will leave gaps in the lineage and impact analysis answers and 

provide an incomplete picture of the physical architecture of your systems. 

 

In order to address these gaps and produce proper lineage and impact results, Oracle Metadata 

Management (OMM) has a Data Mapping Specifications editing and management toolset.  Data 

Mapping Specifications are essentially simply high-level logical (or notional) definitions of the 

way data “flows” from some number of source models into elements of a target model.  These 

mappings are specified using a simple web based drag and drop type mapping specification 

editor and are defined using descriptive text and one may also define pseudo operations using an 

operation editor. 

 

The Data Mapping Specifications form a content within Oracle Metadata Management (OMM) 

which defines logical mappings between source and target data stores.  The data stores 

themselves are modeled separately as model contents within Oracle Metadata Management 

(OMM) but external to the Data Mapping Specifications, as shown in this diagram: 

 
 

Each data store model content is referenced as either a source, a target, or can be both a source 

and target.  One may then drag and drop objects (e.g., schemas, tables or columns) in a data 

source onto objects in a data target, thus creating maps.  These maps may then be documented in 

descriptions or with more explicit operations. 
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Create Data Mapping Specifications 
1. Sign in to Oracle Metadata Management (OMM) as a user with Metadata Manager UI 

privileges.   

2. Right click on a folder In the Repository Panel where you want the mapping to be 

located, and selection New -> Data Mapping Specifications (of whichever type). 

3. Select the Properties tab in the Create Mapping dialog. 

4. Enter the Name and Description for the mapping. 

5. Click Create. 

6. Drag the source for the mapping to the Source in the mapping workspace. 

7. Drag the destination for the mapping to the Destination in the mapping workspace. 

8. You may now edit the mapping. 

Edit the Data Mapping Specifications 

1. Sign in to Oracle Metadata Management (OMM) as a Metadata Explorer UI user which 

has Metadata Manager UI privileges to the mapping you wish to edit.  

2. Navigate to the mapping directly using the Configuration panel (see Metadata Explorer 

UI User Interface Components). 

3. Click on the Mapping Editor tab. 

4. To create a mapping, navigate to the source element on the left panel and the destination 

element on the right element and drag the left element onto the right element. 

Once you have a map defined, you may: 

 Edit the Description, Operation and Status for the map in the Mapping Details panel 

below the Destination panel.  You may 

o Click on the Edit action next to the Source/Operation text box to edit the 

expression by: 

1. Drag Source elements into the text box to include them in the Operation 

2. Type any operation text 

3. Drag Source elements into the Description text box to include their 

Business Name in the Description and type any other text. 

 Update/Set the Status of the map. 

 Remove any Source element mapping by selecting the map and clicking on the Remove 

Map button. 

For both the Source and the Destination panels, you may: 

 Use the navigation arrows to move forward and back in the history of elements browsed. 

 Select a level to navigate to in breadcrumbs pulldown. 

 Search for elements using both 

o Search Business Glossary 

o Search Current Location 

 Filter the elements displayed to show only: 

o Show Mapped 

o Show UnMapped 

o Show InScope Objects 
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o Show out of Scope Objects 

 Show in Repository – show the location in the Repository Panel of this version of the 

source or destination model selected. 

 Include/Exclude a selected element in the Data Mapping Specifications scope 

 Set Default – set the opened version of the mapping to be the default 

 

For the Destination panel, you may: 

 Update/Set the Status of the map. 

 Create a bookmark and email or retrieve a link to the map. 

 Define sort criteria for the map by selecting the Destination columns to sort by and the 

order in which to sort. 

For the Source panel, you may: 

 Split the Source panel into more than one browse panel in order to browse and select 

from multiple classifiers. 

 Right click on any level column and Show in Metadata Browser. 

Include a Data Mapping Specifications in a Configuration 
In order to visualize lineage you must include the Data Mapping Specifications in a 

Configuration. 

1. Sign in to Oracle Metadata Management (OMM) as a user with Metadata Manager UI 

privileges.   

2. Open the configuration in the Repository Panel where you want the mapping to be 

located. 

3. Drag the mapping in the Repository Panel to the configuration. 

4. A dialog may appear t to include any source or destination models to include.   

5. You may now manage the configuration normally. 

Scope of effort and status for Data Mapping Specifications  
When defining a task for mapping, it is often important to first define a scope for the mapping 

effort.  In general, this scope is simply a specification of which source and target elements should 

be included in the resulting mapping. 

 

Secondly, one would like to track progress as the effort progresses.  It could take some time to 

collect the proper information to document and certify all of the mapping definitions (and 

potentially operations).  Thus, one would like to track the status of each mapping and report on 

this. 

Set scope of Data Mapping Specifications 
1. Browse to the specific Data Mapping Specifications content and open it. 

2. Navigate to a specific column in the Target Panel 

3. Right-click on the element and select Exclude or Include 

o Note: one can use ctrl-click and shift-click multi-select actions to include or 

exclude groups of elements at a time. 
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Filter by scope for a Data Mapping Specifications 
1. Browse to the specific Data Mapping Specifications content and open it. 

2. In either the Source or Target Panel click on the Filter ( ) icon and un-check Show 

Out of Scope Objects 

Set status of a Mapping in a Data Mapping Specifications 
1. Browse to the specific Data Mapping Specifications content and open it. 

2. Navigate to a specific column in the Target Panel 

3. Click on the More Actions ( ) icon or right-click on the element and select Status -> 

and the status you want to assign: 

 In Progress 

 Completed 

 Approved 

Filter by status for a Data Mapping Specifications 
1. Browse to the specific Data Mapping Specifications content and open it. 

2. In either the Source or Target Panel click on the Filter ( ) icon and un-check or check 

the particular statuses to hide or show in the filter. 

Review status of Data Mapping Specifications 
1. Browse to the specific Data Mapping Specifications content and open it. 

2. Navigate to a specific column in the Target Panel 

3. Click on the More Actions ( ) icon and select View Column Status or click on the 

element and select the View Column Status button. 

Semantic Mappings for Semantic Lineage and Definition 
The model mapper may be used to define either semantic (meaning) or data flow relationships 

among models in Oracle Metadata Management (OMM).  It consists of the mapping editor and 

mapping reporter. 

 

In general, a Semantic Mapping describes how elements in a source model (more conceptual) 

define elements in a destination model (closer to an implementation or representation).  Put the 

other way, elements in the destination model are representations or implementations of the 

associated element in the source model. 

 

A Semantic Mappingis a relationship between two contents in the repository.  It consists of one 

or more mapping elements, which are relationships defined between a destination element and 

one or more source elements.  Descriptive information may be associated with a mapping 

element. 

 

There are three primary use cases for construction a Semantic Mapping: 

 Data Standardization and Compliance: 

In this case one is defining semantic links from an external standard data model (e.g.. the 

healthcare HL7 standard data model) to a physical data store (harvested by a live 

database) and an enterprise data model (harvested from a data modeling tool) 
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 Multi Level Modeling of semantic relationships from conceptual to logical, and to 

physical data model with a few sub cases: 

o From an Object Model to a Data Model 

A UML Object Model (harvested from an object modeling / code development 

tool) semantic links to IDEF1X Data Model (harvested from a data modeling tool) 

o Between Multi-Vendor Data Models 

A conceptual data model (harvested from a data modeling tool) semantic links to 

a logical data model (harvested from another vendor’s data modeling tool. 

o From a Data Model to the actual Database implementation harvested from a live 

database 

 Business Glossary term classification: 

In this case, one is classifying terms in a Business Glossary through a Semantic Mapping 

from the business glossary to another model.  The target model in this case may be any 

data modeling single or multi-model as well as any business intelligence reporting model 

(where supported by the available bridges). 

Create a Semantic Mapping: 
1. Sign in to Oracle Metadata Management (OMM) as a user with Metadata Manager UI 

privileges.   

2. Right click on a folder In the Repository Panel where you want the mapping to be 

located, and selection New -> Mapping (of whichever type). 

3. Select the Properties tab in the Create Mapping dialog. 

4. Enter the Name and Description for the mapping. 

5. Click Create. 

6. Drag the source for the mapping to the Source in the mapping workspace. 

7. Drag the destination for the mapping to the Destination in the mapping workspace. 

8. You may now edit the mapping. 

Please note, after having defined a semantic mapping from a business glossary to a BI report 

(when these bridges are enabled) one may also update a semantic mapping in the Metadata 

Explorer UI by using the Glossary tab.  Please see the Metadata Explorer UI help documentation 

for more details. 

Edit a Semantic Mapping 

1. Sign in to Oracle Metadata Management (OMM) as a MetadataExplorerUI user which 

has Metadata Manager UI privileges to the mapping you wish to edit.  

2. Navigate to the mapping directly using the Configuration panel (see Metadata Explorer 

UI User Interface Components). 

3. Click on the Mapping Editor tab. 

4. To create a mapping, navigate to the source element on the left panel and the destination 

element on the right element and drag the left element onto the right element. 

Once you have a map defined, you may: 

 Document the mapping using the Description and/or Operation text boxes 
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 Remove any element mapping defined by clicking on the Delete Map ( )icon. 

For either the source or the destination panels, you may: 

 Navigate using the Next and Previous ( ) icons 

 Search for elements using both 

o Search Business Glossary 

o Search Current Location 

 Filter the elements displayed to show only: 

o Show All 

o Show Mapped Only 

o Show UnMapped Only 

 Select any level element (e.g., table) and Remove All Maps. 

For the entire mapping you may: 

 Show in Configuration - show the specific location of this mapping in the Configuration 

 Set Default – set the opened version of the mapping to be the default. 

 

Please note, after having defined a semantic mapping from a business glossary to a BI report 

(when these bridges are enabled) one may also update a semantic mapping in the Metadata 

Explorer UI by using the Glossary tab.  Please see the Metadata Explorer UI help documentation 

for more details. 

Include a Semantic Mapping in a Configuration 
In order to visualize lineage you must include the Semantic Mapping in a Configuration. 

 

6. Sign in to Oracle Metadata Management (OMM) as a user with Metadata Manager UI 

privileges.   

7. Open the configuration in the Repository Panel where you want the mapping to be 

located. 

8. Drag the mapping in the Repository Panel to the configuration. 

9. A dialog may appear t to include any source or destination models to include.   

10. You may now manage the configuration normally. 

General Features of Mapping Editors 
These are general features which apply to both Semantic Mappings and Data Mapping 

Specifications. 

Report on a Mapping 

1. Sign in to Oracle Metadata Management (OMM)as a Metadata Explorer UI user which 

has Metadata Manager UI privileges to the mapping you wish to edit.  

2. Navigate to the mapping directly using the Configuration panel (see Metadata Explorer 

UI User Interface Components). 

3. Click on the Mapping Reporter tab. 
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From here you may: 

 Click on any element to see properties 

 Add/Remove columns and sort 

 Click on the Source name or Destination name and open that content. 

 

For the entire mapping you may: 

 Show in Configuration - show the specific location of this mapping in the Configuration 

 Set Default – set the opened version of the mapping to be the default. 

Include a Mapping in a Configuration 
1. Sign in to Oracle Metadata Management (OMM)as a user with Metadata Manager UI 

privileges.   

2. Open the configuration in the Repository Panel where you want the mapping to be 

located. 

3. Drag the mapping in the Repository Panel to the configuration. 

4. A dialog may appear t to include any source or destination models to include.   

5. You may now manage the configuration normally. 

Export a Mapping to Excel 
One may export Data Mapping Specifications or a Data Mapping Design to a Microsoft Excel 

spreadsheet format.  The process is the same for both data mapping objects: 

17. Browse to a specific Data Mapping content and open it. 

18. Click on the More Actions ( ) icon . 

19. Select Export to Excel. 

20. The Log Messages dialog then appears and log messages are presented as the export 

process proceeds. 

21. If you receive the Operation Successful result, click Close and open the Excel 

spreadsheet.  If instead you see the Operation Failed result, inspect the log messages 

and correct the issue accordingly. 

22. You may now open the Data Mapping in Microsoft Excel. 

Import a Mapping from Excel 
One may import Data Mapping Specifications or a Data Mapping Design from a Microsoft Excel 

spreadsheet format.  The process is the same for both data mapping objects: 

1. Browse to a specific Data Mapping content and open it or create a new one. 

2. Click on the More Actions ( ) icon . 

3. Select Export to Excel. 

4. The Log Messages dialog then appears and log messages are presented as the export 

process proceeds. 

5. If you receive the Operation Successful result, click Close and open the Excel 

spreadsheet.  If instead you see the Operation Failed result, inspect the log messages 

and correct the issue accordingly. 

6. You may now open the data mapping in Microsoft Excel. 
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Special features when semantically mapping from a business glossary 
As the business glossary is a repository authored object, i.e. it is edited and maintained within 

Oracle Metadata Management (OMM), when mapping from a business glossary to another 

model, one may drag from the right panel (destination) to the left panel (business glossary 

source) to both create a new term in the business glossary and create a semantic mapping. 

1. Sign in to Oracle Metadata Management (OMM) as a MetadataExplorerUI user which 

has Metadata Manager UI privileges to the mapping you wish to edit.  

2. Navigate to the mapping directly using the Configuration panel (see Metadata Explorer 

UI User Interface Components). 

3. Click on the Mapping Editor tab. 

4. To create a new term and matching mapping: 

o Navigate to the context (category in the business glossary for the new term in the 

source or left panel element 

o Navigate to the destination element in the right panel to be used as the basis for 

creating the term 

o Drag the right element onto the left panel 
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Administration 

User Group Administration 
Each user of the system is assigned one or more groups.  Each group assigned to a user controls 

the user interface associations (Metadata Manager UI or Metadata Explorer UI) and security 

roles assigned (Viewer/Editor/Manager).  Security roles are then associated with the types of 

permissions one has to an object in Oracle Metadata Management (OMM). 

 

The basic configuration of Oracle Metadata Management (OMM) has one group defined, which 

may not be removed: 

 Administrators – Users assigned this group are given all security roles and may use the 

Metadata Manager UI or Metadata Explorer UI. 

 

A user assigned to the Administrators group may create any number of groups with different 

user interface assignments and access security role assignments. 

 

NOTE: All security role related operations are available to both users and user groups.   

 

There are two types of security roles in Oracle Metadata Management (OMM): 

 A security role can be assigned to users and groups and applies to repository objects, like 

folders and contents. 

 A workflow role typically applies to a particular content type and its workflow (see 

Workflow process for details (e.g., business glossary workflow). 

 

Below is a table of security role assignments and the permissions they provide: 

Permissions by object type Security roles with the 
permission 

Viewer Editor Manager 
Folders 

View X   
Edit the folder properties, like description  X  
Create, delete and move child folders and content   X 

Any Content 
View X   
Add comments and labels X   
Edit the content properties, like description  X  
Create and delete child versions, like import model  X X 
Edit version properties  X  
Set default version   X 
Archive   X 
Manage security role assignments   X 

Havestable Content 
Configure import parameters  X  
Import new version  X  
Configure trigger and schedule   X 
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Business Glossary Content 
Edit business glossary  X  
Enable and disable workflow   X 
Assign workflow roles   X 

Documentable data model 
Assignment of business glossary and configuration of naming 
standards 

 X  

Document with business glossary terms  X  
Edit the semantic mapping  X  

Data and Semantic Mapping 
Add, remove and replace models in mapping  X  
Add, remove and edit maps, including operation and 
description 

 X  

Set mapping status   X 
Configuration 

Add, remove and replace contents and edit connections  X  
Publish a version   X 

Create a new group 
1. Sign in to Oracle Metadata Management (OMM) as a user assigned to the group 

Administrators.  

2. Go to Tools -> Administration. 

3. Select the Groups tab. 

4. Click on the Add action in the header. 

5. Provide Name and, Description. 

6. Check Steward to include the members of this group in the list of possible stewards 

7. Check Use Metadata Explorer to assign all the members of this group to the Metadata 

Explorer UI. 

8. Select a published configuration from the Default Configuration search box. 

Assign security roles to a repository object 
Keep in mind that in order to have any security role assignments on a child object in Oracle 

Metadata Management (OMM), one must at least have the Viewer security role to its parent.  

Thus, in order to create portions of the repository which are entirely inaccessible to a group, you 

may create a new folder at the root of the Repository Panel in order to assign special Viewer 
security role assignments privileges there. 

 

1. Sign in to Oracle Metadata Management (OMM) as a user assigned to the group 

Administrators.  

2. Locate the content, configuration or folder you wish to assign security role assignments 

to 

3. Go to the Security tab. 

4. Assign security role assignments by group (please see table below). 

Please note: The security roles that you set for a configuration apply to the configuration, not its 

contents.  Thus, when you assign a group or user to the Editor security role on that configuration 
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then they have the ability to, e.g. add a model to the configuration, but does not necessarily have 

permissions to edit the contained models within the configuration. 

Instead, each model in the configuration may also have its own security role assignments.  Thus, 

if you wish to be able to edit the contained model properties, you will need to assign the Editor 
security role to that user or group.  This is a very powerful feature that allows one to control who 

is Editor or Manager for individual models in a configuration, separately from security role 

assignments to the configuration itself. 

One other note, while security roles assignments are not inherited through the configuration, 

security role assignments are inherited through the actual folder structure in Oracle Metadata 

Management (OMM).  Thus, if you assign a group or user to the Editor security role for a parent 

folder (e.g., "public") then all contained contents and folders are included in those security role 

assignments. 

Below is a table of security role assignments and the permissions they provide: 

Permissions by object type Security roles with the 
permission 

Viewer Editor Manager 
Folders 

View X   
Edit the folder properties, like description  X  
Create, delete and move child folders and content   X 

Any Content 
View X   
Add comments and labels X   
Edit the content properties, like description  X  
Create and delete child versions, like import model  X X 
Edit version properties  X  
Set default version   X 
Archive   X 
Manage security role assignments   X 

Havestable Content 
Configure import parameters  X  
Import new version  X  
Configure trigger and schedule   X 

Business Glossary Content 
Edit business glossary  X  
Enable and disable workflow   X 
Assign workflow security roles   X 

Documentable data model 
Assignment of business glossary and configuration of naming 
standards 

 X  

Document with business glossary terms  X  
Edit the semantic mapping  X  

Data and Semantic Mapping 
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Add, remove and replace models in mapping  X  
Add, remove and edit maps, including operation and 
description 

 X  

Set mapping status   X 
Configuration 

Add, remove and replace contents and edit connections  X  
Publish a version   X 

Download group report 
1. Sign in to Oracle Metadata Management (OMM) as a user assigned to the group 

Administrators.  

2. Go to Tools -> Administration. 

3. Select the Groups tab. 

4. Click on the Download action in the header. 

User Authentication Login Modes 

The Native/LDAP Authentication mode 
In this mode, users may be defined as either a native (local) or LDAP authenticated user.  When 

logging in, if the user name is associated with a native user the system will authenticate that user 

with native authentication (based on the local password).  Otherwise, the system will attempt to 

authenticate the username with LDAP authentication (requiring the LDAP connection to be 

configured). 

 

You will know that the LDAP connection is enabled when the LDAP button is highlighted in 

yellow.  

 

Configure the LDAP connection 

1. Sign in to Oracle Metadata Management (OMM) as a user assigned to the group 

Administrators.  

2. Go to Tools -> Administration. 

3. Select the Users tab. 

4. Click on the LDAP action in the header. 

5. Complete the 

o Type of LDAP system (e.g. “Microsoft Active Directory” by default) 

o URL (e.g. ldap://MyLdapServer) 

o User Name (and matching Password) with sufficient privileges to query the 

needed LDAP users and groups. 

In addition, one may use the Advanced button to customize how the LDAP user attributes (login 

(username, full name, e-mail, description, etc.) are automatically populated by appropriate LDAP 

attributes (e.g. sAMAccountName is used by default for login on Microsoft Active Directory). 

The LDAP authentication can be disabled (gray LDAP icon) by deleting the LDAP URL.  In 

such case, only native authentication will be in effect. 
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Create a new native user 

Native users are manually created/updated by the Administrator. A Native user is required to 

have a password defined at the creation time.  Native Users can coexist with LDAP Users, which 

may be useful in creating temporarily logins for administrators, support, consultants, etc. 

 

1. Sign in to Oracle Metadata Management (OMM) as a user assigned to the group 

Administrators.  

2. Go to Tools -> Administration. 

3. Select the User tab. 

4. Use the Add action in the header. 

5. Provide a username unique to this user. 

6. Provide a password for the user to log in with. 

7. Provide the other identifying user information. 

8. Assign a group to a user. 

Delete a user 

You may delete any user.  However, LDAP and externally authenticated users will be recreated 

if that user signs in and is again properly authenticated. 

1. Sign in to Oracle Metadata Management (OMM) as a user assigned to the group 

Administrators.  

2. Go to Tools -> Administration. 

3. Select the User tab. 

4. Select the user from the list. 

5. Use the Delete action in the header. 

Create a new LDAP user 

There is no need to create an LDAP user manually.  Instead, an LDAP user is automatically 

created/updated as a result of a successful LDAP authentication login.  Thus, all that is required 

is that the user/password combination is valid for the LDAP authentication connection 

definitions and query rules. 

 

The LDAP user attributes (login, full name, e-mail, description, etc.) are automatically mapped 

to selected LDAP attributes (e.g. sAMAccountName is used by default for login on Microsoft 

Active Directory).  In addition, one may change this mapping using the Advanced LDAP 

connection button.  

The External Authentication mode 
Configuration of Oracle Metadata Management (OMM) to support an external SSO environment 

requires working with your System Administrator.  In this mode, the system default login page is 

disabled and not presented.  It must be replaced by an external authentication login system.  

 

Note that Administrators can always login even in External Authentication Mode using the 

dedicated administrator rescue login URL: http://localhost/MM/Admin. 

 

Please refer to the readme for more details. 

 

http://localhost/MM/Admin
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Add an external authentication user 

External authentication users are automatically created/updated by successful external 

authentication login.  They are assigned groups according to the rules provided by the 

authentication system, or the guest group by default.   

One may specify additional group assignments manually (see Assign a group to a user). 

Download user report 
A complete report of users may be downloaded. 

1. Sign in to Oracle Metadata Management (OMM) as a user assigned to the group 

Administrators.  

2. Go to Tools -> Administration. 

3. Select the Users tab. 

4. Click on the Download action in the header. 

Review user statistics 
Detailed user session statistics may be downloaded. 

1. Sign in to Oracle Metadata Management (OMM) as a user assigned to the group 

Administrators.  

2. Go to Tools -> Administration. 

3. Select the User tab. 

4. Select the user from the list. 

5. In the panel at the bottom, click on Show Statistics. 

6. Use the Statistics For: control in the header to change the period for which statistics are 

presented. 

User Group Assignment 
Users may be assigned to one or more groups, as defined in user group administration.  Each 

group assigned controls the user interface associations (Metadata Manager UI or Metadata 

Explorer UI) and security roles assigned (Viewer/Editor/Manager). 

Native Group Assignment 
Native group assignment applies to all native users.  It may also apply to LDAP users when the 

LDAP Driven Group Assignment is not enabled (which is the case by default).   In this case, one 

may configure the LDAP connection setting up LDAP authentication without specifying how 

groups will be assigned when an LDAP user logs in.   Thus, users will be authenticated using 

LDAP and these users will not be assigned to any group.   

 

In all these cases, any group assignments may be made as follows: 

 

1. Sign in to Oracle Metadata Management (OMM) as a user assigned to the group 

Administrators.  

2. Go to Tools -> Administration. 

3. Select the User tab. 

4. If you have not already done so create a new user. 

5. If you have not already done so create a new group. 

6. Assign the selected group to the user. 
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Define administrative users 

Administrative users are those who are assigned the group Administrator.  To create an 

administrative user: 

 

1. Sign in to Oracle Metadata Management (OMM) as a user assigned to the group 

Administrator.  

2. Go to Tools -> Administration. 

3. Select the User tab. 

4. If you have not already done so create a new user. 

5. Assign the Administrator group to the user. 

LDAP Driven Group Assignment 
The LDAP configuration window offers a second tab for LDAP driven group assignment.  In this 

case, the groups assignments may be associated to predefined LDAP groups or queries.  There 

are two convenience features helping non LDAP experts retrieve/build the group assignments 

they need: 

 

1. The LDAP group data entry allows one to search for groups defined in your LDAP 

environment and retrieve the exact LDAP query for such groups. This is very useful 

when planning to use large predefined groups of business users in group assignment. 

2. The LDAP search filter data entry allows one to automatically build a proper query to 

create an LDAP based virtual group of users.  This is very useful in creating small 

Administrator groups or temporarily groups for a project. 

In order to create queries defining LDAP driven group assignment: 

1. Sign in to Oracle Metadata Management (OMM) as a user assigned to the group 

Administrator.  

2. Go to Tools -> Administration. 

3. Select the User tab. 

4. Select LDAP Authentication from the authentication type pull-down in the header. 

5. Click on LDAP in the header. 

6. Click on the Group Assignment tab. 

7. Click on the Add ( ) icon. 

8. Enter the following: 

a. Provide a Name for the query 

b. Define the group you wish to associate with users in the query 

c. To assign groups by group name: 

i. Click on the Browse ( ) icon in the Group entry 

ii. Enter a group name in the LDAP system or search text 

iii. Select the Distinguished Name for that group 

d. To specify a search filter and include individual users, you may 

i. Specify a Search Root 

like:CN=company,CN=Users,DC=company,DC=local 
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ii. Click on the Browse ( ) icon in the Search Filter entry and select users 

in that filter. 

e. Alternatively, to specify a search filter and exclude individual users, you may 

i. Specify a Search Root: 

CN=company,CN=Users,DC=company,DC=local 
ii. Use the following syntax: 

(&(!(sAMAccountName=username1))(!(sAMAccountName=

username))) 
9. Click OK. 

 Please keep in mind, when you create the first LDAP query for group assignment, you are now 

switching from native (manually managed) group assignment to LDAP driven (automatic) group 

assignment for all LDAP users. Any LDAP user will lose any previous native group assignment 

at the next login. 

Similarly, when deleting the last LDAP query for group assignment, you are now switching from 

LDAP driven (automatic) group assignment, to native (manually managed) group assignment.  

Any LDAP user will now be only associated to the "Guest" group, until more groups are 

manually granted to that user. 

External Group Assignment 
For external group assignment, one may: 

 Log in as that user to establish that user in Oracle Metadata Management (OMM), and 

then assign groups manually 

 Pass group assignments to Oracle Metadata Management (OMM) from the external 

single sign on system. 

Multiple Group Assignments 
One may assign more than one up to any number of groups to a given user.  In doing so: 

 The user then has the union of all security role assignments provided by those groups 

 If any of the groups assigned to the user are defined as restricted to the Metadata Explorer 

UI 

o Then whenever the user first signs in, they are presented with the Metadata 

Explorer UI and given a choice of configurations from the union of all 

configurations the groups assigned have access to. 

o It is possible at this time or subsequent sign-ins to define a default configuration. 

o They may change configurations at any time going to 

BrowseConfigurationChange Configuration. 

o They may always use the Top Right menu in the Metadata Explorer UI to go to 

the Metadata Manager UI, if at least one group assigned to the user is NOT 

restricted to the Metadata Explorer UI. 

 If none of the groups assigned to the user are defined as restricted to the Metadata 

Explorer UI 

o Then whenever the user first signs in they are presented with the Metadata 

Manager UI. 
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o They may always use the Administrative Tools menu to go to the Metadata 

Explorer UI. 

 If one of the groups assigned to the user is Administrator, then whenever the user first 

signs in they are presented with the Metadata Manager UI. 

Group Assignment Considerations 
A common practice, whether using Native/LDAP or External Authentication is to not depend 

upon these authentication modes to provide proper group assignment.  This is because, those 

systems are managed by other authorities and are generally not maintained in order to group 

users so that group assignments logically map. 

 

Instead, it is common to simply use the default group assignment, so that by default, any user is 

given the Guest group when logging the first time or when created.  By default, Guest group is 

assigned to the Published configuration.  In this way, one controls the default presentation to new 

users, and it is based on the Metadata Explorer UI and in a controlled default configuration. 

 

Once the user’s true groups and responsibilities are identified, further groups are assigned to the 

user.  Note, the considerations for multiple group assignments. 

Concurrent User Management 
A Oracle Metadata Management (OMM) license may include licensing for both named and 

floating concurrent users.  E.g., if a license provides 10 named and 5 floating users, then up to 10 

users may be set as named users and thus can always log in, and the rest of the users are 

considered floating, where only 5 can sign on concurrently. 

Determining number of users available 
1. Sign in to Oracle Metadata Management (OMM) as a user assigned to the group 

Administrator.  

2. Go to Tools -> Administration. 

3. Select the License tab. 

Assigning named users 
1. Sign in to Oracle Metadata Management (OMM) as a user assigned to the group 

Administrator.  

2. Go to Tools -> Administration. 

3. Select the Users tab. 

4. Click on the user in the list. 

5. Select the Named User checkbox.  

6. Click on Save. 

Assigning concurrent (floating) users 
If a user is defined as a named user: 

1. Sign in to Oracle Metadata Management (OMM) as a user assigned to the group 

Administrator.  

2. Go to Tools -> Administration. 

3. Select the Users tab. 
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4. Click on the user in the list. 

5. Uncheck the Named User checkbox.  

6. Click on Save. 

Remember, all users not explicitly named are considered floating. 

Setting user inactivity logout duration 
The system automatically logs a user out after a certain duration of time.  This duration is 

measured in minutes and may be controlled from the Metadata Manager UI: 

1. Sign in to Oracle Metadata Management (OMM) as a user assigned to the group 

Administrator.  

2. Go to Tools -> Administration. 

3. Select the Users tab. 

4. Click on the number of minutes (15, 30, 45, 60 or 90) of inactivity before logout. 

User Statistics and Server Audit Log 
All user logins, login attempts (rejected) and object creation/update/delete actions are recorded in 

a Server Audit Log.  To download this log to a CSV file: 

1. Sign in to Oracle Metadata Management (OMM) as a user assigned to the group 

Administrator.  

2. Right click on a repository level object (e.g., entire repository, folder or model) in the 

Repository Panel that you wish to report against. 

3. Select More Download Audit Log. 

Review System Logs 
1. Sign in to Oracle Metadata Management (OMM) as a user assigned to the group 

Administrator.  

2. Go to Tools -> Administration. 

3. Select the Log tab. 

Administer Scheduled Tasks 
One may schedule the automatic harvesting of models.  This administrative function allows 

administrative users to manage these schedules centrally. 

  

1. Sign in to Oracle Metadata Management (OMM) as a user assigned to the group 

Administrator.  

2. Go to Tools -> Administration. 

3. Select the Schedules tab. 

Administer Custom Attributes 
One may customize the Repository to include custom attributes (like user defined properties) 

which will then be associated with any specific object type (e.g., folder, model, entity, column, 

or configuration, etc.). 
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1. Sign in to Oracle Metadata Management (OMM) as a user assigned to the group 

Administrator.  

2. Go to Tools -> Administration. 

3. Select the Attributes tab. 

Add a new custom attribute 
1. Sign in to Oracle Metadata Management (OMM) as a user assigned to the group 

Administrator.  

2. Go to Tools -> Administration. 

3. Select the Attributes tab. 

4. Click on the Add action in the header. 

5. Provide the Name of the custom attribute. 

6. Select the object type to assign the custom attribute to. 

7. Select the data type for the custom attribute. 

8. Optionally provide a default value. 

Remove a custom attribute 
1. Sign in to Oracle Metadata Management (OMM) as a user assigned to the group 

Administrator.  

2. Go to Tools -> Administration. 

3. Select the Attributes tab. 

4. Select the custom attribute to be removed. 

5. Click on the Add action in the header. 

Update the value of a custom attribute for a repository level object 
1. Sign in to the Repository as a user with Update privileges to the object you wish to 

update the value a custom attribute to. 

2. Select the object in the Repository Panel  

3. Click on the custom attribute value in the Properties Panel. 

4. Provide a value for the custom attribute. 

5. The value is automatically committed once you leave the edit box. 

6. You may edit longer custom attributes (like a description) in the edit box at the bottom of 

the Properties Panel. 

Administer Licenses 
1. Sign in to Oracle Metadata Management (OMM) as a user assigned to the group 

Administrator.  

2. Go to Tools -> Administration. 

3. Select the Licenses tab. 

4. Here you may Upload a New License or Download the License Information required 

when requesting a new license. 

Administer the database 
Many of the common database management tasks may be performed from the Metadata Manager 

UI without the need to connect directly to the database server. 
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1. Sign in to Oracle Metadata Management (OMM) as a user assigned to the group 

Administrator.  

2. Go to Tools -> Administration. 

3. Select the Licenses tab. 

Run database maintenance 
1. Sign in to Oracle Metadata Management (OMM) as a user assigned to the group 

Administrator.  

2. Go to Tools -> Administration. 

3. Select the Licenses tab. 

4. Click on the Run Maintenance button. 

Clear database cache 
Certain repository objects are cached for faster retrieval. You may clear the cache so that the 

Repository will load these objects from the database the next time they are accessed. 

 

1. Sign in to Oracle Metadata Management (OMM) as a user assigned to the group 

Administrator.  

2. Go to Tools -> Administration. 

3. Select the Licenses tab. 

4. Click on the Clear Cache button. 

5. Select which cache to clear. 

Run performance script 
1. Sign in to Oracle Metadata Management (OMM) as a user assigned to the group 

Administrator.  

2. Go to Tools -> Administration. 

3. Select the Licenses tab. 

DB configuration 
See Server Installation. 

System backup 
Regular backups of contents of the repository are highly recommended.  When backing up 

Oracle Metadata Management (OMM), there are both the database and the model cache that 

should be backed up.  While all the contents of the repository which are used to present metadata 

for analysis are stored entirely in the database, a cache of what is harvested (to be used when 

exporting or when populating a glossary from a harvested model, as well as information 

maintained to support incremental harvesting) is maintained on the application server machine in 

the ProgramData folder.  One should be sure to back up the contents of that folder as part of 

regular backups. 

Installation 
For installation and configuration details, please refer to the ReadMe document. 
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HostInfo file and licensing 
When requesting a license, a HostInfo.xml file generated for the server machine is required.  One 

is located in the root of the installation directory after install of the Oracle Metadata Management 

(OMM). 
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Troubleshooting 

General troubleshooting steps 

UI troubleshooting steps 
For any issue where you see something unexpected in the UI, please perform the following steps: 

1. Stop Oracle Metadata Management (OMM) service on the server machine and run Oracle 

Metadata Management (OMM) as a desktop app by selecting Start -> All Programs -> 

Meta Integration ->  Server Restart.   

2. Close all instances of the web browser you are using. 

3. Check that the browser and Adobe Flash are updated to the latest patches. 

4. Open an instance of the browser. 

5. Clear the cache and recent history on the web browser. 

6. Close all instances of the web browser. 

7. Open the browser and reconnect to Oracle Metadata Management (OMM). 

Bridge troubleshooting steps 
For any issue where you see something unexpected when importing a model, please perform the 

following steps: 

1. Review the tool tips (help) for the bridge in general and each bridge parameter 

individually to ensure that the bridge is being used correctly. 

2. Open the import (or export) log and be sure to select Show: All.  Then, make any 

changes specified in the log messages. 

3. Stop Oracle Metadata Management (OMM) service on the server machine and run Oracle 

Metadata Management (OMM) as a desktop app by selecting Start -> All Programs -> 

Meta Integration ->  Server Restart.  If this step resolved the problem, then refer to the 

Oracle Metadata Management (OMM) Readme and be sure you have followed: 

a. Step (3.) in section (5.1) “Default install on Windows with bundled Tomcat” 

b. All the steps in section (6.) “MIMB (Metadata Harvesting)”. 

4. Clear the import cache directories on the application server machine at: 

C:\ProgramData\Meta Integration\data\MIMB\cache 
5. Change the system preferences to Print Debug Log Messages, run the bridge again and 

review the log messages. 

Configuration troubleshooting steps 
For any issue where you see something unexpected and neither of the above have resolved the 

issue: 

1. Ask the system administration staff to review the installation and configuration steps in 

the ReadMe, especially the sections covering installation and testing of the Application 

Server and software. 

Reporting issues 

Creating a backup 
In order for Support staff to reproduce an issue you report, please be sure to back up the relevant 

portion of Oracle Metadata Management (OMM).  In general, it is best to create a backup of the 

configuration containing the model or models where the problem was observed. 
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To generate a backup: 

1. Sign in to the Repository as a user with full access privileges to all of the models and 

configurations contained with the backup scope. 

2. Select the root object in the Repository Panel which will be backed up.  Remember, all 

contained models and configurations will also be backed up. 

3. Right-click and select More -> Backup. 

4. Browse for a directory on the server machine where you wish to create the backup.  If 

you specify a directory which does not exist, Oracle Metadata Management (OMM) will 

create it when backing up. 

5. If the issue is related to users, groups, security role assignments or other system 

configuration settings, be sure to select the check box for Backup advanced system 

objects like Groups 
6. Be sure to select the check box for Backup all versions of models Content. 

7. Click on the Backup button. 

Restoring a Backup 
To restore a backup: 

1. Sign in to the Repository as a user with full access privileges to all of the models and 

configurations contained with the backup scope. 

2. Create and empty folder in the Repository Panel which will be used to restore the backed 

up models.  Remember, all contained models and configurations will also be restored. 

3. Right-click and select More -> Restore. 

4. Browse for a directory on the server machine where you created the backup before 

5. Click on the Restore button. 

 


